TFTP PXE File Not Found after Upgrade



  • Been beating my head against a wall for too long on this one. Upgraded from .33b to 1.0 Everything went swimmingly until TFTP time. Specifically if I try and connect from a network computer I get:

    Upgrade to 1.0.0 to ensure that my Fog TFTP settings are in line
    I’ve changed my fog management password to reflect the local user password, and I’ve tested FTP to ensure that I can connect via FTP

    My tftpd-hpa looks as such:

    TFTP_USERNAME="fog"
    TFTP_DIRECTORY="/tftpboot"
    TFTP_ADDRESS="10.1.2.2:69"
    TFTP_OPTIONS="-s"
    

    If I try and connect from my desktop to the TFTP server I get:

    F:\>tftp 10.1.2.2 GET undionly.kpxe
    Timeout occurred
                       Connect request failed
    

    (but I can ping, http and SSH to the server from my desk)

    I’ve ensured that TFTP-HPA is running and pointed at the right spot:

    root      3258  0.0  0.0  14808   304 ?        Ss   13:36   0:00 /usr/sbin/in.tftpd --listen --user fog --address 10.1.2.2:69 -s /tftpboot
    

    The TFTP boot folder is owned by fog:

    drwxr-xr-x   3 fog  root 4.0K 2014-05-13 11:41 tftpboot
    

    This is on Ubuntu 10. Obviously I’m missing something stupid, but I can’t figure out what.


  • Developer

    @AllenP, post: 41471, member: 24073 said:

    I don’t know if you found a solution to this but after goggling the problem for days and days. I thought to myself what could have changed between .32 and 1.2. So I looked at the boot setting in the DHCP server and saw that the file name had changed from .32 to 1.2 so make sure you check DHCP settings edit option 067. I really hope this helps someone else bc it drove me nuts. I wish that someone would big red flags and fireworks going off anything to draw more attention to the change in the file name.
    %(#444444]Open up the scope of your DHCP server and edit these settings)[

    • Edit option 066 and enter the IP address of your FOG server.
    • Edit option 067 and put a string value of undionly.kpxe] or undionly.kpxe.INTEL

    Part of the installation script that tells you that you need to update your DHCP Scope.



  • I don’t know if you found a solution to this but after goggling the problem for days and days. I thought to myself what could have changed between .32 and 1.2. So I looked at the boot setting in the DHCP server and saw that the file name had changed from .32 to 1.2 so make sure you check DHCP settings edit option 067. I really hope this helps someone else bc it drove me nuts. I wish that someone would big red flags and fireworks going off anything to draw more attention to the change in the file name.
    %(#444444]Open up the scope of your DHCP server and edit these settings)[

    • Edit option 066 and enter the IP address of your FOG server.
    • Edit option 067 and put a string value of undionly.kpxe] or undionly.kpxe.INTEL

  • Developer

    DeadTurtle, do you find that using DNSMASQ on your version of linux causes any issues with the boot file?

    I’m using an older version of linux and that might be my entire problem, its more or less just for testing purposes anyway, but I have found that while issuing the boot command dnsmasq wants to append .0 to the file making the file either undionly.kpxe.0 or undionly.0

    I can circumvent this issue with a symlink

    sudo ln -s undionly.kpxe undionly.0
    

    but I am curious to find if there is a better way to serve the file without symlinking, and figuring out WHY dnsmasq appends said 0.


  • Senior Developer

    Found out the issue you Jaymes, and deadturtle were/are having with switching to undionly.kpxe in the scope options is simply a numerical setting of the number of characters option 67 can contain. Novel 6.5 (not SP2) will not allow characters over 12 in the options field. This means (undionly.kpxe at 13 characters) does not fit the scope. So you where on the right track of having to create a symbolic link. Best suggestion I can come up with is change the name from undionly.kpxe to ipxe.kpxe. Or do so with a symbolic link.

    Thanks to deadturtle for showing the issue and knowing about this character limitation.

    Hope this helps.


  • Developer

    http://fogproject.org/wiki/index.php/Using_FOG_with_an_unmodifiable_DHCP_server/_Using_FOG_with_no_DHCP_server#DNSMASQ_settings_for_iPXE

    this service offers a proxy dhcp for booting during iPXE/PXE booting and help to resolve the tftp server and the boot file name. I thought the cause of the issue was the ip address helpers and the funky way my network is laid out. Glad to know it’s Novell!


  • Senior Developer

    [S]Is your scope options setup? Meaning, do you have options 67/66 set to point at the FOG Server IP and undionly.kpxe file?[/S]

    Disregard!



  • Ok I figured it out (Finally!) Netware 6.5 DHCP can’t/doesn’t pass the undionly.kpxe var correctly. Not sure if its because our scope is messed up, or if there is something deeper that is causing the issues… I bounced a temporary Windows DHCP server and things lit up (phew!)



  • Yeah that was my thought, but its still not working. Strangely I CAN tftp from a workstation on the same vmware host as the FOG server, but still not from my workstation

    @TE I’ve searched google/forums pretty hard, and I’ve verified all the steps in the Wiki.



  • I had the same problem.

    I installed PHPMyadmin, exported seperate SQL databases that I wanted to keep (images and host for me) and did a clean install of 1.0.1. Not a problem anymore.



  • I’m beginning to think the issue is either with Ubuntu or with our network environment. I installed a squeaky clean empty Fog server onto Ubuntu 14. I still had 1.0.0 in my folder, but I upgraded to 1.0.1 and I am getting the exact same errors. To re-iterate out-of-the-box Ubuntu install, clean Fog install 1.0.0 -> 1.0.1 can’t TFTP from my desktop to the client, can’t PXE boot from a workstation.

    (Prevision version was Ub 10 with .33b -> 1.0.0)

    @Wolf if I restart I get: tftpd-hpa start/running, process 24585
    -D


  • Developer

    what happens when you do a:

    sudo restart tftpd-hpa
    

    ???


  • Senior Developer

    F:>tftp 10.1.2.2 GET undionly.kpxe
    Timeout occurred
    Connect request failed

    That’s the part i’m worried about. It sounds to me like tftpd-hpa server isn’t working.



  • I tried changing it to 777 across the board with no effect.
    -D



  • what are permissions on the actual undionly.kpxe file which is in the tftpboot folder?

    make sure its has read and execute for anyone. the pxe client doesnt connect as fog, it connects to the tftp service as anonymous, and the tftp service needs to be able to read the endionly.kpxe file


Log in to reply
 

322
Online

38724
Users

10553
Topics

99907
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.