Can no longer upload from virtualbox image

  • I apologize now if there is a already a posting answering my question but I haven’t been able to find it.
    I have been using fog .32, running dhcp, on a laptop so I can image on an isolated network, and making my image in Virtualbox and uploading perfectly. I am currently in the process of integrating a fog server into my network to eliminate a lot of the manual process of imaging.

    What I am using in my new setup:
    Ubuntu 12.04 server
    Fog 1.0.0

    I can can boot a normal workstation and register, schedule tasks, etc. When I try to boot the virtualbox (template machine) into FOG I get:

    [CODE]Configuring (net0 00:50:56:37:df:20… Error 0x040ee119 (http://FATAL: INT18: BOOT FAILURE[/CODE]

    Every once in a while (very rarely) it will boot to fog. I was able to register the VM but it will not upload the image.

    Is there something I missed to allow a VM to work with FOG?

  • All of you using virtual box, the Files I’m providing labeled with ipxe.kpxe do work with Virtual Box.

  • Hi There,

    I have been looking at FOG this week (for the first time). I have installed FOG Server on Ubuntu Desktop 14.04.

    I have current success with a IBM think pad S440, this is currently uploading a image “YAY”


    I have a virtual box linux system, I was able to PXE boot fine initially, I performed a quick registration successfully, then it rebooted and stops with the Error 0x040ee119.

    It pauses "Configuring (net0 xxxxxxxxxxxxxx)

    then moves onto Error 0x040ee119


    I deleted the virtual boxes host registration from the DHCP to see if that made a difference, it didn’t

    Hope this helps with the current issue…




  • I noticed FOG 1.0.1 was posted so I ran the update and it booted initially but the kernel was not able to see my machine because of what I believe was an issue between the kernel and VirtualBox ([url][/url]).

    I remember I was using a vmware kernel on my old FOG server (running .32) so I copied the Kernel over to the new server and set the Host Kernel for my template machine and tried FOG again. It booted again and began to load the kernel but then froze. I rebooted, FOG booted again and began to load the kernel and got a little further and froze again. I decided to reboot again, because what the heck another reboot couldn’t hurt. This time… no go, I got the BOOT FAILURE message.

    I changed the Kernel back to bzImage and was able to boot but it went back to searching for /dev/sda. I’m guessing now that the problem, once I get it booted, is getting a kernel that will work.

    [url="/_imported_xf_attachments/0/768_can’t see partitions-VBOX.png?:"]can’t see partitions-VBOX.png[/url]

  • I downloaded the latest FOG and the the first time I tried to upload from the VM it proceeded past where it was hanging up and appeared to be getting ready to upload. Partclone came up and flashed an error and then rebooted. After reboot, it went back to giving me boot errors. I kept rebooting hoping that it would proceed again so I could get the exact wording and after 8 tries it went through again. the wording is:

    [CODE]Starting to clone device (/dev/sda1) to image (/tmp/pigz1)
    Clone: open /dev/sda1 error[/CODE]

    Then once again it rebooted.

    My apache log came up with:
    [CODE]tail: cannot open ‘/opt/fog//log/multicast.log’ for reading: No such file or directory
    [Tue May 13 07:56:44 2014] [notice] caught SIGTERM, shutting down
    [Tue May 13 07:56:45 2014] [notice] Apache/2.2.22 (Ubuntu) PHP/5.4.9-4ubuntu2.4 configured – resuming normal operations
    [Tue May 13 07:57:26 2014] [error] [client] PHP Fatal error: Call to a member function get() on a non-object in /var/www/fog/lib/pages/DashboardPage.class.php on line 30, referer:[/CODE]

    I also checked config.php and confirmed that I had set the password.


  • Not sure what you did with this latest revision but I so far have been able to start an upload.

  • Developer

    Good morning!

    Unfortunately its not a good morning for the new update for fog. 😞

    [QUOTE]Configuring (net0 xx:xx:xx:xx:xx:xx)… Error 0x040ee119[/QUOTE]

    The new update intermittently works on the VM and a Dell D610. The VM was working well enough in the evening but this morning I can only get it to boot to fog about 1/8 times. BUT this is[B] greatly improved from yesterday[/B] being 1/30+.

  • Developer

    Shhhh…Left the password blank. I only use this machine for Fog.



    define(‘DATABASE_TYPE’, ‘mysql’); // mysql or oracle
    define(‘DATABASE_HOST’, ‘localhost’);
    define(‘DATABASE_NAME’, ‘fog’);
    define(‘DATABASE_USERNAME’, ‘root’);
    define(‘DATABASE_PASSWORD’, ‘’);

    BUT it is working on a VM, so I’m leaning towards it will work in the morning.

  • Check your mysql password in commons/config.php If it’s not set properly, it will fail as you’re seeing there, because it returns as not valid.

  • Developer

    LOL Couldn’t wait!


    File does however exist!

    [CODE]fog@fog-Latitude-D630:/$ locate boot.php

    This occurred on first boot after update. Then next the 0x040ee119 error. Then it booted to the bzImage 5 times after that. SO for giggles I deleted the Lease from the DHCP server for that IP and it still worked after that.

    This was perform on a VM, so I will test physical HW in the morning! Can’t wait!
    Thanks Tom!!!


  • Developer

    Updating in the morning and will report back asap!

  • Thanks for the reply Tom,

    The last FOG install was Friday (may 9th) from:
    If there is was a newer update I will try updating my install.

    I tried:
    Kernel Issues: [url][/url]
    No change.

    The only thing in my apache logs is:
    [CODE][Sun May 11 06:49:11 2014] [notice] Apache/2.2.22 (Ubuntu) PHP/5.4.9-4ubuntu2.4 configured – resuming normal operations

    Currently running:
    FOG Version: 1.0.0
    Ubuntu 13.04

  • Try 1667 and let me know if you have issues. I found a few things, though I can’t tell you what they were, I’m going to try “breaking” undionly.kpxe again to see what exactly was causing the problems.

  • I’m getting the same error only using vmware workstation

  • Developer

    Thank goodness I’m not the only one! This is occurring on all my machines now. Clients are still all getting DHCP addresses and nothing has changed on our windows server. I am getting the same issue after the uninstall of 0.33b and install to v1.0. I keep running the update hoping for a patch but no fix.

    I thought it was odd that my [FONT=Ubuntu][COLOR=#555555]FOG_PXE_IMAGE_DNSADDRESS == [/COLOR][/FONT]I’m not sure why that is but I do not recall that address being a local address.

    Yes, same symptoms as above. It will boot to the bzImage/bzImage32 every ~1/30 times.

    See pics for Error, TFTP settings, Install log, and dhcp error on windows server.

    Apache2 log repeats:
    [Mon May 12 11:47:36.492663 2014] [:error] [pid 17916] [client] PHP Warning: date_default_timezone_get(): It is not safe to rely on the system’s timezone settings. You are required to use the date.timezone setting or$…$ set date.timezone to select your timezone. in /var/www/fog/commons/system.php on line 11

    Yes I have the right timezone and the time is correct.
    [CODE]fog@fog-Latitude-D630:/var/log/apache2$ date
    Mon May 12 11:56:00 EDT 2014

    PHP Version:
    [CODE]fog@fog-Latitude-D630:/var/log/apache2$ php -v
    PHP 5.5.3-1ubuntu2.3 (cli) (built: Apr 4 2014 01:10:38)
    Copyright © 1997-2013 The PHP Group
    Zend Engine v2.5.0, Copyright © 1998-2013 Zend Technologies
    with Zend OPcache v7.0.3-dev, Copyright © 1999-2013, by Zend Technologies

    Other References: [url][/url]

    See below for OS and fog version.

    [url="/_imported_xf_attachments/0/735_Error_0x040ee119.png?:"]Error_0x040ee119.png[/url][url="/_imported_xf_attachments/0/736_TFTP settings.png?:"]TFTP settings.png[/url][url="/_imported_xf_attachments/0/737_DHCP.txt?:"]DHCP.txt[/url][url="/_imported_xf_attachments/0/738_Install_log.txt?:"]Install_log.txt[/url][url="/_imported_xf_attachments/0/739_system.php?:"]system.php[/url]