Error 0x040ee119 FOG v1.0.0 Centos 6.5



  • Hi! I am brazilian and my english is not very good. …
    I’m with FOG 1.0.1 xenserver vm installed on CentOS 6.5 and PXE menu does not work, displays the following error: Error 0x040ee119
    What should I do?

    [IMG]http://i.imgur.com/M86eDsd.jpg[/IMG]


  • Developer

    i believe we have found a solution to this problem
    [url]http://fogproject.org/forum/threads/040ee119-error-on-boot.10493/[/url]



  • Hey guys. I’m new to this forum as well. I’m getting this same exact error, but only for some of my hardware (maybe mainly the realtek nics? could be a lenovo thing too /shrug). I’ve tried several different kernels (some official and then the ones in Tom’s signature) and BIOS settings. I was able to pxe boot from a Dell E5500 just fine throughout the day today, but not on my Lenovo hardware. I’m getting valid responses on my DHCP server (Windows Server 2008) for the realtek/lenovo cards, but it terminates at error 0x040ee119.



  • [quote=“marquinhoxd, post: 26788, member: 24088”]Hi! I am brazilian and my english is not very good. …
    I’m with FOG 1.0.1 xenserver vm installed on CentOS 6.5 and PXE menu does not work, displays the following error: Error 0x040ee119
    What should I do?

    [IMG]http://i.imgur.com/M86eDsd.jpg[/IMG][/quote]

    I am getting the exact same error Marquin. I have been running FOG for a long time now, but v1.0.1 has broken. :)

    I have checked my DHCP settings to make sure everything was ok, and it is. Nothing changed on the settings and the DHCP logs show that the DHCP server is being contacted:

    10,05/14/14,16:09:32,Assign,10.28.0.32,5C260A57E7D4,3571930892,0,

    I am also still looking for the solution.

    -=Lon=-


  • Senior Developer

    Question 1: Have you read the WIKI? I realize it’s inEnglish, but if you follow the steps, it works.

    Question 2: The error being reported, is saying it can’t configure the device. Do you have a DHCP server issuing IP Addresses?

    Question 3: Is this working properly?

    Question 4: Have you tried a cold reboot (i.e. power off the system for a few seconds, turn it back on?)

    From what I can establish, your Server is not passing DHCP requests at all. It gets the initial TFTP information for network boot, but nothing is actually handing out DHCP after this point.



  • [quote=“BPSTravis, post: 26791, member: 22444”]According to the iPXE forums that is the new error message for DHCP failing. I myself have never encountered that error.

    Is there a switch between the FOG server and the client, if so has this server worked previously to image clients?[/quote]

    'm noob … I am now starting to use the FOG, it is actually the first install mode! I make all install mode, the fog does not work … only with version 1.00 which is ok.
    And I intend to use CentOS. Rather install FOG on Arch Linux or FreeBSD, but not found documentation. Can you suggest me a tutorial that works on CentOS 6.5? I am using CentOS 6.4 Tutorial Wiki, but always after installed this error occurs 0x040ee119



  • [quote=“Marcos Marti, post: 26790, member: 24067”]This error indicates that iPXE timed out while attempting to autoconfigure a network adapter

    Its the fog server a VM or the destination PC a VM?[/quote]

    CentOS 6.5 (Fog-Server) VM - XenServer —> PC Client - LAN



  • went to the host and chose what image i wanted associated with it. Then went to basic task and chose to create a download task. Under advanced settings I have checked Schedule instant deployment.


  • Developer

    what exactly did you do when you "Went to image"
    did you try to use “quick image” from the ipxe boot screen?
    have you created an image profile and associated it with that computer after registering it with fog?



  • Okay I did that. Was able to register a host just fine. Went to image and go to the area where ipxe says its configuring the mac address then machine just skips imaging and logs in as normal.

    the following is in my apache log file

    [Thu May 08 14:23:55 2014] [error] [client 172.16.4.2] PHP Fatal error: Call to a member function get() on a non-object in /var/www/fog/status/freespace.php on line 39, referer: [url]http://172.16.2.32/fog/mana$[/url]


  • Developer

    Instead of checkout run an update for SVN and install again. It will use the same settings you used the first time but update to the latest release.

    One of the last few releases had some issues with the init files but that is resolved now.

    [CODE]svn up /opt/fog_1.0.0[/CODE]

    [FONT=Arial][COLOR=#000000][SIZE=12px]then[/SIZE][/COLOR][/FONT]

    [CODE]cd /opt/fog_1.0.0/bin/
    ./installfog.sh[/CODE]



  • I’m running version 1.0.0 follwed the steps to install from here: [url]http://community.spiceworks.com/how_to/show/78110-fog-1-0-0-on-ubuntu-server-14-04[/url]

    This is on any host I try


  • Developer

    What revision are you on, can you try the latest?

    Is this on any host you try or just one host/model of machine in particular?



  • I’m getting the same error message as [URL=‘http://fogproject.org/forum/members/marquinhoxd.24088/’][SIZE=11px][COLOR=#969696]marquinhoxd[/COLOR][/SIZE][/URL]. From what I noticed and maybe it was just a fluke but the network card didn’t even seem to turn on and that’s why it wasn’t getting an IP.

    If I boot into windows network is fine, it’s only when trying to establish a connection with ipxe that everything is screwed up.


  • Developer

    According to the iPXE forums that is the new error message for DHCP failing. I myself have never encountered that error.

    [url]http://forum.ipxe.org/showthread.php?tid=7142[/url]

    Is there a switch between the FOG server and the client, if so has this server worked previously to image clients?



  • This error indicates that iPXE timed out while attempting to autoconfigure a network adapter

    Its the fog server a VM or the destination PC a VM?


Log in to reply
 

401
Online

38937
Users

10696
Topics

101490
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.