FOGFTP: Failed to connect. Host xxx.xxx.xxx.xxx, Error: Undefined Index CurrentUser



  • [COLOR=#333333]OS: Ubuntu 12.04 LTS[/COLOR]
    [COLOR=#333333]Fog Version: 0.33B[/COLOR]
    [COLOR=#333333]I took all of the defaults except the DHCP server, which I left OFF since I already have a DHCP server on the network. I also left the password for SQL blank.[/COLOR]
    [COLOR=#333333]I’ve just configured a new FOG installation on a VM. My old install would not work on the latest hardware we have received so I decided to try the Beta version to see how that works. Well, it works great until it tries to move the image that was uploaded from the temp location to the permanent location. I then get this error: “FOGFTP: Failed to Connect. Host : 192.168.127.101, Error: Undefined Index: currentUser”[/COLOR]
    [COLOR=#333333]I’m a NOOB when it comes to UNIX so please give detailed step by step instructions for any commands you want me to try.[/COLOR]
    [COLOR=#333333]Thanks in advance![/COLOR]



  • I’m having this issue also. Receiving the “[COLOR=#333333]Error: Undefined Index: currentUser[/COLOR]” after uploading an image.

    FOG_TFTP_PXE_KERNEL_DIR = /var/www/html/fog/service/ipxe/
    FOG_TFTP_HOST = Server’s IP address
    FOG_TFTP_FTP_USERNAME/PASSWORD = same login as fog user on server
    vsftpd seems to be installed correctly

    Unsure if this is related or not but under “Image Management” it’s not reading “Image Size:ON SERVER” like it did before on Ubuntu. The image files are there and they match the definitions. I can even deploy the images.

    OS: CentOS 6.4
    FOG Version: 1.0.1



  • Oh…i didnt know after each checkout i had to upgrade FOG.

    It works great thanks !


  • Developer

    if you had that line in the file, you had a version installed prior to version 1525, which was release 2 days ago. but your post says that you installed the latest yesterday. was this an upgrade install, or a fresh install?



  • Ok, the option was in the file, i deleted it but i cant start, stop, or restart the service.

    I rebooted the machine and it’s the same.

    No output, no process.


  • Developer

    in /etc/vsftpd.conf is there a line for seccomp_sandbox=no ?
    if there is remove it and restart the service
    if there is not add it and restart the service



  • nop, the service is not running.Which options can i edit ?


  • Developer

    can you veify that the ftp service is running, and you can connect to it? there’s a bit of an issue with vsftpd that sometimes requires an edit to it’s config



  • ok, vsftpd is not properly installed. And the daemon is not started and i cant start it. But the binary is present… When i try to remove and reinstall i get these errors messages in loop and nothing is done :

    [CODE]root@fog-project:# aptitude remove --purge vsftpd

    insserv: Starting FOGScheduler depends on rc.local and therefore on system facility $all' which can not be true! insserv: Starting FOGMulticastManager depends on rc.local and therefore on system facility$all’ which can not be true!
    insserv: Starting FOGImageReplicator depends on rc.local and therefore on system facility `$all’ which can not be true!

    Blablabla

    insserv: exiting now without changing boot order!
    update-rc.d: error: insserv rejected the script header
    dpkg: erreur de traitement de open-iscsi (–configure) :
    le sous-processus script post-installation installé a retourné une erreur de sortie d’état 1
    Des erreurs ont été rencontrées pendant l’exécution :
    open-iscsi[/CODE]

    Any idea ? It’s a clear install of debian, my /images is an iscsitarget mounted correctly, the rights and owners are properly set!

    Thank you



  • Hi, thank you.

    The TFTP_PXE_KERNEL_DIR is ok, i am on debian 7. The username and password are ok.

    I am on FOG 0.33b (svn checkout this morning). The IP address is correct too.

    In error.log, i have this :

    [CODE]ls: cannot access /images/DoubleBootrxxmath: No such file or directory
    ls: cannot access /images/DoubleBootrxxmath: No such file or directory[/CODE]

    It’s FTP related ?


  • Senior Developer

    Verify the TFTP_PXE_KERNEL_DIR is set appropriately. On Ubuntu it should point at: /var/www/fog/service/ipxe/ On Redhat based OS’s it should be: /var/www/html/fog/service/ipxe/.

    Also verify that the TFTP_FTP_HOST IP address is the same as your FOG Server. Verify that the TFTP_FTP_USERNAME and TFTP_FTP_PASSWORD are set correct. If you’re having issues on the imaging side of it, verify that the relevant Storage Nodes Management Username and Password are set correctly.



  • Hi, i’ve got the same error, i launched a checkout to obtain the latest version of fog 0.33b but it’s the same.

    What could i do ? Is there any log in relation ?

    Thx


  • Developer

    try updating to the latest release, i suspect this was just fixed


  • Developer

    Check the fog settings - TFTP Server - FOG_TFTP_PXE_KERNEL_DIR

    Should read exactly as below:

    [CODE]/var/www/fog/service/ipxe/[/CODE]


Log in to reply
 

397
Online

38937
Users

10696
Topics

101490
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.