Fog 0.33b Stability and upgrade questions


  • Developer

    Good morning,

    I have been using 0.32 for about 2 years and it has been working like a dream. I manage a school district’s 700+ computers and every single one of them at this point are now all imaged by FOG. 0.32 is extremely stable. I see that 0.33b-r1431 is now out. I was just wondering the progress of 0.33 and its stability. Can I download this, upgrade to 0.33b-r1431, keep my old images, and keep the inventory list already in 0.32


  • Developer

    Yep just switched to:
    [FONT=Ubuntu][COLOR=#555555]FOG_TFTP_PXE_KERNEL == [/COLOR][/FONT]bzImage32
    [FONT=Ubuntu][COLOR=#555555]FOG_PXE_BOOT_IMAGE == [/COLOR][/FONT]init_32.xz

    and worked without issue.

    Update:
    crap looks like r1439 has fixed this. With this update you no longer need to select the 32bit or 64bit image.


  • Senior Developer

    For that system you’ll need to boot through the init_32.xz and bzImage32 files. These must be set through the FOG Configuration pages->FOG Settings->TFTP Server->FOG_TFTP_PXE_KERNEL and FOG_PXE_BOOT_IMAGE

    All 64 bit systems will boot just fine under 32 bit, but 32 bit (as you can see) will not boot up under 64 bit.


  • Developer

    I understand you can not make every situation for all the different OS installs. You are corrected I did find that there is a specific statement to disable the firewall in the documentation. Apologizes…

    However, I have ran your update for both the 64-bit and 32-bit.
    [QUOTE]# cd /var/www/fog/service/ipxe

    wget -O bzImage --no-check-certificate [url]https://mastacontrola.com/fogboot/kernel/bzImage[/url]

    wget -O bzImage32 --no-check-certificate [url]https://mastacontrola.com/fogboot/kernel/bzImage32[/url]

    #var/www/fog/service/ipxe$ ls
    advanced.php bg.png boot.php bzImage bzImage32 bzImage32.orig.482014 bzImage.orig.482014 init_32.xz init.xz memdisk memtest.bin
    [/QUOTE]

    Then try to register the DELL LATITUDE D610 and I receive “[URL=‘https://www.dropbox.com/s/a8imm2elqnt2qx3/IMG_20140408_144249.jpg’]This kernel requires an x86-64CPU, but only detected an i686 CPU Unable to boot - please use a kernel appropriate for your CPU[/URL].”

    I did try a Dell D630 and it when right to the registration. Also, worked with HP DC5700, HP DC7800, Dell E6400. Which are all 64-bit processors.


  • Senior Developer

    [quote=“Wolfbane8653, post: 25097, member: 3362”]THAT WAS IT!!!

    So there is an issue from the install that doesn’t make an exception in the firewall. Please make this edit to the .sh file.

    Update:

    sudo ufw allow tftp

    sudo ufw allow http[/quote]

    Part of the documentation tells you to turn off the firewall first. We don’t know what ubuntu is going to be using in the future so it’s kind of hard to keep up to date. You, at the individual level, should be either disabling entirely, or establishing the proper firewall rules rather than try to have our scripts do this work for you.

    Read the wiki in my signature to understand what and why my kernel’s DO support i686 CPU’s. You will need the bzImage32 file though.


  • Senior Developer

    YES IT DOES


  • Developer

    Also Kernel 3.14.0 does not support i686 CPU for a DELL Latitude D610.


  • Developer

    THAT WAS IT!!!

    So there is an issue from the install that doesn’t make an exception in the firewall. Please make this edit to the .sh file.

    Update:

    sudo ufw allow tftp

    sudo ufw allow http


  • Senior Developer

    maybe a firewall blocking the tftp port?

    [code]sudo ufw disable[/code]


  • Developer

    Ran the following
    [QUOTE]
    #sudo service tftpd-hpa restart
    tftpd-hpa stop/waiting
    tftpd-hpa start/running, process 3282

    #sudo chown -R fog:root /tftpboot
    [/QUOTE]

    Still the same result. I then rebooted the entire Ubuntu machine. Then “TFTP: Timed out” restarted the service and back to the same result of “PXE-T01: File not found”


  • Senior Developer

    You likely need to restart the tftp server on the ubuntu machine: or verify permissions are correct for tftpboot:
    [code]sudo chown -R fog:root /tftpboot[/code]


  • Developer

    Tom,

    I have uninstalled 0.32 using:
    [QUOTE]
    #Uninstall FOG
    #remove service
    sudo rm /etc/init.d/FOGImageReplicator
    sudo rm /etc/init.d/FOGMulticastManager
    sudo rm /etc/init.d/FOGScheduler

    #delete fog database
    sudo mysql
    #(or ‘sudo mysql -p’ if you set a root password for mysql)
    drop database fog;
    quit

    #Remove files
    sudo rm -rf /var/www/fog
    sudo rm -rf /opt/fog
    sudo rm -rf /tftpboot
    sudo rm -rf /images
    [/QUOTE]
    Then downloaded and set up btsync to keep up-to-date with your updates. I then ran the fog_33b/bin/sudo ./installfog.sh
    [QUOTE]OPTIONS:
    –Ubuntu 12.10 install: choice 2
    –What type of installation would you like to do? [N] N
    –What is the IP address to be used by this FOG Server? [10.0.0.252] 10.0.0.252
    –Would you like to setup a router address for the DHCP server? [Y/n] n
    –Would you like to setup a DNS address for the DHCP server and client boot image? [Y/n] y
    –What is the IP address to be used for DNS on the DHCP server and client boot image? [127.0.1.1] 10.0.0.252
    –Would you like to change the default network interface from eth0?
    If you are not sure, select No. [y/N]n
    –Would you like to use the FOG server for DHCP service? [Y/n] n
    –This version of FOG has internationalization support, would
    you like to install the additional language packs? [y/N] n
    [/QUOTE]
    Then on our Window DHCP server we have changed:
    [QUOTE]
    Option 066: 10.0.0.252
    Option 067: undionly.kpxe (from pxelinux.0 --> 0.32)
    [/QUOTE]
    Then updated the Client Kernal to version 3.8.8 Core (Official).

    I grab an old Dell Latitude D610 to register the PC and boot to NIC and I receive:
    [QUOTE]TFTP.
    PXE-T01: File not Found
    PXE-E3B: TFTP Error - File Not found
    PXE-M0F: Exiting Broadcom PXE ROM.
    [/QUOTE]
    I then updated the Client Kernal to version 3.14.0 x86_64(unofficial) and I get the same result.

    Any ideas what I did wrong?

    Update:
    undionly.kpxe is located in /tftpboot so file does exist

    [SIZE=4][B][FONT=Ubuntu][COLOR=#4c68a0]TFTP Server[/COLOR][/FONT][/B][/SIZE]
    [SIZE=13px][FONT=Ubuntu][COLOR=#555555][FONT=Tahoma][COLOR=#141414]FOG_TFTP_TFTP_HOST: 10.0.0.252[/COLOR][/FONT][/COLOR][/FONT][/SIZE]
    FOG_TFTP_FTP_USERNAME: fog
    FOG_TFTP_FTP_PASSWORD: **************
    FOG_TFTP_PXE_CONFIG_DIR: TFTP_PXE_CONFIG_DIR
    FOG_TFTP_PXE_KERNEL_DIR:
    FOG_TFTP_PXE_KERNEL: bzImage
    FOG_KERNEL_RAMDISK_SIZE: 127000
    FOG_PXE_BOOT_IMAGE: init.xz
    FOG_PXE_IMAGE_DNSADDRESS: 10.0.0.252


  • Developer

    This post is deleted!

  • Developer

    Tom,

    I will just uninstall and install 0.33b-r1431. Recommendations from a developer should [B]ALWAYS[/B] be followed. We currently use Windows 7 and Windows XP environment. Re-registering on the client takes a total of 10 seconds so I won’t miss that. I will also image the machines to save the images and upload them after the new install.


  • Senior Developer

    I always recommend a fresh install vs. upgrade, however you can upgrade should you need to.

    There are a lot of changes though, so get things working properly in your environment, you’ll need to be aware of them.

    First, you will likely have to remove all tasks in your current database. Open MySQL and run the statement:
    [code]truncate table tasks;[/code]

    This resets all tasks in the system and makes it usable without throwing a ton of errors. Part of this is we switched from letter codes to numeric Task types.

    Host OSID is now deleted from the hosts table, as the OSID is now kept with the Image itself, so when you transition over, you’ll need to assign the OSID to the Image (IMPORTANT).

    Other than that, everything else should work fine. Upgrading from 0.32 to 0.33, the imaging will now work thanks to Chuck. When you upload over an old image it will update to the latest.

    Best of luck.

    Stability wise, I believe it’s relatively close to 0.32. There are a few things that don’t work so well yet, such as Windows 8 FOG Client doesn’t (always) seem to work properly yet. Other than that, Windows 7, Windows XP, and Linux imaging seems to work perfectly. Not so much dual boot yet, but everything else should be pretty good.


Log in to reply
 

812
Online

38993
Users

10713
Topics

101700
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.