Problems for IP configuration for FOG



  • (translated by google)

    Hi all,
    I have Ubuntu 32bit 12.04 relaunched and given a fixed IP address (192.168.115.20) that system. My router has towards the LAN IP address 192.168.115.5, the DNS server in the router also has the 192.168.115.5. These addresses I have given to the system during the installation process of FOG. The router assigns DHCP addresses 192.168.115.150-192.168.115.199.
    I want to let the router as a DHCP server for PXE boot, and I must therefore ask at the setting for his FOG DHCP server to “N”? FOG install will always offer at DNS server 127.0.0.1, that’s right, or must be entered here, the DNS server of the router?

    I can do what I want, I’m just not on the GUI of FOG and therefore ask for some help. If there is a German user who can assist me with the first steps something that would be very kind.

    Many greetings.



  • Hi all,
    my PC with Mainboard ASUS P5RD2 VM has the same error like my PC with Mainboard ASUS P5W DH Deluxe (Image in post #11).

    Please give me hints for resolving the problem, many thanks.

    edit:
    now I try another PC (FSC Esprimo E5925), it´s the same Problem …

    edit 2:
    now I trying PC with Mainboard ASUS M3N78-VM, Chipset Nvidia Geforce 8200, MCP78S, LAN Nvidia nForce build-in Gigabit MAC with external Realtek 8211CL-GR PHY, AND FOG WORK´S !!
    (Windows 8.1 64bit, Image Type “Other Windows”)

    [I] I confused …[/I]

    edit 3:
    Now I’ve tried desktop to circumvent the problem with the installation of Intel Pro/1000 GT Adapter, unfortunately without success. In all three problematic computers the same failure (see photo post#11).
    Now I do not go on and ask for help.



  • Hallo madeyem,
    ganz vielen Dank fürs übersetzen und für die Hilfe.

    Ich habe jetzt einen hardware-identischen Client mit Windows7 Home 32bit hergenommen und siehe da, damit funktioniert der Upload!

    Also nochmals:
    ich besitze zwei Notebooks FSC C-Series Lifebook, auf dem einen ist Windows XP, auf dem anderen Windows7. die Hardware ist bis auf die RAM-Größe identisch. Damit funktioniert FOG, sowohl unter XP als auch unter Windows7.

    Das Foto in #11 ist von einem weiteren Client mit Windows7 Home 64bit, es ist ein Mainboard P5W DH Deluxe verbaut, der Chipsatz ist Intel 975X ICH7R, 8GB RAM, ein Quadcore-Prozessor. PXE-Boot ist im BIOS aktiviert und holt sich die DHCP-Adresse; nur wie auf dem Foto in #11 dargestellt macht TFTP Schwierigkeiten.

    Vielleicht hilft das einem potenziellen Helfer weiter.

    Danke nochmals und freundliche Grüße.

    (Google translated)

    very thanks for translating and for the help.
    I now trying with a hardware-identical client with Windows7 Home 32bit and lo and behold, so does the upload!
    So once again:
    I have two notebooks FSC Lifebook C Series, on the one hand, Windows XP, on the other Windows7. the hardware is identical to the RAM size. This works FOG, under both XP and Windows7.
    The photo in # 11 is installed by another client with Windows7 Home 64bit, it is a P5W DH Deluxe motherboard, the chipset is Intel 975X ICH7R, 8GB RAM, a quad core processor. PXE boot is enabled in the BIOS and gets the DHCP address, just like in the photo in # 11 is shown makes TFTP difficulties.
    Maybe this helps a potential helper.
    Thanks again and best regards.



  • Hm dann bin ich überfragt. Ich kann den aktuellen Stand mal auf Englisch übersetzen, damit dir evtl. andere helfen können.


    Hi everyone,
    here is an update on the threadstarter’s problem:

    He installed DNSmasq on his FOG server (192.168.115.20), which now handles the IP range 192.168.115.21 - 35 as a DHCP. He has another DHCP (Fritzbox, home router), which handles the IP range 192.168.115.150 - 199.

    He can PXE-boot a Windows XP client and has already uploaded an image using the debug-mode. When he tries to PXE-boot a Windows 7 client, he gets an error, which you can see in the screenshot in post #11. PXE-boot is enabled on that client. The threadstartet hasn’t changed anything in pxelinux.cfg/default.

    Can someone help?



  • Hi,
    ja, das PXE-Boot im windows7-Client ist korrekt aktiviert. Ich habe auch die fogprep.exe gestartet. Die Datei pxelinux.cfg/default habe ich bisher nicht angefasst.



  • Hi,
    es ist seltsam, dass es mit einem Windows XP-Client geht und mit einem Windows 7-Client nicht. Denn der PXE-Boot hat mit dem installierten Betriebssystem in der Regel nichts zu tun. Der Netzwerkboot läuft ja, bevor das Betriebssystem überhaupt angefasst wird.

    Ich würde also zunächst überprüfen, ob im BIOS des Windows 7-Clients der PXE-Boot korrekt aktiviert ist. Ansonsten scheint was in der Datei pxelinux.cfg/default falsch zu sein. Hast du dort was verstellt?



  • Hallo madeyem,
    dnsmasq auf der Fritzbox setzt voraus, dass man ein modifiziertes Firmware-Image auf die Box bringt (freetz), das wollte ich mir bzw. der Box nicht antun.
    Es laufen also jetzt 2 DHCP-Server nebeneinander, einmal die Range 192.168.115.150 - 199 auf der Fritzbox, der FOG-DHCP bedient die Range 192.168.115.21 - 35; der FOG-Server selbst hat die 192.168.115.20.

    Soweit funktioniert jetzt der DHCP-Dienst, und mit einem XP-Client funktioniert auch TFTP. Einen upload habe ich damit bereits ausgeführt, zumindest im debug-Modus.

    Ein kleines Problem bleibt aber noch: mit einem Windows7-Client funktioniert TFTP immer noch nicht. Ich hänge ein Foto an, worauf die Fehlermeldung zu sehen ist.

    Danke für jeden Tipp zur Lösung des Problems; jeder Hinweis ist willkommen!

    Viele Grüße.

    [url="/_imported_xf_attachments/0/579_SAM_1947.JPG?:"]SAM_1947.JPG[/url]



  • Hi,
    es ist wichtig die Optionen 66 und 67 in [I][U]dem[/U][/I] DHCP einzutragen, der auch die IPs verteilt, in deinem Fall also offensichtlich die Fritzbox. Du müsstest hier erstmal recherchieren, ob man dort diese Optionen überhaupt eintragen kann. Bei jedem “normalen” DHCP geht das, aber Fritzbox ist ja eher was für Heimanwender und evtl. kann der das gar nicht.

    Ich würde erstmal das, was du im letzten Post gemacht hast, rückgängig machen, d.h. die Fritzbox als next-server wieder austragen.

    Du kannst den FOG auch als DHCP nutzen und dort die Optionen 66 und 67 konfigurieren. Allerdings kann es natürlich sein, dass sich die beiden DHCPs dann in die Quere kommen. Man sollte jedenfalls nur einen DHCP in einem Netzwerk nutzen. Als weitere Alternative gibt es noch DNSmasq. Da müsstest du dich erstmal einlesen und das einfach ausprobieren. Ich habe damit noch keine Erfahrungen gemacht. Hier für den Anfang:

    [url]http://wiki.ubuntuusers.de/Dnsmasq[/url]
    vor allem siehe Abschnitt: [url]http://wiki.ubuntuusers.de/Dnsmasq#PXE-Server[/url]

    [CODE]dhcp-boot=/pxelinux.0,zeus,192.168.1.11[/CODE]

    “zeus” ersetzt du durch den Namen deines Fogservers und die IP durch die IP deines Fogservers.

    [url]http://wiki.ip-phone-forum.de/software:ds-mod:pakete:dnsmasq[/url]



  • (google translated)

    Hello,
    my DHCP problem I can solve. My router (Fritz!Box 7270) with the IP address 192.168.115.5 was entered in the / etc / dhcp / dhcpd.conf as “next server”.
    Nevertheless, I still can not get further. Now comes on the client after the PXE boot the error:
    PXE-E32: TFTP open timeout
    TFTP …
    Do you please have a tip for me, how I can solve this problem? Now already many thanks and best regards.

    (german origin)

    Hallo,
    mein DHCP-Problem habe ich lösen können. Mein Router (Fritz!Box 7270) mit der IP-Adresse 192.168.115.5 wurde in die /etc/dhcp/dhcpd.conf als “next server” eingetragen.
    Trotzdem komme ich immer noch nicht weiter. Jetzt kommt auf dem Client nach dem PXE-Boot der Fehler:
    PXE-E32: TFTP open timeout
    TFTP …
    Habt ihr bitte noch einen Tipp für mich, wie ich dieses Problem lösen kann? Jetzt schon vielen Dank und freundliche Grüße.



  • Hallo madeyem,
    mir ist folgendes noch nicht ganz klar:

    wo muss ich die Optionen 66 und 67 eintragen? Du schreibst “im DHCP”, wo bitte ist das genau? Im Client läuft die PXE-Boot-Option, der Client wartet auf eine IP-Adresse, die ihm per DHCP vergeben werden soll, aber er wartet vergebens und bricht den Vorgang nach einigen Sekunden ab. Wenn ich den Host wo der FOG drauf läuft (Ubuntu 12.04 32bit) als DHCP-Server den Dienst des FOG nehme, kann ich dort in die Konfiguration etwas eintragen, kein Problem. Aber auf der Fritzbox die normalerweise auch mein DHCP-Server ist geht das nicht, jedenfalls wüsste ich nicht wie das dort zu machen wäre.

    Bitte noch einen kurzen Hinweis, was ich genau wo eintragen muss, vielen Dank.

    Freundliche Grüße.



  • Hi,
    ich glaube dein Problem ist, dass dein aktiver DHCP den Clients nicht mitteilt, wo sie das PXE-Bootfile des Fogservers finden. Dafür gibt es im DHCP die Optionen 66 (IP des Fogservers) und 67 (Name des Bootfiles, im Falle von FOG “pxelinux.0”). Diese beiden Optionen musst du im DHCP eintragen, sonst wissen deine Clients nicht, wo sie das Bootfile finden.

    Im Client selbst muss die PXE-Bootoption aktiviert sein im BIOS. Normalerweise kannst du mit F12 den Netzwerkboot einleiten auf dem Client. Darüber kannst du erstmal testen, ob dein Client das Bootfile von FOG lädt. Dies erkennst du an dem Erscheinen des FOG-Menüs. Wenn das erfolgreich gelaufen ist, würde ich erst einen Task anstarten.



  • (translated by Google continued)

    Hi all,
    I have come with your help a few steps further. But still not up to success.
    I start with the FOG Task to upload and here ends my art. The client restarts not boot with PXE and gets an IP address via DHCP. I have the / etc / network / dhcpd.conf file processed in order to operate next to the DHCP server of my router another DHCP server can, and I have the DHC server of my router disabled, all to no avail.
    The client waits for an IP address, then aborts the process and it will boot to the operating system.
    Please: Where can I keep looking for my mistakes?
    I would like to create it in the end, to transmit a pre-defect-free image of a calculator on eight computers in a LAN (all Vista machine with the same hardware).
    Please continue to give me help, thank you.
    Friendly greetings.



  • Hi,

    try [url]http://192.168.115.20/fog/management/[/url]

    Seems like you are on [url]http://192.168.115.20[/url] wich shows the default Page from apache.

    EDIT: Nevermind… Jaymes Driver was faster ;)


  • Developer

    [quote=“Oma Voss, post: 23921, member: 22725”]Hi Tom,
    thank you for your support.
    It did not work. I get the browser in big black letters back:
    [code]
    It works!
    This is the default web page for this server.
    The web server software is running but no content has been addet, yet.
    [/code]

    From the wiki I’ve taken, how to completely uninstall FOG and have done that. But despite reinstalling FOG again and again the same error, I can not get to the GUI.

    Can you still give advice, except perhaps completely new set up the Ubuntu system to me please?

    Best regards and thanks again.[/quote]

    In order to get to the web GUI you need to add /fog/management to the end of your URL.

    so if the IP address of your FOG server is 192.168.115.5 you would use

    [url]http://192.168.115.5/fog/management[/url]

    The problem is that the service installed to server the HTTP portions of fog is Apache2. apache sets up a stock page for use to let you know the service is working, that is the page you are seeing stating that “IT WORKS!!!” meaning your Apache is working.

    You can set up a simple redirect page in the future to point your address to the /fog/managment folder.



  • Hi Tom,
    thank you for your support.
    It did not work. I get the browser in big black letters back:
    [code]
    It works!
    This is the default web page for this server.
    The web server software is running but no content has been addet, yet.
    [/code]

    From the wiki I’ve taken, how to completely uninstall FOG and have done that. But despite reinstalling FOG again and again the same error, I can not get to the GUI.

    Can you still give advice, except perhaps completely new set up the Ubuntu system to me please?

    Best regards and thanks again.


  • Senior Developer

    While I’m not German, (I’m sorry), I can still try to help.

    Set the DNS to that of your Router (192.168.115.5). As long as the router has the ability to point clients to get the pxelinux.0 file, you should be fine.

    Thank you,


Log in to reply
 

353
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.