Post Fog install. PXE boot issues. Multiple PXE servers (1 old, previous IT managers install)



  • Post Fog install. PXE boot issues. Multiple PXE servers (1 old, previous IT managers install)

    Hi All,

    I am having issues getting machines to PXE boot to fog.

    I have used fog before and like it very much. I have just taken over an IT department and have installed fog on a Linux Ubuntu box. I can access the server remotely.

    I have set up my windows DHCP to have scope options 66 FOGSERVER and 67 pxelinux.0 (thats a zero)

    The problem is there appears to be 2 PXE servers. My Fog Ubuntu setup and also another. Set up by the previous manager. The previous manager died and left no documentation. The 2nd pxe server that the machines boot from is a windows pxe server.

    I can see on pxe boot that it is booting from my windows DHCP server. This is where I have set the scope options to point to fog. Somehow, something is still pointing to the old server.

    I have found the location of the other PXE application and it is on another server. I will when possible shut this server down to test if the fog pxe then works.

    In the mean time does anyone have any ideas of what could be causing the problem. It seems like there is something else on my DHCP server that is pointing this in the wrong direction. People have also put in tutorials to ;-

        [SIZE=12px][FONT=Arial][COLOR=#000000]I would reccomend putting an A record in your DNS called FOGSERVER this will make things easier to remember.[/COLOR][/FONT][/SIZE]
    

    [SIZE=12px][FONT=Arial][COLOR=#000000]Could this help? if so how do I do it. (forward, reverse lookup? A record what info?)[/COLOR][/FONT][/SIZE]



  • sorted it thanks guys, Stopped the WDS service for a starting. Then realised I had the DNS server setting in fog set incorrectly. Rebuilt Linux and reinstalled Fog correctly (


  • Developer

    Use dnsmasq to set up ProxyDHCP service. I had to do this in my network operating on a Novell Newtork. We have a WDS at some other locations and we had helper ips added to help get the imaging to the other buildings. This in turn over writes your settings in your DNS/DHCP area where you have set the fog server ip address.

    I found that enabling the proxy dhcp server allows me to FIRST boot my fog server, and if I turn my fog server off I can still image via WDS. It is a win/win situation.

    Use DNSmasq.

    I work in an environment where each tech has a certain number of buildings, and we get to manage and image each the way we choose. My other tech who was here before me set up the WDS, so I KNOW it is still in use as he is still here, so disabling any services on the WDS was not an option for me.


  • Moderator

    I ran into issues when first attempting to test FOG on my network because my Windows WDS server was still running. WDS is the service that Windows Server uses to serve PXE responses. If you do not want to remove the role from the server yet (in case you need to use it again soon), then you can go into Services and change WDSServer (Windows Deployment Services Server) to Disabled. That will stop the Windows server from responding to PXE requests, which is what is happening now. When you have two PXE servers on the network, even if only one is declared in the DHCP, they can be stuck in a ‘quick draw’ situation, where the first one to respond gets to fulfill the request.


Log in to reply
 

454
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.