Need Help With Zero Touch Unattend.xml



  • We have an unattend.xml file already made up, but it’s set up to stop on the machine name screen, so we can name it before setup process is done. What do you change it to, to have a default name used until the FOG client kicks in and renames the machine to the pre-setup hostname (stored in FOG)?


  • Developer

    Exactly as Tom says. Good luck.

    VincentJ you can name them as you want, but I set the fog service to rename them, and if they don’t meet my naming scheme I track them through a management software, a couple of them really, so I can see the Host name assigned to the machine.

    I check all of this and even fix it if necessary, which has only been the case on like 4 machines, and then I activate my windows. Everything I do is tied to a user log in, it registers everything to my novel tree and context, names the computer, enables novel auto log in (which heavily depends on the host name of the machine) then it activates windows.


  • Senior Developer

    i’m pretty sure you just change the processorArchitecture=“x86” to processorArchitecture=“amd64”



  • Thanks Jaymes. How hard is this to change over to 64 bit?

    Also, I managed to get the existing unattend to give a random name, but now it seems like either the FOG server or client isn’t telling the machine to reboot to change it’s hostname… I’m currently on revision 1257. Is there anything that would be preventing this?


  • Moderator

    I name all my newly deployed PCs ‘newdeploy’ so I can see any of them which are not renaming in the DHCP pool.


  • Developer

    I will do you a solid and just post my Unattend.XML

    Please note that the key listed here in my unattend file is a generic key, I activate to my KMS server after installation this just gives the install a key so it can continue.

    [code]
    <?xml version=“1.0” encoding=“utf-8”?>
    <unattend xmlns=“urn:schemas-microsoft-com:unattend”>
    <settings pass=“windowsPE”>
    <component name=“Microsoft-Windows-International-Core-WinPE” processorArchitecture=“x86” publicKeyToken=“31bf3856ad364e35” language=“neutral” versionScope=“nonSxS” xmlns:wcm=“http://schemas.microsoft.com/WMIConfig/2002/State” xmlns:xsi=“http://www.w3.org/2001/XMLSchema-instance”>
    <SetupUILanguage>
    <UILanguage>en-US</UILanguage>
    </SetupUILanguage>
    <InputLocale>en-US</InputLocale>
    <SystemLocale>en-US</SystemLocale>
    <UILanguage>en-US</UILanguage>
    <UserLocale>en-US</UserLocale>
    </component>
    <component name=“Microsoft-Windows-Setup” processorArchitecture=“x86” publicKeyToken=“31bf3856ad364e35” language=“neutral” versionScope=“nonSxS” xmlns:wcm=“http://schemas.microsoft.com/WMIConfig/2002/State” xmlns:xsi=“http://www.w3.org/2001/XMLSchema-instance”>
    <UserData>
    <AcceptEula>true</AcceptEula>
    </UserData>
    <EnableNetwork>true</EnableNetwork>
    <EnableFirewall>false</EnableFirewall>
    </component>
    </settings>
    <settings pass=“specialize”>
    <component name=“Microsoft-Windows-Shell-Setup” processorArchitecture=“x86” publicKeyToken=“31bf3856ad364e35” language=“neutral” versionScope=“nonSxS” xmlns:wcm=“http://schemas.microsoft.com/WMIConfig/2002/State” xmlns:xsi=“http://www.w3.org/2001/XMLSchema-instance”>
    <ShowWindowsLive>false</ShowWindowsLive>
    <ComputerName>*</ComputerName>
    <RegisteredOrganization>Microsoft</RegisteredOrganization>
    <RegisteredOwner>AutoBVT</RegisteredOwner>
    <ProductKey>KEY GOES HERE</ProductKey>
    <CopyProfile>true</CopyProfile>
    <TimeZone>Eastern Standard Time</TimeZone>
    </component>
    <component name=“Microsoft-Windows-TerminalServices-LocalSessionManager” processorArchitecture=“x86” publicKeyToken=“31bf3856ad364e35” language=“neutral” versionScope=“nonSxS” xmlns:wcm=“http://schemas.microsoft.com/WMIConfig/2002/State” xmlns:xsi=“http://www.w3.org/2001/XMLSchema-instance”>
    <fDenyTSConnections>false</fDenyTSConnections>
    </component>
    </settings>
    <settings pass=“oobeSystem”>
    <component name=“Microsoft-Windows-International-Core” processorArchitecture=“x86” publicKeyToken=“31bf3856ad364e35” language=“neutral” versionScope=“nonSxS” xmlns:wcm=“http://schemas.microsoft.com/WMIConfig/2002/State” xmlns:xsi=“http://www.w3.org/2001/XMLSchema-instance”>
    <InputLocale>en-US</InputLocale>
    <UILanguage>en-US</UILanguage>
    <UILanguageFallback>en-US</UILanguageFallback>
    <SystemLocale>en-US</SystemLocale>
    <UserLocale>en-US</UserLocale>
    </component>
    <component name=“Microsoft-Windows-Shell-Setup” processorArchitecture=“x86” publicKeyToken=“31bf3856ad364e35” language=“neutral” versionScope=“nonSxS” xmlns:wcm=“http://schemas.microsoft.com/WMIConfig/2002/State” xmlns:xsi=“http://www.w3.org/2001/XMLSchema-instance”>
    <AutoLogon>
    <Enabled>false</Enabled>
    <LogonCount>1</LogonCount>
    <Username>administrator</Username>
    <Domain>Redding</Domain>
    </AutoLogon>
    <OOBE>
    <HideEULAPage>true</HideEULAPage>
    <NetworkLocation>Work</NetworkLocation>
    <ProtectYourPC>3</ProtectYourPC>
    <HideWirelessSetupInOOBE>true</HideWirelessSetupInOOBE>
    </OOBE>
    <UserAccounts>
    <AdministratorPassword>
    <Value>MAB3AGwAMQA2ADMAOABBAGQAbQBpAG4AaQBzAHQAcgBhAHQAbwByAFAAYQBzAHMAdwBvAHIAZAA=</Value>
    <PlainText>false</PlainText>
    </AdministratorPassword>
    <LocalAccounts>
    <LocalAccount wcm:action=“add”>
    <Description>Local Administrator</Description>
    <DisplayName>Administrator</DisplayName>
    <Group>Administrators</Group>
    <Name>Administrator</Name>
    </LocalAccount>
    </LocalAccounts>
    </UserAccounts>
    <RegisteredOrganization>Seymour Community Schools</RegisteredOrganization>
    <RegisteredOwner>Seymour Community Schools</RegisteredOwner>
    <VisualEffects>
    <FontSmoothing>ClearType</FontSmoothing>
    </VisualEffects>
    </component>
    </settings>
    <settings pass=“generalize”>
    <component name=“Microsoft-Windows-Security-SPP” processorArchitecture=“x86” publicKeyToken=“31bf3856ad364e35” language=“neutral” versionScope=“nonSxS” xmlns:wcm=“http://schemas.microsoft.com/WMIConfig/2002/State” xmlns:xsi=“http://www.w3.org/2001/XMLSchema-instance”>
    <SkipRearm>0</SkipRearm>
    </component>
    </settings>
    <cpi:offlineImage cpi:source=“wim:d:/sources/install.wim#Windows 7 PROFESSIONAL” xmlns:cpi=“urn:schemas-microsoft-com:cpi” />
    </unattend>
    [/code]



  • This is weird… I had this working fine, but somewhere in the midst of things, I lost/overwrote the working unattend.xml and had to create a new one. So, I pulled the same original image that had the correct image file on it and just added the “<ComputerName>*</ComputerName>” part. Now, sysprep run just fine, but upon reboot, I get the same pop-up to name the machine. Is there another setting that you’re supposed to remove, so the <ComputerName> portion will be used?


  • Developer

    I would stick it in here and test it on a machine.

    [code]
    <RegisteredOwner>Naylor</RegisteredOwner>
    <RegisteredOrganization>Naylor</RegisteredOrganization>
    <TimeZone>Eastern Standard Time</TimeZone>
    <ShowWindowsLive>false</ShowWindowsLive>
    <ComputerName>*</ComputerName>
    [/code]



  • Mine isn’t set up like that. I didn’t create our unattend.xml. A network admin that has been here forever did it. I don’t think he actually set it up correctly. Can you take a look?

    This is what I have…

    [CODE]<?xml version=“1.0” encoding=“utf-8”?>
    <unattend xmlns=“urn:schemas-microsoft-com:unattend”>
    <settings pass=“oobeSystem”>
    <component name=“Microsoft-Windows-Shell-Setup” processorArchitecture=“amd64” publicKeyToken=“31bf3856ad364e35” language=“neutral” versionScope=“nonSxS” xmlns:wcm=“http://schemas.microsoft.com/WMIConfig/2002/State” xmlns:xsi=“http://www.w3.org/2001/XMLSchema-instance”>
    <!-- Uncomment the following section to set display settings
    <Display>
    <ColorDepth>32</ColorDepth>
    <DPI>120</DPI>
    <HorizontalResolution>1024</HorizontalResolution>
    <RefreshRate>60</RefreshRate>
    <VerticalResolution>768</VerticalResolution>
    </Display>
    –>
    <RegisteredOwner>Naylor</RegisteredOwner>
    <RegisteredOrganization>Naylor</RegisteredOrganization>
    <TimeZone>Eastern Standard Time</TimeZone>
    <ShowWindowsLive>false</ShowWindowsLive>
    <OOBE>
    <HideEULAPage>true</HideEULAPage>
    <HideWirelessSetupInOOBE>true</HideWirelessSetupInOOBE>
    <NetworkLocation>Work</NetworkLocation>
    <ProtectYourPC>1</ProtectYourPC>
    <SkipMachineOOBE>true</SkipMachineOOBE>
    <SkipUserOOBE>true</SkipUserOOBE>
    </OOBE>
    <AutoLogon>
    <Enabled>false</Enabled>
    <LogonCount>5</LogonCount>
    <Username>Administrator</Username>
    </AutoLogon>
    <FirstLogonCommands>
    <SynchronousCommand wcm:action=“add”>
    <Order>1</Order>
    </SynchronousCommand>
    </FirstLogonCommands>
    <UserAccounts>
    <LocalAccounts>
    <LocalAccount wcm:action=“add”>
    <DisplayName>Adminuser</DisplayName>
    <Group>Administrators</Group>
    <Name>Adminuser</Name>
    <Password>
    <Value>VQBzAGUAcgAyAHMAZQBhAFAAYQBzAHMAdwBvAHIAZAA=</Value>
    <PlainText>false</PlainText>
    </Password>
    </LocalAccount>
    </LocalAccounts>
    </UserAccounts>
    </component>
    <component name=“Microsoft-Windows-International-Core” processorArchitecture=“amd64” publicKeyToken=“31bf3856ad364e35” language=“neutral” versionScope=“nonSxS” xmlns:wcm=“http://schemas.microsoft.com/WMIConfig/2002/State” xmlns:xsi=“http://www.w3.org/2001/XMLSchema-instance”>
    <InputLocale>en-US</InputLocale>
    <SystemLocale>en-US</SystemLocale>
    <UILanguage>en-US</UILanguage>
    <UserLocale>en-US</UserLocale>
    </component>
    </settings>
    <settings pass=“generalize”>
    <component name=“Microsoft-Windows-PnpSysprep” processorArchitecture=“amd64” publicKeyToken=“31bf3856ad364e35” language=“neutral” versionScope=“nonSxS” xmlns:wcm=“http://schemas.microsoft.com/WMIConfig/2002/State” xmlns:xsi=“http://www.w3.org/2001/XMLSchema-instance”>
    <PersistAllDeviceInstalls>true</PersistAllDeviceInstalls>
    </component>
    <component name=“Microsoft-Windows-Security-SPP” processorArchitecture=“amd64” publicKeyToken=“31bf3856ad364e35” language=“neutral” versionScope=“nonSxS” xmlns:wcm=“http://schemas.microsoft.com/WMIConfig/2002/State” xmlns:xsi=“http://www.w3.org/2001/XMLSchema-instance”>
    <SkipRearm>0</SkipRearm>
    </component>
    <component name=“Microsoft-Windows-Security-Licensing-SLC” processorArchitecture=“amd64” publicKeyToken=“31bf3856ad364e35” language=“neutral” versionScope=“nonSxS” xmlns:wcm=“http://schemas.microsoft.com/WMIConfig/2002/State” xmlns:xsi=“http://www.w3.org/2001/XMLSchema-instance”>
    <SkipRearm>0</SkipRearm>
    </component>
    </settings>
    <settings pass=“specialize”>
    <component name=“Microsoft-Windows-Shell-Setup” processorArchitecture=“amd64” publicKeyToken=“31bf3856ad364e35” language=“neutral” versionScope=“nonSxS” xmlns:wcm=“http://schemas.microsoft.com/WMIConfig/2002/State” xmlns:xsi=“http://www.w3.org/2001/XMLSchema-instance”>
    <ProductKey>FJ82H-XT6CR-J8D7P-XQJJ2-GPDD4</ProductKey>
    <Display>
    <ColorDepth>32</ColorDepth>
    <DPI>96</DPI>
    <HorizontalResolution>1024</HorizontalResolution>
    <RefreshRate>60</RefreshRate>
    <VerticalResolution>768</VerticalResolution>
    </Display>
    <Themes>
    <DefaultThemesOff>true</DefaultThemesOff>
    <DesktopBackground>%WINDIR%_NaylorBlue.bmp</DesktopBackground>
    <ScreenSaver>Ribbons.scr</ScreenSaver>
    </Themes>
    <CopyProfile>true</CopyProfile>
    <ShowWindowsLive>false</ShowWindowsLive>
    <TimeZone>Eastern Standard Time</TimeZone>
    </component>
    <component name=“Microsoft-Windows-Security-SPP-UX” processorArchitecture=“amd64” publicKeyToken=“31bf3856ad364e35” language=“neutral” versionScope=“nonSxS” xmlns:wcm=“http://schemas.microsoft.com/WMIConfig/2002/State” xmlns:xsi=“http://www.w3.org/2001/XMLSchema-instance”>
    <SkipAutoActivation>true</SkipAutoActivation>
    </component>
    <component name=“Microsoft-Windows-Deployment” processorArchitecture=“amd64” publicKeyToken=“31bf3856ad364e35” language=“neutral” versionScope=“nonSxS” xmlns:wcm=“http://schemas.microsoft.com/WMIConfig/2002/State” xmlns:xsi=“http://www.w3.org/2001/XMLSchema-instance”>
    <RunSynchronous>
    <RunSynchronousCommand wcm:action=“add”>
    <Order>1</Order>
    <Path>net user administrator /active:yes</Path>
    </RunSynchronousCommand>
    </RunSynchronous>
    </component>
    <component name=“Microsoft-Windows-UnattendedJoin” processorArchitecture=“amd64” publicKeyToken=“31bf3856ad364e35” language=“neutral” versionScope=“nonSxS” xmlns:wcm=“http://schemas.microsoft.com/WMIConfig/2002/State” xmlns:xsi=“http://www.w3.org/2001/XMLSchema-instance”>
    <Identification>
    <JoinWorkgroup>WORKGROUP</JoinWorkgroup>
    </Identification>
    </component>
    </settings>
    <cpi:offlineImage cpi:source=“wim:d:/wims/win7-amd64/install.wim#Windows 7 PROFESSIONAL” xmlns:cpi=“urn:schemas-microsoft-com:cpi”/>
    </unattend>[/CODE]


  • Developer

    You will want it in the section that is answering the OOBE questions and assigning your serial

    In my unattend.xml it is the FIRST instance of Microsoft-Windows-Shell-Setup

    [code]
    <component name=“Microsoft-Windows-International-Core-WinPE” processorArchitecture=“x86” publicKeyToken=“31bf3856ad364e35” language=“neutral” versionScope=“nonSxS” xmlns:wcm=“http://schemas.microsoft.com/WMIConfig/2002/State” xmlns:xsi=“http://www.w3.org/2001/XMLSchema-instance”>
    <SetupUILanguage>
    <UILanguage>en-US</UILanguage>
    </SetupUILanguage>
    <InputLocale>en-US</InputLocale>
    <SystemLocale>en-US</SystemLocale>
    <UILanguage>en-US</UILanguage>
    <UserLocale>en-US</UserLocale>
    </component>
    <component name=“Microsoft-Windows-Setup” processorArchitecture=“x86” publicKeyToken=“31bf3856ad364e35” language=“neutral” versionScope=“nonSxS” xmlns:wcm=“http://schemas.microsoft.com/WMIConfig/2002/State” xmlns:xsi=“http://www.w3.org/2001/XMLSchema-instance”>
    <UserData>
    <AcceptEula>true</AcceptEula>
    </UserData>
    <EnableNetwork>true</EnableNetwork>
    <EnableFirewall>false</EnableFirewall>
    </component>
    </settings>
    <settings pass=“specialize”>
    <component name=“Microsoft-Windows-Deployment” processorArchitecture=“x86” publicKeyToken=“31bf3856ad364e35” language=“neutral” versionScope=“nonSxS” xmlns:wcm=“http://schemas.microsoft.com/WMIConfig/2002/State” xmlns:xsi=“http://www.w3.org/2001/XMLSchema-instance”>
    <RunAsynchronous>
    <RunAsynchronousCommand wcm:action=“add”>
    <Description>De-activate EnableLUA</Description>
    <Order>1</Order>
    <Path>cmd /c reg add HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System /v EnableLUA /t REG_DWORD /d 0 /f</Path>
    </RunAsynchronousCommand>
    </RunAsynchronous>
    </component>
    [/code]

    THIS is the portion that gives the computer it’s name

    [code]
    <component name=“Microsoft-Windows-Shell-Setup” processorArchitecture=“x86” publicKeyToken=“31bf3856ad364e35” language=“neutral” versionScope=“nonSxS” xmlns:wcm=“http://schemas.microsoft.com/WMIConfig/2002/State” xmlns:xsi=“http://www.w3.org/2001/XMLSchema-instance”>
    <ShowWindowsLive>false</ShowWindowsLive>
    <ComputerName>*</ComputerName>
    <RegisteredOrganization>SCSC</RegisteredOrganization>
    <RegisteredOwner>SCSC</RegisteredOwner>
    <ProductKey> This is a GENERIC key, I activate at Setupcomplete.CMD to my KMS server.</ProductKey>
    <CopyProfile>true</CopyProfile>
    <TimeZone>Eastern Standard Time</TimeZone>
    </component>
    [/code]



  • Any certain place this goes under “…Shell-Setup”?

    Currently, we have <Product Key>, <Display>, <Themes>, <CopyProfile>, <ShowWindowsLive>, and <TimeZone>…

    I mean, should it go at the top, above <Product Key>, or at the bottom, under <TimeZone>, etc… ?


  • Developer

    under component name=“Microsoft-Windows-Shell-Setup”

    add

    <ComputerName>*</ComputerName>


Log in to reply
 

388
Online

38982
Users

10712
Topics

101677
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.