Pxe-e53 no boot file name



  • Hi
    I volunteer at a place called computers for schools, had fog running and was going to do a muticast test. when our router decided to give up the ghost (literally minutes before doing the test) so it was replaced with a linksys EA6400. Instead of trying to reconfigure it to work with the new router I just reinstalled ubuntu and fog, but when i try to pxe boot anything I am greeted with a :
    pxe-e53 no boot file name
    directly followed by
    pxe-M0F exiting intel boot agent.

    The fog server is directly connected to the linksys router any computers to be imaged are behind an additional 2 switches.

    Thanks in advance for any help, speeding up the process of refurbishing these old computers will let us focus on our sizeable pile of E-waste


  • Moderator

    After searching through the interface for the EA6400, it doesn’t appear to support PXE boot options. Just use DNSMasq as Jaymes advised. It will let your Linksys router serve DHCP, and just respond with PXE Boot information to those clients that request it, such as next server name and boot file name, no IP info.


  • Developer

    You can try to install the DNSMasq service to serve a “proxydhcp” server for pxebooting, I ultimately had to in my environment, it couldn’t hurt giving it a shot. It will try to help your clients to resolve to the pxe server.



  • I see no setting for boot file name, but I’m not used to linksys’ new interface. I’ll give it a bit longer but I think I’m going to go with my backup plan

    again thanks for the help


  • Developer

    Do you have a management console for the Linksys EA6400?

    There may be a setting for “Boot file name” that we need to edit to allow pxelinux.0 to boot.



  • The new Linksys EA6400 is doing the dhcp


  • Moderator

    What device is serving DHCP for this network segment?



  • FOG_TFTP_HOST = 192.168.1.200
    FOG_PXE_IMAGE_DNSADDRESS = 127.0.0.1
    FOG_WEB_HOST = 192.168.1.200
    fog was installed without dhcp
    (didn’t change any of these its what they have been since the reinstall after router died)
    error still persists :(

    again thanks for the help


  • Senior Developer

    It looks like the 3com switch is a managed switch, but I don’t think that’s quite your issue.

    As you state the static IP Changed from 192.168.0.200 to now, 192.168.1.200, is all of your FOG stuff pointing there, and is option 66 pointing to the new server.

    Option 66 on the DHCP Server should be, now, set to the new IP address of the FOG Server. This should give you back pxe menu.

    In the FOG Management side of the house, you’ll likely need to make the changes to Storage Management->Storage Node, FOG Configuration (Other)->FOG Settings-> FOG_TFTP_HOST, FOG_PXE_IMAGE_DNSADDRESS (This will probably be the new Dlink’s gateway address.), and FOG_WEB_HOST.

    Did you install FOG with or without a DHCP Server?



  • ubuntu is 12.04
    fog is 0.32
    router was changed from a dlink so the static ip is now 192.168.1.200 (was previously 0.200 but changed when reinstalling ubuntu and fog after dlink died)
    first switch is an unmanaged dllink dgs-1016D
    second switch is a 3com superstack 3 4200 (cant find a definitive answer on if its managed or not)
    also I was able to pull and deploy an image fine before the router switch and reinstall of ubuntu and fog (forgot that in original post)

    Again many thanks for the help


  • Developer

    when you set up your fog server did you set up the static ip address as the same ip address you had before? You will need to update your DHCP scheme to include options 66 adn 67 to point to your server and your boot image respectively.

    Are your switches standard hub style switches or are they managed switches?

    What Ubuntu version did you install and what version of Fog did you install?


Log in to reply
 

784
Online

38918
Users

10688
Topics

101399
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.