Problem Deploying Dell3010



  • Hello everybody,

    i’m french and i don’t speak very well.

    i tried to deploying DELL3010 with FOG 0.32 on my network.
    Ubuntu 12.04 and my kernel is 3.8.8
    All is on my fog server (images, tftp,…) except DHCP on another server.

    It’s impossible to deploy
    while that it’s good with HP6800.

    I have updating BIOS to A11
    There are 2 partitions (1:100Mo and 2: rest of disk)
    Computer is under win7 x86
    [ATTACH=full]508[/ATTACH]
    When i deployed this computer, message said "checking queuing done"
    and nothing (5s) (10s) (15s)…

    [url="/_imported_xf_attachments/0/508_fog01.jpg?:"]fog01.jpg[/url]



  • Finally, my problem to deploying came from network Access control list.
    Thanxs for your help. ;)



  • I just did a deployment on Dell laptops. We changed all of the boot options in the bios to legacy and turned off secure boot. Then we had to boot the master laptop from a windows dvd, go to repair and using the command prompt convert the partition scheme from GPT to MBR. Then install windows, build your image, sysprep, upload. Boot target laptop from Windows dvd,change bios as above, convert partition as above. Deploy image. Worked a treat.



  • I’ve had this same issue before. It seems like it gets stuck for some reason. A workaround i have found is to put that drive into a system that is known to be working and can be imaged and pushing the image to that computer. IMMEDIATELY after the image finishes deploying turn the computer off (this needs to be done before it starts trying to boot into windows) if you SysPrep’d and used OOBE you should be able to just swap that drive into the computer your having issues with start and up and away you go. If your able give that a try and let me know if that works for you



  • I try to use text mode
    try
    boot : inventory:fog.reginput
    Could not find kernel image

    So i want to restore graphic mode
    [ATTACH=full]527[/ATTACH]
    And FAILED ?!?

    The password is the same :
    Storage Management->Storage Node->Management Username/Password.
    and
    FOG Settings->FOG_TFTP_FTP_USERNAME,[FONT=Ubuntu][COLOR=#333333]FOG_TFTP_FTP_PASSWORD[/COLOR][/FONT]

    [url="/_imported_xf_attachments/0/527_fog2.png?:"]fog2.png[/url]



  • [ATTACH=full]526[/ATTACH]
    I don’t understand why the upload is good and not deployment

    [url="/_imported_xf_attachments/0/526_fog.png?:"]fog.png[/url]


  • Moderator

    I have experienced this as well with a couple of odd Dell systems, and in the end it came down to issues with the network card driver. Some sort of firmware or BIOS mismatch compared to what the kernel wanted to see if I understand correctly. Considering this has exclusively been with newer Dell systems, I am not that shocked.



  • Everything is OK for the password ;)
    You know if it’s possible to force deploying when a computer is queuing ?


  • Senior Developer

    The passwords are not updated through the config.php file. The only exception for that is the initial install when you first install FOG. They’re only there to make sure things are setup. The only password you need in place is the MYSQL_PASSWORD in /var/www/fog/commons/config.php and in /opt/fog/service/etc/config.php

    After that, make sure all passwords are set using the FOG GUI.

    The first place to check is under Storage Management->Storage Node->Management Username/Password.

    The second place to check is under FOG Configuration (Other – The ? icon.)->FOG Settings->FOG_TFTP_FTP_USERNAME,[FONT=Ubuntu][COLOR=#333333]FOG_TFTP_FTP_PASSWORD[/COLOR][/FONT]

    [FONT=Ubuntu][COLOR=#333333]The PXE Menu passwords will be encrypted when you enter a new password and click Save PXE Menu, so there is no need to encrypt with FOG Crypt. FOG Crypt is used for the Active Directory password.[/COLOR][/FONT]



  • sorry for the response time,
    The password is the same everywhere (mysql, fog web,…)
    And it’s not a problem.

    The first capture in top
    vim /opt/fog/service/etc/config.php

    The second capture in bottom
    vim /opt/fog/.fogsettings

    [ATTACH=full]523[/ATTACH]

    However,
    I don’t know what can i do for my Dell3010.
    It’s not possible to force the ghost ?

    [url="/_imported_xf_attachments/0/523_fog.png?:"]fog.png[/url]


  • Senior Developer

    If that’s the password you’re referring to, Shane is absolutely correct. This is the password that asks as soon as you make a selection on the PXE Boot Image? Meaning the menu is displayed behind it asking for the password?

    Or is this the password it asks for after you’re in the menu and it asks you for the username and password? If it’s the one asking for User and Password, it’ll be your fog web gui information as I stated before.

    @Shane
    The queue system does more than just mc. Multicast may have a queue, but not that I’m aware of. If you have, lets say, 10 computers to image (Unicast) and you’ve only got 5 slots, the last five in the task list will wait until the slot’s reopen spawning the Checking queue.
    That, however, can also be created by a misconfiguration in the file system. Though you’d have to be watching the error log on the fog server to be sure.



  • You need to go to fog settings and set a PXE menu master password, then a blank password will work for the quick image.

    Also are you trying to do a multicast image? That is the only time I have seen anything about checking queue. If you are you need all the computers turned on and in pxe. Perhaps try a single computer deployment first


  • Senior Developer

    The quick image password should be your fog user from the database. (The same one most people use to log into the FOG Web GUI.)



  • Network -> PASS
    Hard-Drive -> PASS
    o_O’

    Another strange thing :
    When i try quick image, Fog ask me a password, i tried all passwords.
    No message and nothing.


  • Senior Developer

    Can you perform a compatibility check?

    From the PXE Boot Menu, choose Client Information. Then a menu will come up, I think it’s option 4. Both network and hard-drive need to say pass.

    My suspicion is it doesn’t recognize your hard drive. The errors you report seeing, aren’t usually indicative of the actual problem, though in your case the one that worries me is the hdparm, It feels like your hard-drive is not recognized though I may be wrong. I say this because you wouldn’t typically get to that phase in the menu if your network was incompatible.

    The operation mode could be an issue, though I’ve included AHCI into the kernel, so it shouldn’t pose as much a threat and we use AHCI were I work without issue on FOG 0.32.

    I may need to build a new kernel so your system will recognize the drivers.



  • Thanks for reply.

    I tried it with your bzImage. -> nok
    A new message appear :
    esas2r : driver will no be loaded because no ATTO esas2r devices were found i2c-parport-light adaptater type unspecified.

    and few secondes later :
    Checking operating system ----------> win7
    Checking CPU Core -------------------> 2
    Send Method --------------------------> NFS
    Checking Queue -----------------------> Done
    (5s)
    (10s)

    For registration, i create a new host with address MAC and name.
    When i tried a Perform Full Host Registration and Inventory
    Message:
    Unable to register host for the following reasons :
    hdparm ioctl 0x304 failed : inapropriated ioctl for device

    inventory of computer

    and then
    attemping to send inventory
    and nothing.

    My BIOS parameter for HD:
    SATA Operation : AHCI

    Have you an idea ?
    Thanxs


  • Senior Developer

    It sounds like it can’t detect the network. Try a newer kernel:

    [url]https://mastacontrola.com/fogboot/kernel/bzImage[/url]

    Place this file in:
    [code]cd /tftpboot/fog/kernel
    mkdir backup
    mv bzImage backup/bzImage.21JAN2014
    wget --no-check-certificate https://mastacontrola.com/fogboot/kernel/bzImage[/code]

    Reboot the system and you should be good to go.

    How did you register this machine? Manually?


Log in to reply
 

393
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.