Atheros AR71/AR81 Compatibilty Issue

  • Hi Guys

    I’m new at this ubuntu stuff, but I am a system builder and came across an issue with a new motherboard that was delivered today where it would boot from PXE, but would not send inventory as described at this page [url][/url] [SIZE=2]due to current fog latest [/SIZE]kernel [SIZE=2]not having the driver installed.[/SIZE]

    [SIZE=2]By using the instructions found here [/SIZE][url][/url] I managed to create a new kernel using version 3.12 which now includes this driver allowing fog to perform quick host and inventory to send to the server.

    Please note I am new at this and try at your own risk as I will not be held responsible for any issues that may arise or data loss (backup existing kernel in [FONT=monospace][COLOR=#000000]/tftpboot/fog/kernel first) - My kernel is available at [/COLOR][/FONT][url][/url]

    Please be warned, on booting kernel message it may look frozen for a couple of minutes before fog actually shows on screen.

    This is tested and working on Asrock FM2A88M Extreme 4+ Skt FM2+ Motherboard using Atheros AR8171 LAN/NIC as I have managed to perform quick host and inventory as well as upload the machines image.

  • Hi there

    I only made this Kernel because the ones that I could download through fog just wouldn’t work with this Atheros LAN card. I have been using it as a main Kernel, but ideally one needs to be made that has all LAN adapters on, as some earlier machines still fail to work.

  • That’s so funny. Got tired of my new Asus desktops with the Atheros chipset not flashing and built my kernel yesterday. Have yet to try it on the Pro desktops i have but the one laptop flashed fine.

    Edit: The newly compiled kernel also allows flashing of the Asus Pro BP6320, which would kernel panic on the newest Fog kernel.

  • Same link, try again. It works for me.

    And I just updated so now it’s on 3.12.1 not 3.12.0.

  • [quote=“Tom Elliott, post: 19780, member: 7271”]When did you try the kernel.

    Can you try the latest one:


    Any change you can repost the kernel? the link doesn’t seem to work.


  • I have a toshiba right here, i’ll download that one now and report back in 5 mins 🙂
    That file is 2 meg smaller than the one I tried so heres hoping.


    that one works fine. Takes the same amount of time to perform a network action. Seemed to hang on “compatibility” but has started imaging ok.

    Thank you both.

  • When did you try the kernel.

    Can you try the latest one:


  • We had a delivery of toshiba satellite pro c50-a-1e2 laptops. These have atheros AR8171 LAN too. I tried your bzImageALLNET Tom but it didnt work - it hung and never recovered after booting the kernel on the client (left it 30 minutes). Normal 3.8.8 wouldnt detect the card.

    The one done by ExcelGroup does work but takes about 2 minutes to get any sort of network information out of fog (such as fog compatibility or to start cloning). Not a problem as I had resorted to “donor machine” cloning the hard drives.

    Ironically enough I was coming to the boards to see how to incorporate drivers into the kernel…

  • Excel,

    I appreciate this, but I’ve also built a kernel that contains all possible network drivers on my kernel.

    What did you build from? Core, PeterSykes, KitchenSink?

    Is this kernel only going to be used on the Asrock MB’s, or do you plan on using this kernel as your main kernel?

    Just wondering and hoping to help if needed.