Nfs different subnet



  • hi,

    our clients are in a different subnet, so they cant access the nfs server and cant upload a image:

    [ATTACH]430[/ATTACH]

    what can id do?

    [url="/_imported_xf_attachments/0/430_Unbenannt.png?:"]Unbenannt.png[/url]


  • Senior Developer

    When I install the Virtio Drivers, it doesn’t have anything for Virtio network, it’s just a balloon driver. So it makes sense that it would not work. I’ll see what I can find though.



  • i use version 0.32, there are no other tasks in queue. and i use unicast ( i try every time only one client). did i change the net driver back to realtek it works.


  • Senior Developer

    Are you imaging that system using Multicast? Have you tried using Unicast? Also, check how many tasks are actually in queue.

    It looks like it is working now, but it keeps checking for valid status.

    What version of FOG are you using? (0.33, 0.32, etc…)



  • also not working, i get this:

    [ATTACH]439[/ATTACH]

    and this is running endless…

    [url="/_imported_xf_attachments/0/439_Unbenannt.png?:"]Unbenannt.png[/url]


  • Senior Developer

    Can you give it a shot again? New kernel, less, hopefully, driver confusion from networks.



  • mhh not realy, the upload task crachs:

    [ATTACH]438[/ATTACH]

    only working is a old kernel from fog version 0.29, all newer kernels are extrem slow for my clients.

    did you know why?

    [url="/_imported_xf_attachments/0/438_Unbenannt.png?:"]Unbenannt.png[/url]


  • Senior Developer

    The kernel I’ve recently built has Virtio Drivers built in.

    Download from:
    [url]https://mastacontrola.com/fogboot/kernel/bzImage[/url]

    Hope this helps you out.


  • Senior Developer

    I’m rebuilding a kernel as we speak with virtio drivers enabled. It should be up shortly.


  • Developer

    There is a way to add the driver to the kernel.

    You can try your hand at making a kernel, Ozzy has made a WONDERFUL walk through on the process.

    [url]http://fogproject.org/forum/threads/request-for-kernel-compiling-info-please-read.4045/#post-12589[/url]

    Second post.



  • i think i have the problem! the kernel or what ever cant understand virtio network driver… so i change it to realtek… i will see if it works tommorow…

    is ther a kernel version which understand virtio drivers?


  • Senior Developer

    Is you system setup so your FOG Server is the DHCP server for FOG Clients?

    If anything, I’d take a look at the dhcpd.conf file. It should be located at: /etc/dhcpd.conf though I don’t know what OS you’re using. Look for the line that says:
    [code]option routers X.X.X.X;[/code]

    I think you’d need the gateway, but make sure, if your FOG Server is the DHCP Server, that you use your FOG Server’s IP address rather than the actual gateway. DNS should then point to the proper DNS Server and as long as your fog server can access the internet, your FOG Client’s should be able to access the internet as well.

    This is just my guess.



  • [quote=“chad-bisd, post: 19663, member: 18”]Do you have a router address in your config? It might be wrong for subnets other than the one shared with the server. Try removing the router information from your config. I use FOG with multiple subnets and I do not supply a router address when I setup FOG.[/quote]

    what do you mean with router address? of course i need to setup gateway, else i dont have internet etc…

    so what could be for my config?

    it is a virtuel windows xp machine…



  • hi,

    i rebootet the machine many times …

    [CODE]# The primary network interface
    auto eth0
    iface eth0 inet static
    address 192.168.200.34
    netmask 255.255.252.0
    gateway 192.168.200.1
    dns-nameservers 192.168.200.2[/CODE]

    where else should i config gateway?

    thx!

    Erik


  • Senior Developer

    You might try restarting the nfs service and the portmap/rpcbind service

    FOR UBUNTU OS:
    [code]sudo service portmap restart
    sudo service nfs-kernel-server restart[/code]

    FOR REDHAT/CENTOS/FEDORA OS:
    [code]service rpcbind restart
    service nfs restart[/code]

    See if this helps you out, sometimes a simple service restart will help. It may not in this case, but you never know.


  • Moderator

    Do you have a router address in your config? It might be wrong for subnets other than the one shared with the server. Try removing the router information from your config. I use FOG with multiple subnets and I do not supply a router address when I setup FOG.



  • it seems not a subnet problem :( i can accees nfs from other linux system on different subnet, so why did i get this error? 192.168.200.34 is the fogserver


Log in to reply
 

394
Online

38982
Users

10712
Topics

101677
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.