VOIP and FOG - Can't PXE Boot



  • %(#000000]I am using Ubuntu 11.10 and Fog .32. Recently our school network was modified to accommodate VOIP and the subnet mask changed from 255.255.0.0 to 255.255.224.0 My fog server was working fine before the changes were made for VOIP. Here is the message I now get when I try to pxe boot from a client.
    [
    ]
    I can ping from the client to my fog server and I can use the tftp command at the client to get the pxelinux.0 file. My Fog server is setup with a static IP, Netmask 255.255.0.0, and gateway 10.141.0.1. There is no DHCP and no DNS setup on the Fog server as I am part of a school district which has its own DHCP and DNS servers.

    I am seeking suggestions on what I may need to modify in my network settings on my fog server so the clients can find it? Also would you recommend that I try to use iPxe and avoid the interaction with the school district servers?


  • Developer

    Yes dnsmasq works with ubuntu 11.10, and any ubuntu revision.



  • Thank you for the suggestions! I can’t access my organization’s switches or the the the DHCP server to even see how they are set… I will try to install dnsmasq and setup the proxyDHCP. Will dnsmasq work with Ubuntu 11.10?


  • Senior Developer

    While reading up on this:

    VoIP Phones do PXE boot, but through option 43, try taking a look at that if possible.

    PXE Boot hosts use 66/67 options.

    Maybe take a look at those things? I don’t really know as we don’t have any VoIP stuff.


  • Developer

    I agree, the VOIP system would normally cause some issues. You can try adjusting the settings to get your server to be seen again, or you can set up the proxyDHCP service with dnsmasq, it has been beneficial in my environment when we had trouble communicating to my fog server.

    I was able to ping my tftp server, and pull the pxe file from the command line, but something in my network prevented the entire file from reaching it’s destination. Setting up the dnsmasq helped to resolve the issue.



  • As far as I’m aware… most VOIP phone are actually PXE booted, so it might be that somebody has replaced the global DHCP options 66 and 67 to point at the VOIP system.


  • Senior Developer

    I would look on the switches and see if you have the ip-helper tools available on them. Then, you just use ip-helper to forward the 66/67 options to your fog server as it can communicate with it.


Log in to reply
 

427
Online

38918
Users

10688
Topics

101398
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.