Proposed Setup



  • Hi Guys,

    The school I contract to for the purpose of imaging their computers during their breaks have finally decided to decommission a server and give it to me in order to install FOG on it. Previously, we were imaging approx. 1000 computers / laptops with a shitty little Lenovo laptop (getting speeds up to 5gb / min!!).

    Now I will be installing FOG on a dual Xenon dual core server @ 2.ghz with 4GB of RAM, dual G/Bit NIC and DUAL fibre to the SAN.

    I am proposing to do Bond the NICs in a BOND 0 configuration and place the images on the SAN on a RAID 0+1 setup.

    We are looking to break land speed records here, all their switches are brand new HP procurve, and the entire school is connected via 20G/Bit Fibre between buildings.

    What else can I tinker with to achieve max speed on image deployment?

    I am considering

    1. Jumbo Frames (anyone had any success?)
    2. Decompression of the image on the client end rather than the server end.
    3. Can I trunk the fibre channels???

    any other ideas ?

    Fog 0.32 will be used along with Fedora 15 64bit



  • the FUN just keeps on coming…

    DAY 3
    Decided to bond the NIC’s

    again… googled the hell out of it, surprisingly, there is no result for Fedora 15 nic bonding, save the official docs from Fedora that clearly articulates how to achieve bonding…

    HOWEVER, not once did they mention that you needed to chkconfig NetworkManager off, nor did they mention to service NetworkManager Stop…
    They failed to mention that when bond0 comes up, for some reason eth1 still holds an ip address, and that ifdown eth1 then ifup eth1 gets it to behave… then ifdown bond0 followed by ifup bond0…

    they failed to mention the horror when you can no longer ping anything… not even the router even though all settings in the ifcfg file are correct and you’ve quadruple checked ifconfig -a output…

    endless googling finally reveals that “perhaps” you may need to add a route by tying route add default gw 192.168.x.x dev bond0 which doesn’t seem to persist on network restarts…

    suffice it to say, blowing away the server and re-installing crossed my mind on several occasions…

    the result???

    I have internet access but I can only ping computers on the same subnet, all other computers on any subnet can ping me… thats fine for now because imaging is working… again…

    note to self… charge more for this $h!t in future…


  • Developer

    Sounds like you have been having some FUN. Thanks for documenting the process so the rest of us may be able to use the information on future troubleshooting.

    wow upload at 4.31 GiBs O.O I WANT IT :)



  • Ok… after much gnashing of teeth… the server is now up and fogging laptops… however, let me describe the pain involved…

    Day 1:
    Windows server 2003 - decommissioned and awaiting my Fedora 15 live ISO…
    CD Spins up, auto boot… server hangs…

    Take 2
    CD Spins up, boot with less gfx option. That works, and I begin the installation process.
    Drives selected, I can see the SAN drives - RADI 5, the local RAID which is RAID 1 configuration. Installation bombs saying unhandled exception error.
    Googling reveals that Fibre has to be disconnected or it may cause errors in the setup process…
    Take 3
    This time, disconnect the fibre prior to booting and all goes well, partitions are created and boot loader is installed. Reboot the machine to be confronted by "no boot disk, please insert and press any key… "

    Take 4
    Same as take 3, but this time, it boots and I’m in Fedora… YAY!
    yum update is downloading 410mb at 2.5kb/s… WTF?? lol…
    During updates, I load the multipath driver (after extensive googling)
    kill the update process, install fog…
    fog bombs on php-gettext, google some more and make edits to the functions.sh file to remove the culprit.
    fog completes the set up, we change the DHCP server to point to the new fog server and… TFTP permissions issue… all suggested fixes on this site and others do not yield a result… not to worry, i’ll fix it tomorrow…
    restart updates and leave the updates running over night at 2.5kb/s (while browsing and other internet activity are at lightning speeds).

    DAY 2
    Updates are finished, hoping the TFTP issue will resolve itself (magically) post reboot and to ensure updates are applied, I reboot the server and …
    multipath has decided to take over the local RAID and now fedora wont boot…
    googling reveals that I should have black listed the local raid with its WWID in the multipath.conf file… wish I had read that before frying the damned thing and re-installing fedora 15…
    this time, even more googling (we are now up to a cumulative total of 5 hours of solid googling) reveals the magical command that reveals this WWID for the local raid, because the conventional one wasn’t working (multipath -v2)… scsi_id -g -u /block/xxx reveals the WWID and I add it to the black list… 4:00pm and fog appears to be up and running smoothly…
    mounting the /images folder was a pain and several issues with permissions, mount point does not exist… yada yada yada… 5:00pm, I take up the first image… at a blistering 4.31GiB’s …

    Still left to do:
    Team the Ethernet Cards (when I tried to do it on day one following the tutorial in here, I just ended up losing the ability to browse internet, and connection would come in and out).
    Permanently mount the SAN to /images at boot time (you would be surprised the problems you get when you try to fstab it).

    if anyone is interested, I am happy to put up a tutorial on WHAT NOT TO DO… when embarking on such a setup!!


  • group:cid:13:privileges:mods:members

    Having used RAID for a long time, RAID 10 isn’t significantly faster, but does allow for potentially more drive failures than RAID 5. I would strongly look up the RAID 5 write hole, [url]http://www.raid-recovery-guide.com/raid5-write-hole.aspx[/url]. While no RAID is perfect, 5 is being revisited as not being all that reliable due to the nature of the write hole. RAID 10 is a little better for this, but make sure you never lose power to the system when it’s writing or you’ll lose all the data as well.

    However, for me, up time and reliability was more important to me than capacity. So RAID 10 was my choice. I could have a potential greater loss of drives at 1 time without losing everything, so RAID 10 was the route I chose to go. If I were to do it over, I may look into RAID 6 next time.


  • Moderator

    good read for those interested on raid lvls [url]http://community.spiceworks.com/topic/352280-obr10-vs-raid6-metrics[/url]


  • Senior Developer

    For this particular setup, the mirroring process is still there so RAID 10 isn’t really going to have a huge speed increase… RAID 5, on the other hand, allows more space available to the system and I believe is faster than RAID 10. RAID 0 is the fastest, but it, for most things, essentially is JBOD as long as all disks are the same size. So you gain loads of speed, but have no redundancy. I’d say go with RAID 5 or 6 for this particular setup if you’re going to do RAID. I say either 5 or 6 because they are basically the same. RAID 5 only requires one drive for the parity bits, meaning if you lose a drive, you can just hot-swap it and once rebuilt, you’re back on track. RAID 6 if if you’re worried you may lose more than one drive in the setup at a given time. It is similar to RAID 5 but requires 2 drives for the Parity bits. I only say this if you’re looking for some redundancy with high Speed availability.



  • [quote=“chad-bisd, post: 16729, member: 18”]Does RAID 0+1 have better read speeds than RAID5? The majority of the work will be read, so pick the fastest disk organization that also has redundancy.

    Will you primarily be multicasting or unicasting?

    Do you have any experience with Jumbo frames so you have a working knowledge?

    How much free time do you have to learn all this new stuff or do you need to have a working system asap?[/quote]

    I believe RAID 0+1 is RAID 0 with Mirror, theoretically, RAID 0 is the fastest no? I am open to suggestions…

    Multicasting vs unicasting is about even…

    I have tried jumbo frames before to no avail… i have enabled jumbo frames on the switches and then booted fog in debug mode, enabled jumbo frames on the PC and continued with FOG, but i didnt see any improvements… was hoping someone else had some experience…

    I’ll be installing on Monday and need to start imaging by Tuesday, I will try and post some screen shots of the speeds I am getting…


  • Moderator

    Does RAID 0+1 have better read speeds than RAID5? The majority of the work will be read, so pick the fastest disk organization that also has redundancy.

    Will you primarily be multicasting or unicasting?

    Do you have any experience with Jumbo frames so you have a working knowledge?

    How much free time do you have to learn all this new stuff or do you need to have a working system asap?


  • Developer

    Sounds awesome, keep us posted I want to know what speeds you hit!


Log in to reply
 

424
Online

38951
Users

10701
Topics

101530
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.