Having issues with Win 7 x64



  • Hi Guys,

    I am using Fog 0.32 on Ubuntu 10.04. I have created, uploaded and deployed a Win7 x32 image perfectly fine without any issues whatsoever.

    I can’t say the same for Win7 x64, everytime I go to upload the image it comes up with

    unable to move /images/dev/(mac address) to /images/

    It can’t be a permissions issue as I can do x32 images fine, will it have an effect if it’s Legacy/EFI?

    Does it matter if it’s AHCI or IDE?

    Could somebody please assist, I am seriously struggling.

    Thanks guys

    Kam



  • i have hp system with Win7 and three partitions i can do upload the image and it does with all partition but one parttition d1p3.img has size of 340 Kb actually its is 30gb partition with data of 26GB. i can restore the image but while restoring the parttition d1p3 it does not locate image file and ask for full path.



  • Well… I tested bzImageCORE today but it doesn’t work. I can imagine how it’s hard to debug without the right disks ! For my emergency, I’ll clone with my old Acrns DVD, this will be slower but it doesn’t matter ;-)

    At work we use a lot Fog, it saves us lot of time ; so we seriously consider the possibility of donating. But it’s very hard for us (French Public Administration) to make a donation 1) with PayPal 2) to a non-organisation :-) (but we’re working on it).

    The first thing we could do is to buy equipment, for example 1 or 2 AF drives… Would it help you ?


  • Senior Developer

    As a side note, my core now contains all network drivers and shouldn’t try kms.


  • Senior Developer

    JiC,

    As you’ve updated to 0.33, to allow for other hosts to register, check the forums. I uploaded an auto.register.php script in the FOG Bugs 0.33 forum.

    For your AF drives, I’m working on editing the fog script, but I don’t have AF drives myself.

    I don’t even know if we have AF Drives where I work.

    I know I ran into an issue, at work, with my “minimal” kernel imaging an HP ProBook 6475b, but I created a CORE kernel, and that fixed the drive issue for my work place.

    Maybe try another kernel:
    [url]https://mastacontrola.com/fogboot/kernel/bzImageCORE[/url]

    I don’t know if this will help you out.

    I’ve already found out how to allow parted to create partitions under AF setup, but I have no method of testing without those types of drives in my possession.



  • I set my image with “Windows 7” OS and “multiple partition-single disk” ? (I have 2 partitions on my disk).


  • Moderator

    What image type are you specifying for your 64bit images? Are you doing single partition resizable, or multiple partition-single disk, or something else?



  • I checked : my disks are 4K / Advanced Format drives. Bloody hell :-)

    I saw that Fog 0.33b was able to manage AF drives, so I tried it today.

    When I make a new task to upload my image, FOG only upload the MBR (d1.mbr) in the /images/myimage/ folder. But no partitions :(

    When I try an image with debug mode, I’m stuck on an error :

    “/bin/fog : line 7 OS_ID_WIN7 not found
    /bin/fog : line 8 OS_ID_WIN8 not found”

    I patched /bin/fog (spaces before and after the sign “=”), but if I retry launching fog, the task was completed before so nothing happens (“Unable to find a valid task ID…”). I don’t know how to patch it for good in my FOG server.

    So I can’t check if Fog 0.33 will patch the AF Drives problem for me ?

    Notes for later - relative topics :

    [url]http://fogproject.org/forum/threads/advanced-format-drives.845/[/url]
    [url]http://fogproject.org/forum/threads/another-advanced-format-drive-question.866/[/url]


  • Senior Developer

    Have you tried an upload with debug mode enabled, so it can spit out more messages on screen to help us narrow down the issue?

    I’d say try debug mode on an upload process of both types of systems (one that completes, and one that doesn’t) maybe this can help us out.



  • Hi Guys

    Just been checking out our 32bit machines and they all have 4k bytes per cluster. Bytes per sector is at 512.

    I did however bring it down on our x64 PCs to 2048 and I still got the same error message.

    Unable to move /images/dev/mac address to /images/image name etc etc.



  • Can we set it to anything 2048 and under?


  • Developer

    The hardrives that are currently being produced are of a “new format”. It uses a new method of storing sectors for use with partitions on magnetic disks in hard disk drives that exceeds 512 to 520 bytes per sector.

    The new format is for 4 KB native mode, there is no emulation layer; disk media directly exposes its 4 KB physical sector size to the OS.
    As you can see this is a new technology so until we completely understand it and it’s capabilities, and right now it doesn’t exactly work with FOG.



  • Well, I’m lost ^_^

    I can’t find any clue about “Advanced Format Drive”, it’s a basic Seagate Barracuda 250 GB, ST250DM000, Serial ATA III.

    When you ask me setting a custom layer, where should I do this ?? In FOG, in the BIOS of my computer ? Elsewhere ? I reached my level of incompetence :-)


  • Senior Developer

    Is the drive an Advanced Format Drive (4k)? It doesn’t make sense that it’s installed 32, but maybe 32 bit can’t support 4k byte sectors.

    Can you set do a custom layout and make sure the drive formatting for Win 7x64 is setup for 2048?

    Thanks,



  • I tried a new test ! Before installing Win 7 x64, I backuped up the hard drive : I kept the Win 7 x32 drive on a secure place, and I put in my computer a new and empty disk on which I installed Win 7 x64. Both disks are the same model (Seagate barracuda 250 GB).

    When I put the Windows x32 version, I can upload an image.
    When I put the Windows x64 version, I can’t upload an image. Only d1.mbr is written in the folder [COLOR=#333333][FONT=Arial]/images/dev/(mac address).[/FONT][/COLOR]

    It looks like if FOG is not able to read some disks where Windows 7 x64 [COLOR=#333333][FONT=Arial]is installed. It happens only on one computer (HP Compaq 8200 Elite). This computer has an EFI BIOS but I disabled EFI Boot Sources before installing Windows.[/FONT][/COLOR]



  • Hi Tom & Kam,

    I’ve almost the same problem.

    In june, I uploaded an image of a Windowd 7 32 bits computer, and I had no problems. I change the OS on this computer (same Windows 7, but this time x64) and I can’t clone it anymore. I have the same problem as Kamz :

    [I] unable to move /images/dev/(mac address) to /images/[/I]

    I think it’s a permissions problem, because I can upload others images… Even x64 computers !!

    The amazing thing is that on the FOG Server, in the “/images/dev/(mac address)” folder, the file “d1.mbr” is written. But no data from partitions. It’s like if FOG is not able to read Windows 7 x64 partitions ??



  • Hi Tom,

    Thanks for the reply. I can upload x32 perfectly fine even after this error? That’s why I assumed it wouldn’t be a permissions problem.

    I haven’t set those passwords myself, but there does seem to be a password in there. Please see attached.

    [url="/_imported_xf_attachments/0/394_fog.jpg?:"]fog.jpg[/url][url="/_imported_xf_attachments/0/395_fog2.jpg?:"]fog2.jpg[/url]


  • Senior Developer

    Also,

    The fog user on the linux system may need the same password setup as in your config as ftp usually uses the local username for this purpose.


  • Senior Developer

    It most certainly does sound like, and very well could be, an issue with permissions.

    Have you, since you received this error, tried uploading and x32 image?

    Did your FTP, TFTP username password change recently?

    It won’t have any problems mounting the /images directory as the mounted folder is actually:
    /images/dev which is setup as rw across the board.
    Where /images is mounted ro.

    I’d check your GUI under Storage Management->All Storage Nodes->{YOUR STORAGE NODE} and verify the username and password are correct.

    Then, check that Other Information->FOG Settings->TFTP Server that the [FONT=Ubuntu][COLOR=#333333] FOG_TFTP_FTP_USERNAME and FOG_TFTP_FTP_PASSWORD are correct (from my knowledge these should match that of Storage Management).[/COLOR][/FONT]


Log in to reply
 

485
Online

39.3k
Users

11.0k
Topics

104.6k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.