FOG 0.32 and Windows 8 Image Upload Problems

  • Hi I have read in a few posts that users have Windows 8 uploading and deploying using the current version of FOG. Does anyone have steps on how to accomplish this? Because right now I get errors when I try to upload my sysprepped image. Any help would be appreciated.

    [FONT=Ubuntubeta][COLOR=#000000]Mounting File System … mount: RPC: unable to send :errorno, reason given by server: Permission denied.[/COLOR][/FONT]
    [FONT=Ubuntubeta][COLOR=#000000]mount: mounting FileServerIP:/images/dev/ on /images failed: Bad file descriptor[/COLOR][/FONT]
    [FONT=Ubuntubeta][COLOR=#000000]Checking Mounted Filesystem …[/COLOR][/FONT]
    [FONT=Ubuntubeta][COLOR=#000000]An error has been detected![/COLOR][/FONT]
    [FONT=Ubuntubeta][COLOR=#000000]Fatal Error: Failed to mount NFS Volume.[/COLOR][/FONT]
    [FONT=Ubuntubeta][COLOR=#000000]Computer will reboot in 1 minute.[/COLOR][/FONT]

  • Moderator

    Updated link…


    There are some notes about steps that I did not need to perform since this guide is from 2007. But kernel compiling hasn’t changed that much theoretically, just the actual syntax of the commands.

  • The link in your post no longer works, any other guides I should check out?

  • Moderator

    I have a thread somewhere about an Acer Iconia Tab and compiling a custom kernel with new drivers. It may shed some light on this.

  • I have a Ubuntu 12 box I was using to try out .33, I can do it there. I will have to look up a guide for compiling the kernel. So I will have more posts incoming. lol

    Thanks for all the help.

  • Moderator

    Do you have a workstation setup for kernel compiling yet? It can be a VM in VirtualBox or VMWare?

    Once you have that, you can start the kernel config steps and see if the Atheros LAN drivers are already included in the config options. If so, it may be as easy as finding the source files and replacing them with newer ones. If not, you will have to edit the config options to add support for your new drivers and tell it how to compile the drivers during kernel compile time.

    It sounds daunting, but it’s not really that bad. I setup a VirtualBox running Ubuntu 11 desktop version, followed a quick guide on the internet to get the compile tools and source files for kernel version I wanted, then copied the original kernel config from the FOG download. I had to overwrite my old “Asix USB to Ethernet” drivers, which was under usb/networking/ somewhere. It overwrote the existing asix.c, asix.h and another file, and added an extra file. When I went into the config and told it to compile in those drivers, the new kernel worked. I got lucky in that I didn’t have to specify new config or compile options.

  • OK I have found the driver on the ASUS website, but how do I use it to create my own custom kernel. Atheros LAN Driver Version V2.1.0.7.

  • Moderator

    If the network failed and the disk passed, then your FOG client kernel probably doesn’t have the proper driver support compiled into it. What model and revision of the Atheros card is in this machine?

  • Developer

    UEFI isn’t exactly supported yet, we have talked about the addition in 0.33 but currently it is unavailable in 0.32, I would recommend adjusting your BIOS settings to something legacy.

    If adjusting the settings in the BIOS doesn’t work, you may have to build a custom kernel or use the kitchen sink. BUT Atheros cards normally function well with linux, I would first try adjusting your BIOS Settings.

  • Network Failed. Is it due to the fact it is UEFI? When I PXE boot the computer I use the Atheros Network card option.

  • Developer

    A. Set up your BIOS to boot from the network card as the first device OR if you have the option to choose the boot device do so and choose your network adapter.
    B. Your computer will look for a tftp server and download a file
    C. Your computer will display this file as the Pxe Boot Menu
    D. From the fog PXE boot menu, you will see:

    Boot from hard disk
    Run memtest86
    Quick host registration and Inventroy
    Perform full host registration and Inventory
    Quick Image
    Client system information
    Debug Mode

    E. Choose Client System Information

    F. Your computer will load another menu and it will look like this:

    1.) Reboot
    2.) IP Information
    3.) Partition Information
    4.) Check FOG compatability
    5.) Ping a Host
    6.) Display MAC Address
    7.) Show DMI Information

    G. Type 4 and press Enter

  • Sorry to sound noob, but how do I run a compatibility check? The unit I am trying to upload and deploy to is an Asus 1015E. I am running Ubuntu 11.04, I haven’t had a chance to upgrade that server to 12.04 LTS.

  • Moderator

    Run a compatibility check on the client to make sure your current FOG kernel can see the nic and drive.

    By FOG kernel I mean the bzimage file the client loads to run the client side tasks. Newer client hardware may require an update client kernel.

  • What is the OS you’re server is running on?

    In Ubuntu (Debian Based), NFS requires nfs-kernel-server nfs-common and portmap. In Fedora/Centos (Redhat based) NFS requires rpcbind and nfs (yum install nfs rpcbind; chkconfig rpcbind on; chkconfig nfs on; service rpcbind start; service nfs start)

    Check your /var/logs/messages files for errors that may lead you in the right direction. Also Check your /etc/my.cnf file for the binding address. my.cnf deals with the mysql side of the house and if it’s bind address is set to, and the system you’re trying to load is outside of the network your server is on (outside being vlan, subnet, etc…) it won’t be able to connect to the sql server properly to get the NFS information and load it to the client for mounting. (WHEW that’s a long sentence)

    I don’t know what else to ask so chad or anybody else with other ideas, or if I’m just plain an idiot, please feel free to step in.

  • Could you get the same error if the HDD is set to UEFI? Also before updating the kernel, if it was working I’d check the previously working computer could still be imaged first.This should help to better focus on where to look?

  • We have been using this server all year for imaging with no issues at all. I will try updating the kernel. What settings do you use for the Windows 8 image?

  • Moderator

    This doesn’t initially appear to be a Windows 8 issue, but rather an NFS mounting issue. Do you have any other machines that are able to upload to FOG (Windows XP, Windows 7, etc)?

    I’m thinking that maybe your FOG kernel doesn’t have the proper drivers for the newer hardware and can’t access the network, hence the nfs error.