FOG and More than 10 Unicast Clients



  • As for some unknown reason i cannot multi cast to the 200+ new dells a school as recieved the gigabit switch is multicast enabled and if i unicast to any one machine i get 3.5-4 gib/min but if multicast to 20 at once (24 port switch) they max out around 230mib/min… its a managed netgear and it is off network in its own… I’ve made sure anything multicast is on and up… So for whatever reason that won’t work. I am going to get stuck unicasting but i want to do more than 10 at a time … and i can’t seem to. at the magic 10 mark i get to sit and wait for one machien to fall off for another to start… I scoured the config and only saw a multicast max client setting… where is the Unicast?


  • Senior Developer

    Yes, our storage node is set to allow 15 clients as well as the other two places specified, but it still doesn’t work in our setup. It’s not a huge deal for us though, as our images are fairly small and everything is gig-e.


  • Moderator

    You actually change it under storage management, all storage nodes, edit storage node, set max clients there. I have raid 5 array and gigabit nic so I set mine to 20 clients per node.


  • Senior Developer

    I’m sorry. And I’ve noticed, with FOG 0.32, this doesn’t matter. We have all of our configs (even if deprecated) set for max of 15 clients, but as soon as 10 clients are downloading, the limit is met and anything after just queues up. We’ve restarted the server to make sure it wasn’t just a service needing to be restarted, and this didn’t help. It seems like the queue is set at 10 no matter what we do. Now I haven’t looked into funcs.sh or the /bin/fog script so maybe I’m just being silly, but it seems like it’s a constant that we can’t change for now.


  • Moderator

    [quote=“Tom Elliott, post: 14290, member: 7271”]Try this:

    In FOG Configuration
    Choose FOG Settings
    Look for:
    [FONT=Ubuntu][COLOR=#555555]FOG_QUEUESIZE and change the value there.[/COLOR][/FONT]

    [FONT=Ubuntu][COLOR=#555555]Then, just to be on the safe side, go to your config file and make the change at:[/COLOR][/FONT]

    [FONT=Ubuntu][COLOR=#555555]{fogwebdir}/commons/config.php[/COLOR][/FONT]

    [FONT=Ubuntu][COLOR=#555555]Look for Like:[/COLOR][/FONT]
    [FONT=Ubuntu][COLOR=#555555]QUEUESIZE and make the change there and save. You should be set to have more hosts imaging.[/COLOR][/FONT][/quote]

    The FOG QueueSize in the fog settings is really deprecated and the actual working value is handled per storage node settings as Gavin stated. The next version of FOG should remove most of the duplicated or unused settings fields.



  • [quote=“Gavin Behrens, post: 14303, member: 11980”]under storage management - all stroage nodes - default member(or whatever node it’s going from) there’s a field for max clients - the deafult value is 10. As a rule of thumb though I usually stick to multicasting to all hosts on the same physical switch as there can be some timing issues using xover-uplinks from switch to switch , though have tested on multiple switches that have had trunked vlans and all work fine at full speed 4.5GB/min. let me know how you get on.[/quote]

    Thank you very much :)



  • under storage management - all stroage nodes - default member(or whatever node it’s going from) there’s a field for max clients - the deafult value is 10. As a rule of thumb though I usually stick to multicasting to all hosts on the same physical switch as there can be some timing issues using xover-uplinks from switch to switch , though have tested on multiple switches that have had trunked vlans and all work fine at full speed 4.5GB/min. let me know how you get on.


  • Senior Developer

    Try this:

    In FOG Configuration
    Choose FOG Settings
    Look for:
    [FONT=Ubuntu][COLOR=#555555]FOG_QUEUESIZE and change the value there.[/COLOR][/FONT]

    [FONT=Ubuntu][COLOR=#555555]Then, just to be on the safe side, go to your config file and make the change at:[/COLOR][/FONT]

    [FONT=Ubuntu][COLOR=#555555]{fogwebdir}/commons/config.php[/COLOR][/FONT]

    [FONT=Ubuntu][COLOR=#555555]Look for Like:[/COLOR][/FONT]
    [FONT=Ubuntu][COLOR=#555555]QUEUESIZE and make the change there and save. You should be set to have more hosts imaging.[/COLOR][/FONT]


Log in to reply
 

367
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.