Problem to boot on PXE Unspecified file opening error detected



  • Hello,
    I tried an installation of FOG.
    The installation completed successfully, but when I want to boot from a PXE client, I get this error message: PXE-T00 unspecified file opening error detected PXE-E36 Error receveid fromTFTP server
    I followed the installation procedure as in the documentation and did not have any error message.
    The Fog server does not act as dhcp server because it is managed by another server.
    We added next-server and filename in the DHCP server configuration as shown. I put in filename pxelinux.0
    I saw that some people have /tftpboot/pxelinux.0, is this the case for you?
    I use ubuntu 12.04 server on a VMware virtual server.
    I also tried on another physical machine, but I have exactly the same problem.
    Thank you in advance for your help.



  • For my tests I installed a new one on a physical machine to go on simple bases.
    So I now myIP:69 with a netstat but it still gives me the same error on the boot PXE…
    I ping the machine well, I have access to the web interface of FOG, only the “PXE” does not work and returns the error message I mentioned in my previous post.


  • Developer

    How are your settings set up for your virtual machine? Were you able to get to web pages and ping hosts from the virtual machine?

    You need an IP address before TFTP can do any good :/

    I have only used pxelinux.0 in place of the file name, it should be all you need.

    Take a look at your card settings for you VMWare machine, my bet is something isn’t jiving.



  • thank you for your reply.
    I actually restarted the TFTP server with the command "tftpd-hpa restart services."
    A “service tftpd-hpa status” well said “running”.
    A “netstat-laputen | grep 69” returns:
    udp 0 0 0.0.0.0:69 0.0.0.0: * 0 19404 7562/in.tftpd

    (it’s weird just now I had my “IP address: 69” and not 0.0.0.0:69 … This is probably owed to my test)

    I would like to enable the log to see where it stuck but despite the addition of the-v option in the file / etc / default / tftpd-hpa I can not find a log to syslog.

    I also tested on a debian squeeze but I also have the same problem. My pxelinux.0 is with zero …

    Thank you in advance for your help.


  • Moderator

    did you restart the server anytime after installing it? Ubuntu 12.04 has a problem restarting TFTPD-HPA package properly, and you have to manually restart the service or modify the boot up scripts.

    Also, make sure it’s pxelinux.0 <---- Zero, not O


Log in to reply
 

401
Online

39.4k
Users

11.1k
Topics

105.5k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.