VirtualBox VMs don't fall through to local disk



  • I have a summer student working with FOG and he’s using VMs to get his feet wet. Using VirtualBox, he’s set up a FOG server guest and a Windows 7 guest. The Windows 7 guest will PXE boot, register, and upload an image (raw at the moment).

    The issue we’re running into is that PXE booting into FOG then on to the OS on the local disk doesn’t work. Instead it just hangs with a message ‘Booting to local disk…’.

    The same guest will boot Windows 7 fine if we turn off network booting in the guest’s VirtualBox settings.

    This seems like a VirtualBox related problem to us. Any ideas?

    VirtualBox 4.2.10 on Linux (Ubuntu 13.04). FOG 0.32.



  • I didn’t test this with physical hardware it was just something I seen when I was testing FOG in VM’s before moving to physical hardware and thanks for the addon there that now I know it will do the same on physical hardware.



  • Nothing to do with the VM, physical hardware with no partition on the disk will do the same. You need to restore from a full disk image.



  • I know this is a old thread but I have found out if the VM has no OS on the hard drive it will just loop over and over on the countdown.



  • falko, how do you boot the client to PXI? My machine hangs with a static place holder (underscore).


  • Moderator

    I would just like to add that Virtualbox is great tool and I have had it working with for for a very long time as both servers and images


  • Developer

    yeah that sounds to me like it is something to do with the ACER hardware or the way it handles the hard drives, I don’t recommend them, but all of our Tangent computers work well with FOG :)



  • We never figured out how to get a FOG server and client up and running in VirtualBox. I’m sure I initially tested FOG under VirtualBox successfully, but that was more than three years ago. I think it was just a case of choosing the right virtual network hardware and/or chipset.

    And I never got time to look at it myself, which happens at this time of year.

    We ended up setting up FOG on an old workstation (this is just to get the summer student acquainted with FOG) and tried imaging some new Acer desktops. It works, but there BIOS is a little funny. You can PXE boot or HDD boot, but you can’t PXE boot and then fall through to the HDD. So we have to change the boot settings in BIOS, image, then change the boot settings back. We won’t be buying any more of this model of computer.

    @Jaymes Driver, post: 12372, member: 3582 said:

    If you are still having issues I recommend using a custom built kernel, I had to do so to use VMWare, and I take back what I said before about VMWare, Stay on Virtual box, it’s a much easier program to use!!!


  • Developer

    If you are still having issues I recommend using a custom built kernel, I had to do so to use VMWare, and I take back what I said before about VMWare, Stay on Virtual box, it’s a much easier program to use!!!



  • Our summer student has kept pushing on this, and looked into an alternative to pxelinux. I think I’ll set up a FOG test environment myself in a VBox test network sometime soon…but I’m on vacation at the moment. It will have to wait at least until Tuesday.


  • Developer

    Sorry I never got around to looking at my Virtual box I’ve spent all week in the attic running networking cable!!! did you get this resolved? I can try to get a look at the box Monday.



  • We ran into this link on chain-loading in the FOG documentation. We’re looking into this now.



  • We’ve looked into this a bit more, trying physical machines and… We get the same problem. This is really strange as we’re just using a standard FOG .32 install followed by upgraded to the newest kernel, but any machine PXE booting from FOG won’t then be able to fall through to boot off its local hard drive.

    I really want to repeat what the summer student has done to confirm it for myself, but I can’t really see how one could mung things up in a way that would have this affect.


  • Developer

    Sounds like a VB problem, and you shouldn’t do Virtual images for pushing from Virtual Box, at least form what I am told.

    We use VMWare for our virtual images, I was told that it works better (?) I don’t know if there is any truth to this I am still very new to VMWare, but I have been scolded by many for using VirtualBox. I was told that with VMWare you can inject drivers and then sysprep so it can grab drivers during set up. I have my images made but I’ve not pushed them to FOG yet or to any physical box to try it out.

    [B]HOWEVER,[/B] I have used VirtualBox to get my feet wet with sysprep and uploading to FOG and I have had success. The problem you might be running into is using the RAW format to upload to. I ALWAYS set my images to a Multi Partition. Try going to Image Management and changing the disk type to “Multi Partition - All Disks (Non Resizable)” and see if you are able to get past it PXE boot.

    If not change it back, no harm no foul.

    I will look into my VirtualBox settings and see what I have set up. Good Luck in the mean time!


Log in to reply
 

328
Online

38724
Users

10553
Topics

99907
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.