Invalid Operating System (D5) Capone & Windows 7



  • .Hi guys

    Im having a problem with Capone and some Computers i need to image,

    I get:

    Looking up DMI Field…Done

    Looking up Images…Done

    Then it Says

    An Error has been detected.

    Invalid Operating system id (D5)

    Then The computer shuts down.

    Any Ideas?


  • Developer

    My init.gz fixes the problem for 0.32, if anyone else needs a copy send me a message.


  • Developer

    It sounds like the name is wrong, but it looks right.
    I’ll grab a copy of my working init.gz for you later today, and stick it on google drive for you.



  • 755 matched them all up. Owner/group of all files was “root root” already.

    Okay, some progress?

    Now I get:
    /etc/init.d/S99fog: line 72: /bin/fog.capone: not found

    I looked and line 72 is:
    $run;

    Which appears to be the result of else if on line 56-57:
    elif [ “$mode” == “capone” ]; then
    run="/bin/fog.capone";

    Which looks peachy to me. Thanks for sticking with me on this. I’m going to get it one way or another!

    .<
    Chris


  • Developer

    Hi Chris
    That rings a bell.

    If you copied the file in you’ll need to chmod the file, as it probably got dos permissions, which don’t come across into unix ones.

    If you go to the folder and do
    ls -l
    it will tell you what the others are

    ls -l fog.capone will give something like
    -rw-rw-r–
    which is 664, ignore the initial “-”, it is the sticky bit.
    it will tell you what the others are, fog.capone needs to be the same.
    At a guess they will be either 755 or 777

    to set them you do

    chmod 755 fog.capone

    also check the ownership, and change as necessary with

    chown <username> fog.capone.

    at the end it should look the same as the others.



  • Thank you for the link.

    I followed all the steps and now the capone module shuts the machine down after displaying

    Starting network…
    ip: RTRNETLINK answers: File exists
    /etc/init.d/S99fog: line 72: /bin/fog.capone: Permission denied
    The system is going down NOW!
    Sent SIGTERM to all processes

    So it just shuts down in a huff.
    I just copied the file over after using the Boot Image Editor utility. (had tried editing using the manual method but figured I was screwing something up that way)
    Do I need to change permissions on the fog.capone file in the zip? If so, what should they be changed to?

    Sorry, my UNIX classes were 1986 or so and I may be a little rusty.

    Chris


  • Developer

    It is a problem with the fog.capone script. It has been fixed in 0.33 however the 0.32 problem is documented here with a fix.
    [url]http://fogproject.org/forum/threads/capone-and-fog-0-32-not-working-errors.192/#post-762[/url]

    essentially.
    copy init.gz (just in case it all goes wrong)
    uncompress init.gz
    mount it
    edit /bin/fog.capone as per the instructions
    unmount init.gz
    compress init.gz

    Hope this helps.

    PS
    the modified fog.capone is in the link above, which will save you editing it.



  • Did anyone ever find a solution to this issue? We are having the same problem here with a new install.
    Fog .32, Ubuntu 12.04.4 Windows 7 Pro images coming from identical model machines.
    Error is "Invalid Operating System id (i5)



  • Is this your original fog server? We had an issue in another district when migrating certain images off to another fog server and when manually recreating the image definitions, it would error out with the same message. We ended up having to migrate the entire /images directory versus just the select images that were used at that site.


  • Moderator

    I’m not as familiar with Capone as the rest of FOG, but try changing the image name to something without spaces or special characters and see if that helps. Just a guess, but the bash script that is processing your request may error out on the name, but display a misleading error message.



  • Still having no luck with this. If anyone can help that would be great. Doing these machines one by one is a real pain :D



  • Okay i just finished trying all of them. Same problem just with different numbers.
    I also tried deleteing the image and host and re-registering with re image upload and no avail.


  • Developer

    Try a few different ones, just go thru the list, keep track of what they say, I’m sure Chad will be able to sort it out XD.

    I know that the problem is stemming from the Image and the OS selected.



  • Okay i tried switching it to Vista, Now it says:

    Invalid Operating system id (D2)

    Instead of D5 :/


  • Developer

    Try to set it to “vista” someone else had an issue pushing windows 7 images but resolved it by selecting “Vista” under OS type.



  • The Host OS is Windows 7, For my machine. I did a quick Registration then set the host OS in the Web GUI

    See Screenie :)

    [url="/_imported_xf_attachments/0/306_Screenshot from 2013-05-08 11:23:30.png?:"]Screenshot from 2013-05-08 11:23:30.png[/url]


  • Developer

    Quick question, when you registered the computer as a host, did you specify the OS?

    If you did a quick registration you need to specify the image and OS associated with that Host on the Host Management of the FOG web GUI. If you did a Full registration did you specify which image is associated with the host? If not, you can set it in the Host Management.


Log in to reply
 

373
Online

38976
Users

10712
Topics

101675
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.