No disk usage (free space) information for another storage node (nfs)



  • Hi,

    i’ve setup fog to use its default storage node and i added an additional storage group and within this a added a storage node that point to an nfs share like 172.19.102.6:/images, i also have this in my fstab as mountpoint /images2.

    When iam in a shell on the fog server and i type mount i see that /images2 is correctly mounted i also can see the files and dirs in it. If i type df i will see the free space from all drives including /images2 but that information cannot be displayed in the fog webif i can so only cannot connect to xy for the default local storage this is working.

    Which Method is used to check free space?
    I thougth that will be nothing else then a local df or something but it seems not.

    What are the possibilities why this doesn’t work? Any clues or ideas?

    Greetz X23


  • Moderator

    Make sure FTP works on your nodes, and check credentails for those nodes inside storage management.

    https://wiki.fogproject.org/wiki/index.php/Troubleshoot_FTP

    There is also credentials inside FOG Config -> FOG Settings -> FOG Storage Node -> Mysql credentails.



  • Hello,
    I’m new to the list and I use FOG for 4 years. I am now an administrator who wants to use the FOG with high availability. I have the following architecture:
    Debian8 - FOG 1.2 on 3 machines.
    • 3 different geographical zones (ZoneA, ZoneB, ZoneC)
    • 1 master node fog in ZoneA
    • 1 mist storage node in ZonaB (StorageNode-01)
    • 1 mist storage node in ZonaC (StorageNode-02)

    I have a problem with the display in the “Dashboard”.
    I searched the forum and found no answer.
    Looking at the code I found a small error in the file “/var/www/fog/status/freespace.php”
    Capture02.PNG
    Capture01.PNG
    Capture03.PNG But I can not seem to display the graph because the page: http://192.168.227.44/fog/status/freespace.php?id=6 goes to http://192.168.224.44/fog/status/ page freespace.php? idnew = 6 (192.168.224.44 being StorageNode-01) and wants to access the database is not accessible http:// 192.168.224.44/fog/commons/schemaupdater/index.php!
    Capture04.PNG

    Can you tell me what to do?
    Tank
    Good luck been using FOG for about 4 years love it every day.





  • You still don’t understand.

    You can use your FOG server 172.19.102.17, you have mounted your NAS storage on it? You just use /images2 on 172.19.102.17 rather than the /images.

    Your too busy trying to fix the freespace issue and not seeing the bigger picture. Have you tried deploying images yet? Other things are not going work too because NAS box is not a FOG storage Node!

    What FOG services are running on 172.19.106.6? None, so how can you define it as a fog storage node?



  • Hi,
    [LIST]
    [][I]my FOG Server has a external NFS share mounted to /images2[/I]
    [
    ][I]my FOG Server IP is 172.19.102.17[/I]
    [*][I]i don’t use FOGs local Storage Node! my VM’s HDD is only 8GB![/I]
    [/LIST]
    i’ve workarounded this by editing the freenode.php in this way:

    replace:
    [CODE]define( “SPACE_DEFAULT_STORAGE”, “/images/” );[/CODE]

    with:
    [CODE]define( “SPACE_DEFAULT_STORAGE”, “/images2/” );[/CODE]

    replace:
    [CODE] // make HTTP request
    $URL = “http://” . $Node[‘ngmHostname’] . SPACE_DEFAULT_WEBROOT . “status/freespace.php”;[/CODE]

    with:
    [CODE]// make HTTP request
    $URL = “http://172.19.102.17/fog/status/freespace.php”;[/CODE]
    Maybe using localhost instead of using ip address would be the better decision?!

    Now i have the free disk space both for DefaultMember and my additional Storage Node:

    [IMG]http://i.imgur.com/hOgX4Br.png[/IMG][IMG]http://i.imgur.com/aCPjtwF.png[/IMG]

    Greetz X23



  • I’ll try an be more clear this time. You can not define your NAS box as a FOG Storage node, its not. Think of your NAS box as a bunch of disks that many operating systems can share. The FOG server that’s mounting disks from the NAS box is the FOG storage Node.

    Another OS example might help:-

    If you had a microsoft server running IIS7 for a website and its storage was mounted from your NAS box. Would you point your browser to 172.19.106.6 to view the website or the microsoft server?

    The application services are on your FOG server not the NAS box. Your NAS is just a bunch of disks that can be accessed from the network!.



  • Hi,

    thank you for the information. How should i install FOG on a Storage Server? Not possible because the Storage Server has it’s own Operating System. It would be nice to have an option to tell that the freespace check also works with an additional local path.

    Iam not using the defaultmember storagenode that is predefined, will this work if i disable the defaultmember and only have the additional mounted nfs share on another server?

    If you say path …/freespace.php isn’t available that the check works like openening the url to the freespace.php file
    on any additional storage node? Then it’s really no wonder that it doesn’t work.

    [B]EDIT:[/B]

    [B]Can someone tell me where i find the part in the php scripts where it will connect to anothers storage node freespace.php link? Maybe i can change the part in the script to let it check an additional local directory.[/B]

    Greetz X23



  • Looks correct to me.

    Your NAS box is not a true FOG storage node (FOG software not installed) i.e path /var/www/fog/status/freespace.php does exist on your NAS box 172.19.102.6.

    If it was a normal Linux box you would modify /var/www/fog/status/freespace.php on 172.19.102.6
    [CODE]define( “SPACE_DEFAULT_STORAGE”, “/images2/” );
    [/CODE]

    Same node can not have more than one mount point for images.



  • Hi,

    when i change the storage node dir in the freespace.php from /images to /images2 the additional storage node free space is displayed correctly but not at the correct storage node the freespace from /images2 will then displayed for the default member.

    So changing the path from /images to /images2 is working but why isn’t it working when i change the storage node in the webif dashboard?

    Help please.


Log in to reply
 

369
Online

38982
Users

10712
Topics

101680
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.