HELP!!! FOG server working good until next day.



  • I installed Kubuntu 12.04 then updated, then installed FOG.
    I went through all the setup and tested capturing an image and deploying.
    Everything worked great yesterday.
    Today I go to start creating another image and no PXE booting from my test machines. TFTP timeouts.
    Maybe I have to start from scratch EVERY day?

    Any suggestions. I am a noob to this whole thing.

    Thanks in advance.



  • I changed the master user and password for my server login to match the same on the FOG system(for storage node).


  • Moderator

    One important note no matter what version of Linux you use. DO NOT MAKE A FOG USER WHEN INSTALLING THE OS. So many people start loading up a new server and decide that FOG would be a good user name (it is a FOG server after all). This generally leads to many things not working out of the box. Create just about any other username, and let the FOG installer create the fog user.


  • Developer

    I can not promise that downgrading will solve your NAS issues. I recommend downgrading to 10.04 if you do not like to restart the TFTP-HDA service after each reboot. The command can be scripted and I am waiting for a reply to see if we have a resolve for this.

    All functionality of FOG is available with newer revisions of Ubuntu, but starting after 10.04 Grub was changed and a few other things causing TFTP-HDA to start before the machine has the opportunity to get and IP address, and this causes your TFTP-HDA to be unreachable until you restart the service. I hope I’ve made this as clear as possible.

    Any NAS problems, I would start by first making sure that the users have the proper permissions to the space you are trying to save to.



  • We are having some problems with Ubuntu 12.04.2 LTS and fog 0.32 --> Specially trying to save the images to our NAS. Before moving forward I just want to confirm that by downgrading ubuntu server to 10.4 will help with our solution. (Just trying to save some work time).


  • Developer

    Awesome I’m glad you got it!

    What was the resolve? It’s nice to let others know how you solved your problem if/when they use the search feature!



  • GOT it!!!, thanks to all of you for your help.



  • Now that I have done this, no task will start.
    “Unable to start task.”
    "Unable to connect to TFTP server."
    If I change that random super long password back in my settings, it will start the task just not reach the FTP connection to the server.


  • Developer

    Go to the Storage Management section. list all storage nodes and select the one the one that is being used (in my case it was the ‘default member’).

    Check the username and password there and make sure there is a corresponding user account on the fog server with the right access priviliges on the images folder shown in fog managment.

    In my case it was set to username ‘fog’ with a very long password. I don’t know how this ended up as ‘fog’ instead of ‘fogstorage’ but it appeared to have been configured with some randomly generated password.

    [url]http://fogproject.org/forum/threads/ftp-connection-to-storage-server-has-failed.556/[/url]



  • Well I went with Ubuntu 10.04…everything seemed fine, until I try to upload my first image…it gets to the end then: “FTP connection to storage server has failed” over and over and over and over…makes me want to scream…


  • Developer

    There’s no need to re-install the OS it won’t solve anything except after first running the installer it will start the service again, then after you reboot it will happen again.

    IT IS A KNOWN ISSUE with 12.04, if you’re going to nuke and start all over, use an older version like 10.04, I’ve done so and it has eliminated the problem you are facing right now.

    It is also not THAT big of a deal, a quick simple command will start the service again you just have to remember to run it each time you reboot, and that command is [B]sudo service tftpd-hpa restart[/B]

    If after re-installation and checking the TFTP boot and you are still having issues we can help you to get it pointing to where it needs to and also help with DHCP issue;, but first, try to restart the service, or use and older linux revision, 10.04 and fog 0.32 work very nicely together!



  • I rebooted it, completely shutdown, ETC…
    I am in the process of re-installing the entire OS at the moment…
    I will try your suggestions when I get it back up.

    Thanks


  • Developer

    [FONT=sans-serif][COLOR=#000000]Did you reboot your server? There is a known issue with Ubuntu revisions of 12.04 and higher, the service does not start at the right time and thus causes problems. First check to make sure your TFTP service is running by running a few commands.[/COLOR][/FONT]
    [FONT=sans-serif][COLOR=#000000] [/COLOR][/FONT]
    [FONT=sans-serif][COLOR=#000000]From your FOG server test out tftp[/COLOR][/FONT]
    [COLOR=#000000][FONT=monospace]tftp -v X.X.X.X -c get pxelinux.0
    [/FONT][/COLOR]
    [FONT=sans-serif][COLOR=#000000]From a Windows PC run at the cmd prompt:[/COLOR][/FONT]
    [COLOR=#000000][FONT=monospace]tftp x.x.x.x get pxelinux.0
    [/FONT][/COLOR]
    [FONT=sans-serif][COLOR=#000000]If tftp & xinetd are running your should get:[/COLOR][/FONT]
    [COLOR=#000000][FONT=monospace]Received XXXX bytes in X.X seconds…[/FONT][/COLOR]


Log in to reply
 

342
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.