Removed fog user from WebUI and can't get back in with new user I created

  • So…I did something stupid. I removed the “fog” user from the WebUI and then created my own account and made a password. Left and did a few things and when I went and tried logged to back into the WebUI it would not let me in. I went into the MYSql and changed the password multiple times but still no luck. Any ideas on how I can get back in?

  • Developer

    edit your /etc/rc.local

    to include
    /bin/sleep 30 && /etc/init.d/tftpd-hpa restart

    this should tell your linux to restart the service in 30 seconds after it starts this should take care of having to manually enter the command after a reboot.

  • Moderator

    There are a few threads on these forums about adding in a sleep period to slow tftpd-hpa startup, giving the interface time to come up. I still don’t know if Ubuntu has figured out a fix as the tftpd-hpa startup procedures seem to be in flux between init.d and upstart status.

  • Oh wow. Yea, I would of never figured out that the tftpd-hpa service wasn’t even started.

    Thank you very much for your help. It looks like it’s back up and running. I guess I’ll have find a start up script to make sure that starts every time on boot.

  • Moderator

    12.04 has a problem with tftpd-hpa starting before the interface is up. There are threads to help delay tftpd-hpa on boot up, and it’s an Ubuntu issue, not a FOG one. Make sure TFTPD is running and working, or just restart it manually and verify it’s working by downloading the pxelinux.0 file from a tftp client.

    Also, verify the syntax in your menu file. From the article, it appears the menu file needs a section like the code below. Just verify you have everything exact except for the different IP address.

    [CODE]LABEL linuxpxe
    MENU LABEL Linux PXE server…
    #IP address above is Linux PXE host[/CODE]

  • 0.32 on Ubuntu 12.04 LTS.


    I followed the instructions there.

    Had some issues with network not connecting on Ubuntu yesterday with the network manager not being up. I can connect to the FOG using the WebUI.

  • Moderator

    I’m not sure how to help you. What version of FOG on which OS? What customizations have you to do your PXE boot setup?

  • Looks like fog does not like spaces in user names so once my programming friend got here he fixed the name in the PHP table and I was able to log in. Now I’m just having issues with connecting to FOG from PC. It worked before where we have a menu where you pick WDS. FOG or Abort but if I pick FOG I get a

    TFTP boot: pxelinux.0
    pxechain: PXE_RESTART_TFTFP (000001)

    And it just sits there. Does that no matter if I’m going to FOG menu or deploying an image.

    This is not my week so far for random issues.