Goofed something up :(


  • Developer

    It’s nothing major but I can’t seem to find it anywhere, so let me begin.

    First off, Avid Linux user here, Love Ubuntu, or I use to back before unity :(

    Anyway, in the past we have used Clonezilla and I set up an SSH server with Ubuntu to house my images. Everything has gone well. I have started researching FOG, I’m very interested in it, it will make working in my labs a breeze and I manage multiple buildings, so I’m very excited to get it working!

    I installed FOG, and configured it, wow you guys have made that as easy a possible, I thank you. I have no problems.

    Using FOG has been a little different, and has taken some getting use to., I’d really like to do a lot more form the PXE menu, such as deploying and uploading an image without having to touch the server. Would be easiest to add a dialog where an admin can log in to do these features without having them available for my students to play with, but that’s to be discussed later

    Now on to the fun stuff:
    I registered my host, and uploaded my image. I registered a few more hosts and I pushed a few images out. Things went flawlessly, until I accidentally got a little excited during registration and I put in the wrong OS selection. Now that host is stuck in a loop, going back to the PXE menu and spitting back to me that there is an Error(0) Invalid OS Selection, and reboots in a minute.

    I tried to edit the host manually on the FOG server and I managed to save the information, but I still get the same error. I even tried deleting the host so it could be re-registered with the FOG server.

    Is there a way to kick it out of the loop it’s in where it wants to load up and image? Can I get it back to where I can register and try to deploy my image again?

    Any help would be greatly appreciated, thanks.

    The machines I am using are Tangent computers with Windows XP SP3 installed.



  • Let us know what you come up with for the PXE boot menu wont you? I’m intrigued and interested in doing similar things.


  • Developer

    Yes, Thank you Bryce that was exactly what I was looking for, had a lingering task just had to get rid of it!

    I agree Steve, the UDP is VERY nice, but working from a command line is nice too :) I like the best of both worlds, I’m going to be looking into my own scripting for the boot menu and see if I can add some extra features in there!

    Thanks all for the help!



  • If it’s continually booting into FOG as if it has a task, meaning not just the FOG boot menu, then there is probably still an old boot file for that machine sitting on the server. Make sure any tasks for it on the server are killed, then go to /tftpboot/pxelinux.cfg/ on the server and look for the file that matches the MAC address of the host you’re having problems with. Delete that file. That will take care of any lingering tasks.

    If you’re just going to the FOG boot menu and then after the timeout it’s telling you invalid OS then it looks like your MBR is messed up and I’d suggest reimaging with the correct image and OS id.



  • Working from the PXE menu is very cool. But the ultimate coolness is the ability to UDP multicast which does require the Fog server interface. I use it at the school where I have 120 desktops that all share the same image. I haven’t pushed the limits as to what this can do yet, but last summer we had 40 desktops imaging at once with little degradation of performance. That one feature makes Fog the best imaging software EVER. Can’t wait to see 0.33. Many thanks to all the Fog developers who devote a lot of their time to make my job much easier.


  • Developer

    it is the same as this issue

    [url]http://fogproject.org/forum/threads/invalid-operating-system-id-0.864/[/url]

    I did not want to bump an old topic and it was never resolved :(


Log in to reply
 

400
Online

39.3k
Users

11.0k
Topics

104.4k
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.