• I have 300 HP dc7900p and I updated to Fog 1.5.9
    But, for some reason I cannot understand, now when I boot from PXE it stops after the “init.xz…ok” message.
    I tried to use severall files as my undionly.kpxe (intel.pxe, intel.kpxe, intel.kkpxe, ipxe.pxe, ipxe.kpxe, ipxe.kkpxe, undionly.kkpxe), and used a lot of different Kernels (defined in the Host Kernel), but withouth any sucess.


    If I choose the bzImage32, it shows a message ACPI BIOS Error

    Even tried using Kernel.TomElliott. and FOS based on Linux Kernel 5.15.34/buildroot 2021.02.8, that I got from https://github.com/FOGProject/fos/releases), but got no positive results.

  • @george1421 , thank you for all your time. I will try it.

  • Moderator

    @pcrispim I didn’t realize there was no init set function. I guess that is something we can ask the developers to add into 1.5.11 (v1.5.10 is already locked for pre release).

    Looks like you will need to go with option A and add the updated inits to the global settings. As I said what I made is exactly the same thing that ships with FOG with just the restriction on the kernel lowered. It should work just fine for all platforms. The only reason I added “should” is that we have not tested it widely.

  • @george1421 , good morning!
    I already had a group and placed all HPs in there (it was the last image I sent you).
    But, as I showed you in the last image, there’s no option in FOG Groups to set the Host Init (I will post the image below, once again).
    Is there another way to set it?

  • Moderator

    @pcrispim That’s great we have one and done.

    Now you have an option. For the init.xz file. You can update the global setting so it impacts all systems to use the init.4.15.2.xz virtual hard drive. There is no functional difference between the FOG shipped init.xz vs init.4.15.2.xz. Just the latter has the minimum kernel level reduced to 4.14.x.

    The other option is going to be the same for updating the kernels.

    Create a FOG group that contains all of these ill HP desktops. Once you have the group of computers defined then you can use the FOG Group set feature to update all of the hosts in the group with your downgraded kernel name as well as the downgraded init.xz name. Think of the FOG Groups function as a Set group and not a persistent group.

  • @george1421 It worked…
    Did all you told me to do:

    1 - Downloaded the file to /var/www/html/fog/service/ipxe and renamed it:

    2 - Went to host configuration and changed also the Host Init field:

    3 - Booted my machines with PXE and it worked. The process wsa the following:
    (previous image was already changing, so it’s a little messy, sorry)

    But then… it started:

    Thank you so much!! You were a true blessing.

    To finish, now I can se my “KERNEL LOG LEVEL” back to the previous value, right? What value should I use, so it doesn’t show all this messages - 3?

    And, is there a way I can configure a group to use that Host init, like it is possible to do with Group Kernel:

  • Moderator

    @pcrispim OK here is the download link.


    rename this as init_4.15.2.xz and save it in the same location as the bzImage kernel you downloaded.

    Then go into the host definition and change the init field to init_4.15.2.xz

    So what is this file? It is FOG v1.5.9.115 version of the FOS Linux engine. I changed the minimum requirements from Linux 5.10.x kernel to 4.14.x kernel to hopefully allow the 4.15.2 kernel to work and actually boot into FOS Linux. I did zero testing on my part so you are the test candidate.

    If it works then we can talk about next steps.

  • Moderator

    @pcrispim It should be yet today. I started the compile this AM and just went back and there is an error. Working on that now.

  • @george1421 said in Fog stops at init.xz...ok:

    Let me see what I can do. I might have to create a custom virtual drive too that has this block removed

    Well, thank you so much. Just to plan my schedule (don’t want to put pressure because you are so helpful), how long do you think this is gonna take?

  • Moderator

    @pcrispim Well this is now an issue with the virtual hard drive, it has a minimum level of kernel value set. Let me see what I can do. I might have to create a custom virtual drive too that has this block removed. We don’t usually have someone that needs to run a really old kernel because of the hardware. But on the plus side The kernel is working on this hardware up to the point where it connects to the files on the virtual hard drive. So once we get pass this kernel too old error it should work for you.

  • @george1421 Done what you asked for!
    1 - Downloaded Kernel 4.15.2 64 bit and renamed it to bzImage4.15.2:
    Placed it in the directory and set the right permissions:
    2 - Configured the host to use that specific Host Kernel:
    3 - Started the machines and boot to PXE. Got this (2 computers):
    IMG14072022_02.jpeg IMG14072022_01.jpeg

  • Moderator

    @pcrispim OK good we have an ok starting point now.

    The older kernels are located here: https://fogproject.org/kernels/old/

    Download the 4.15.2 64 bit version and then rename it to bzImage4.15.2 That file goes into /var/www/html/fog/service/ipxe directory on the fog server.
    Lastly go into the host definition again for this HP and set the kernel field to bzImage4.15.2

    Now lets try it again to see if we can get the log information and that darn thing to boot into FOS Linux

  • @george1421 , indeed, it was the 4.15.2 Kernell (that’s where I can find it, in To Elliots, right?)
    I removed it and here is the result:

  • Moderator

    @pcrispim Ok that tells us that the kernel is not loading.

    Looking at the picture I see something that looks suspicious / non-standard.

    For the kernel its loading from fog/KERNELS/Kernel.Tom... directory path. Lets reset that back to the default value. I know it will cause an error with these HP computers, but what I want to see is it boot. Then we can bring in the older kernels. Right now we need to see the kernel startup.

  • @george1421 Thank you for your fast answer.
    I configured KERNEL LOGLEVEL to 7:
    Then, configured Kernel to use 4.15.2:
    When I boot the HPs, the same occurs and I get no extra messages:
    (these are images from 2 different HP computers)

    You mentioned a possible network related error. We had to move the Fog Server disks from one computer to another (both computers are exactly the same), because the server motherboard died.
    So, we really had to reconfigure de UUID and setttings from the NICs. Can it be related to that?

  • @george1421 said in Fog stops at init.xz...ok:

    FWIW: Those HP dc7800 and dc7900 are a pita to get to pxe boot well. The kernel for the dc7800s is 4.15.2 that works. Someone else in the forum just got it working what that old kernel.

    That was me. The only reason I was able to figure it out - the dc7800’s worked fine until I upgraded the FOG server. I just kept going back through the older kernels which were out around the time the FOG server was initially installed. 4.15.2 was the first one I came to that worked. Older ones would probably work too.

  • Moderator

    @pcrispim In the web ui -> FOG Configuration -> FOG Settings hit the expand all button. Search for LOG. Set the logging level to 7 for now. Then repeat the steps. I want to see if the kernel is actually starting or something is freezing after the virtual HD is copied over.

    FWIW: Those HP dc7800 and dc7900 are a pita to get to pxe boot well. The kernel for the dc7800s is 4.15.2 that works. Someone else in the forum just got it working what that old kernel. These are bios based computers so undionly.kpxe works just fine.

    If the kernel is not starting (i.e. you don’t see a bunch of text scrolling down the screen) then we’ve seen a network error cause this, but lets first check by adjusting the logging level.