New fog dont boot from ipv4 PXE


  • Hi,
    new fog installation here
    ver. 1.5.9
    ubuntu 20.4 LTS graphic interface (root wasnt activated at start)
    we have domain DHCP option 67 and 66 configured with correct IP and ipxe.efi
    all HP machines
    bios configured - (secure boot off, fast boot off, uefi only machines)

    I dont know If I forgot to setup something after we install fog yesterday, all we done is listed above. I updated kernel to newest from WebUi but didnt help. I think I might try change refind, but I am not sure is correct step now? Give me some hints please 🙂

    We are only seeing this, no errors, after a minute its movind to windows, cant access fog ui from boot
    805ed18c-91f8-41bd-baa1-20c29be10c34.jpg


  • @george1421 You were right, it was a problem with DHCP, our System team solved it by comparing it with another site, I don’t know the details, but it’s working now, Thank you for your help!

  • Moderator

    @mightmar Comments replied in chat.

    Summary the dhcp server 10.242.10.1 is not configured correctly for pxe booting. Both the dhcp header as well as the dhcp options 66 and 67 are missing (i.e. not configured in the dhcp server).


  • @george1421 I did sent you dropbox link to wireshark logs, let me know if you find something

  • Moderator

    @mightmar Ok some quick comments about your screen shots.

    On the tcpdump command running on the fog server. If the pxe booting computer is on a different vlan than the FOG server it will produce what you posted in the first picture. This is because pxe booting (more exactly dhcp process) uses broadcast messaging that is not typically forwarded across vlan routers. So this is understandable.

    The second one with wireshark. That is wrong on two points.

    1. You want to use a capture filter not a display filter. A display filter will work but then you capture every packet that goes by the interface of the wireshark computer. If you were to share that pcap with me it might disclose information you might not want to share. So I suggest that you use a capture filter (set when you select the interface to capture from) to only collect dhcp packets.
    2. Your display filter would have worked but dhcp is udp based not tcp based. Also for the display filter you could also just type in bootp to display the dhcp packets.

    You are on the right path though.


  • @george1421 We was doing the test with tcpdump and wireshark, unfortunately no luck, between 2 vlans we have it fog server and vlan we do images, there is no Firewall, so its suppose not block anything
    image (25).png

    image (24).png

    what can we check next? We have FOGs in a few locations, in every place, but the network configuration is the same, and only this new one with 1.5.9 is having this kind of problem…

  • Moderator

    @mightmar If the fog server is on the same ip subnet as the pxe booting computer you can use this process to perform a packet capture of the pxe booting process using the FOG server: https://forums.fogproject.org/topic/9673/when-dhcp-pxe-booting-process-goes-bad-and-you-have-no-clue

    If the target computer is on a different IP subnet than the FOG server you can use wireshark loaded on a witness computer connected to the same subnet as the pxe booting computer. Use the capture filter of port 67 or port 68.

    You want to look at the dhcp offer packet from your dhcp server. It needs to have the next-server and boot-file fields filled out to match dhcp options 66 and 67.

    Use can use wireshark to inspect the capture coming from the fog server pcap file too. If you can’t understand what you are seeing in the pcap file upload it to a file share, share the file with public read with the link. Finally post the link here or send me a direct FOG DM message in the forum with the link and I’ll look at it.

263
Online

9.5k
Users

15.9k
Topics

147.5k
Posts