• Moderator

    With latest distros being packaged with PHP 8 we need to go ahead with the FOG web UI. I have been working on this over the last few days and committed a first batch of changes to dev-branch.

    @testers @moderators and everyone else may please update and try out the latest dev-branch version and let us know about issues here. We are preparing for a next release to come very soon and I hope we can make sure this is working all fine.

  • Moderator

    @Fog_Newb Awesome! Thanks for testing 1.5.9.138. This was meant to fix another issue reported on github but looks like the same problem in the code was causing the issue you saw.

    Please keep an eye open and try as many things as you can (capture/deploy, fog-client, maybe plugins).


  • @sebastian-roth - Ubuntu, 21.10 - I saw 1.5.9.138 was out. I installed that over 137, no error messages during the install and was able to capture!


  • @sebastian-roth The error during the FOG install on 21.10 is related to installing php 8.0 mysql

    Error

    If I try to manually install php8.0-mysql it appears to be installed already

    Already installed

    The GUI works fine and capturing an image goes smoothly until the end where the database needs to be updated

    Wow, so I ran the FOG installer again, this time there wasn’t an error when it came to the mysql install.

    All good?

    Going to try capturing an image now.

    Hmm. It still fails to update the database.

    Failed


  • @sebastian-roth Going through the process again. Now with the FOG 1.5.9.137. Will take screen caps and can upload log files if you’d like. Just let me know which files to upload.


  • @sebastian-roth Unfortunately I didn’t pay much attention as it was the same error as usual when running the installer under 21.10. Error updating dating base. Then the same thing after capturing. If I get a chance to test again I will and take screen caps.

  • Moderator

    @fog_newb Thanks for testing!

    But error with updating the data-base during the install and after capture are present. But I am sure you guys knew that cause that part hasn’t been updated.

    Can you give us some more details on this? While I am not picky about supporting 21.10 (very short shelf life that has) I am still wondering what exactly you run into with this.

    I have used the pre-release 22.04 which will be the next LTS version to come out soon.


  • @sebastian-roth I updated to the latest dev-branch (on Ubuntu 21,04) and was able to access the GUI. However, right after the update, when going to the FOG web interface it was no longer able to contact the server to determine the current version. I didn’t go any further, instead I made a snapshot and am updating to 21.10 to see if that works.

    Update:

    21.04 with the latest dev branch appears to work fine so far for capturing a win 10 image. 21.10 - GUI is now working if you install the latest dev branch after updating ( if you have the latest dev branch and upgrade to 21.10 no GUI). But error with updating the data-base during the install and after capture are present. But I am sure you guys knew that cause that part hasn’t been updated.


  • This post is deleted!
  • Moderator

    Does not have to be an OS with PHP 8 installed already! We just need people to test if the latest dev-branch is working fine with all the changes made…

282
Online

9.5k
Users

15.9k
Topics

147.5k
Posts