FOG services missing or not running



  • Hi,

    I setup a FOG server 0.32 running on Ubuntu 12.04.1 LTS and “everything” is working fine. I mean "everything because I didn’t realise that services “FOGImageReplicator”, “FOGMulticastManager” and “FOGTaskScheduler” weren’t running until I setup a storage node that wasn’t receiving the images stored in the main FOG server.
    If I go to /opt/fog/service/ I see each folder. When I try to start/restart any of the services I recieve the following messages:

    [CODE]sudo /etc/init.d/FOGImageReplicator start

    • Starting FOG Computer Imaging Solution: FOGImageReplicator [fail][/CODE]

    [CODE]sudo /etc/init.d/FOGImageReplicator restart

    • Restarting FOG Computer Imaging Solution: FOGImageReplicator start-stop-daemon: warning: failed to kill 3479: No such process[/CODE]

    In /opt/fog/log/ there aren’t any logs.

    Does anyone have any idea why this is happening? Any testing?



  • Hi,

    The FOG server has been reinstalled (Ubuntu 12.04 LTS Server 64 bits) without services (LAMP, OpenSSH, etc.), and after that I have installed FOG. The problem is solved.
    Now I can’t upload snapins, but I’m going to start a new thread.

    Thank you for your help.



  • Thank you so much, chad-bisd. You have said something that gave me a clue. Maybe it is related to the Internet access when I installed FOG, because when I try to sudo apt-get update or upgrade it says that “could not access Internet” blah blah blah.

    In my enterprise there are Linux experts who set up this server (just Linux), and I told them that I would need full access to Internet in order to complete the installation. It seems that they forgot that part, so now they are fixing it. I did not realize that the services were not installed until I have needed the storage node (I am still testing FOG). When they fix it, I will uninstall/install to see if that is the problem.


  • Moderator

    I just install FOG 0.32 on a fresh VM of Ubuntu 12.04.02 LTS Server 64 bit. I noticed that even though I told the install script that i didn’t want to use FOG as a DHCP server, it still trying to run the ConfigureDHCP() function in the lib/ubuntu/functions.sh file and generated en error when it couldn’t find the /etc/dhcp.d/dhcp.conf file.

    My services installed corrected.

    Before I ran the fog installer, I did set the interface to have a static address and I did:
    [CODE]
    sudo apt-get update
    sudo apt-get upgrade
    [/CODE]

    Then I ran the installer with sudo.



  • Sorry chad-bisd, my last message was quite nonsense in the last line because I hit the [B]Post Reply[/B] button before finishing it. What I meant by

    [QUOTE]in my storage node that /opt/fog/log logs have been created and the ser, so I assume that[/QUOTE]

    was

    [QUOTE]in my storage node that /opt/fog/log logs have been created and the services are running, so I assume that Gnome Desktop is the key.[/QUOTE]

    I thought it could some kind of problem with the desktop environment because, when I first built the storage node without a desktop environment, the installation failed at some point (I can’t remember now). I then installed Gnome and tried again the installation, and everything went working. But now the issue is on the main server, so you are right, it has nothing to do with the desktop environment.

    I’m quite lost…


  • Moderator

    I run FOG on Ubuntu Server 10.04 LTS without a GUI, so it’s not your desktop interface.



  • Thanks chad-bisd, just to let you know (it might be useful), I uninstalled and installed FOG again, but I get the same errors. I am using Lightweight X11 Desktop Environment. Maybe Gnome installs some files that FOG needs? I’ve seen in my storage node that /opt/fog/log logs have been created and the ser, so I assume that I can’t change the desktop right now. Any help will be much appreciated.


  • Moderator

    I’ll see if I can setup FOG 0.32 on Ubuntu 12.04 LTS on a VM to see why the services might not be running.


Log in to reply
 

457
Online

39176
Users

10821
Topics

102960
Posts

Looks like your connection to FOG Project was lost, please wait while we try to reconnect.