• Developer

    Hi,
    I am trying to install the FOG client under Kubuntu 20.04 but something goes wrong when the daemon initiates. I follow the instructions of the wiki to install it.

    Mono version:

    # mono --version
    Mono JIT compiler version 6.12.0.122 (tarball Mon Feb 22 17:33:28 UTC 2021)
    Copyright (C) 2002-2014 Novell, Inc, Xamarin Inc and Contributors. www.mono-project.com
            TLS:           __thread
            SIGSEGV:       altstack
            Notifications: epoll
            Architecture:  amd64
            Disabled:      none
            Misc:          softdebug 
            Interpreter:   yes
            LLVM:          yes(610)
            Suspend:       hybrid
            GC:            sgen (concurrent by default)
    

    FOG Client version: 0.11.16
    FOG Server Version: 1.5.9
    FOG Client Log:

    14/10/2021 12:51 Middleware::Communication URL: http://10.A.B.C/fog/management/index.php?sub=requestClientInfo&configure&newService&json
     14/10/2021 12:51 Middleware::Response Success
     14/10/2021 12:51 Service ERROR: Invalid promptTime, using default
     14/10/2021 12:51 Middleware::Communication URL: http://10.A.B.C/fog/management/index.php?sub=requestClientInfo&mac=XX:XX:XX:XX:XX:XX&newService&json
     14/10/2021 12:51 Middleware::Authentication Waiting for authentication timeout to pass
     14/10/2021 12:51 Middleware::Communication Download: http://10.A.B.C/fog/management/other/ssl/srvpublic.crt
     14/10/2021 12:51 Middleware::Authentication ERROR: Could not authenticate
     14/10/2021 12:51 Middleware::Authentication ERROR: Value cannot be null.
    Parameter name: authority
     14/10/2021 12:51 Middleware::Response Success
     14/10/2021 12:51 Middleware::Communication URL: http://10.A.B.C/fog/service/getversion.php?clientver&newService&json
     14/10/2021 12:51 Middleware::Communication URL: http://10.A.B.C/fog/service/getversion.php?newService&json
    
     14/10/2021 12:51 Service Creating user agent cache
     14/10/2021 12:51 Middleware::Response ERROR: Unable to get subsection
     14/10/2021 12:51 Middleware::Response ERROR: Object reference not set to an instance of an object
     14/10/2021 12:51 Middleware::Response ERROR: Unable to get subsection
     14/10/2021 12:51 Middleware::Response ERROR: Object reference not set to an instance of an object
     14/10/2021 12:51 Middleware::Response ERROR: Unable to get subsection
     14/10/2021 12:51 Middleware::Response ERROR: Object reference not set to an instance of an object
    
    ------------------------------------------------------------------------------
    ---------------------------------ClientUpdater--------------------------------
    ------------------------------------------------------------------------------
     14/10/2021 12:51 Client-Info Client Version: 0.11.16
     14/10/2021 12:51 Client-Info Client OS:      Linux
     14/10/2021 12:51 Client-Info Server Version: 1.5.9
     14/10/2021 12:51 Middleware::Response Success
    ------------------------------------------------------------------------------
    
    
    ------------------------------------------------------------------------------
    ----------------------------------TaskReboot----------------------------------
    ------------------------------------------------------------------------------
     14/10/2021 12:51 Client-Info Client Version: 0.11.16
     14/10/2021 12:51 Client-Info Client OS:      Linux
     14/10/2021 12:51 Client-Info Server Version: 1.5.9
     14/10/2021 12:51 Middleware::Response ERROR: Unable to get subsection
     14/10/2021 12:51 Middleware::Response ERROR: Object reference not set to an instance of an object
    

    Any ideas?

  • Developer

    Hi @Sebastian-Roth,

    Now works fine the FOG client 🙂

    Thanks for your fast reply

  • Senior Developer

    @Fernando-Gietz Please use the very latest SmartInstaller downloaded from github to see if that’s still causing an issue.

277
Online

8.8k
Users

15.5k
Topics

144.4k
Posts