• Hello,
    I received new machines with only UEFI boot option when until now, I was using Legacy successfully.

    1. We changed DHCP option 067 to ipxe.efi
    2. Updated kernel from console with this article https://wiki.fogproject.org/wiki/index.php?title=Kernel_Update
    3. Exchanged refind_x64.efi to version 0.10.9 cause we have only HP machines.

    I can get to Fog deploy menu and choose to register machines, then its deploying image and all goes fine till its restarting and trying to boot to windows:
    IMG_20210528_083531.jpg

    from this momenet only I can do is to restart computer or shutdown 😞

    What I can do?


  • Hi, so I did change to version refind version 0.10.4 worked with my HP models, and capture new image, on only UEFI bios, and its working. @EduardoTSeoane made me think that I have only legacy compatible images so I tried to fix that. Thank you guys for help!


  • @mightmar have you verify that the partition scheme is UEFI?

    I had that problem, and I verify that this problem can be because the Computer is CSM UEFI+LEGACY, with UEFI first and partition scheme LEGACY (MBR without efi partition), try to configure LAN BOOT OpROM as legacy…


  • @sebastian-roth Yes I am testing it every time too, always end with chainloading failed, and reboot in 10 seconds.
    Edit: I found more options to exit boot:
    a) IPXE General Configuration> boot Exit settings> exit to hard drive type (EFI)
    b) Fog settings> Fog boot settings> EFI boot exit type

    are they different, and what with “boot exit type” its also there which is to change here?

    I also notice that “key sequence which is set to f12” is not recognized, and its always “ESC” instead, maybe its not sending settings to machine after changing to ipxe.efi?

    Maybe I am missing something as I need in the new Image for this? I am open for suggestions

  • Senior Developer

    @mightmar said in Stuck on About rEFInd:

    Is there other ways to use UEFI, …

    Have you tried different exit types as suggested in my last post yet?


  • @sebastian-roth

    Is there other ways to use UEFI, cause refind is really not working for me, I have checked a few versions, still no luck, and even if I found it finally, I am not sure it will work with a different HP model when we have like 4 and also hp laptops. Checking refind for every model seems endless work 😞

  • Senior Developer

    @mightmar said in Stuck on About rEFInd:

    Exchanged refind_x64.efi to version 0.10.9 cause we have only HP machines.

    It’s definitely rEFInd causing this. Unfortunately there is not much we can do from the FOG side. We provide rEFInd as one method to chainload to boot from the local disk. Some hardware/UEFI firmware plays nice and others don’t. There are two things you can try to get it solved:

    • Try out different versions of rEFInd: https://sourceforge.net/projects/refind/files/
    • Change to a different Exit Type in FOG (I suggest you use the per host setting -> Host EFI Exit Type). REFIND_EFI is the default for UEFI settings but you might be lucky with simple EXIT, SANBOOT or maybe GRUB…

236
Online

8.4k
Users

15.2k
Topics

142.6k
Posts