Dell Vostro 470 - UEFI net boot fails

  • Moderator

    Hi all,
    FOG 1.5.9, boot file snponly.efi, kernel 5.10.34 TomElliott.

    Get a strange error when trying to UEFI netboot an old Dell Vostro 470. It has the latest released firmware (A14 from 2018) and throws an error about edk2 (see below). It will not progress past this. I am wondering if this is due to the age of the pc model.
    vostro.jpg

    Let me know if you need any more details as I’m sure I left out an important detail or two by accident.

    Thanks!

  • Moderator

    @sebastian-roth we may have found a workaround since we have a uefi/bios co-existence setup, we are trying to legacy boot to capture/deploy the uefi image. It appears to have worked. I am not sure I want to pursue this issue further since it is a very old model and a one off case.

    I appreciate your help on the matter regardless, thank you.

  • Moderator

    @fry_p said in Dell Vostro 470 - UEFI net boot fails:

    I am wondering what else I could try if this is a fixable issue.

    1. Attempt to image the computer in bios mode. As long as you boot it in uefi mode for the OS, it is acceptable to image the machine in bios mode. Just use the F12 boot manager to one time pxe boot in bios mode.
    2. Bypass iPXE by booting FOS Linux from a usb flash drive.
  • Senior Developer

    @fry_p Unfortunately there is not much we can do for you. Quick search on the web revealed nothing about this particular assert errors. Your best chance is to post on the iPXE developers list: https://lists.ipxe.org/mailman/listinfo/ipxe-devel

  • Moderator

    @sebastian-roth thanks for the advice. I tried ipxe.efi and also tried compiling my own. Unfortunately both times I received the same error. I am wondering what else I could try if this is a fixable issue.

  • Senior Developer

    @fry_p Looks like a buggy firmware on that Dell Vostro 470. You can try using a different iPXE binary (ipxe.efi) or build iPXE from the latest source code and give that a try:

    sudo -i
    cd /root/fogproject/utils/FOGiPXE/
    ./buildipxe.sh
    cd ../../bin/
    ./installfog.sh
    

    Hint: You might need to install packages like “genisoimage syslinux xz-devel” for it to compile properly. That’s the package names on RedHat/CentOS. Not sure about Debain/Ubuntu.

234
Online

8.4k
Users

15.2k
Topics

142.6k
Posts