• FOG version 1.5.9

    I’m trying to image a set of dell all in one 5480’s and i can’t see to find a kernel that is compatible with the NIC.

    I’m getting an No network interfaces found, your kernel is most probably missing the correct driver!

    Which kernel should i be using to image these?

  • Senior Developer

    @The-Dealman Beside grabbing and uploading the messages log here (hopefully that will help) you might also run ip a s on the debug console and post a picture of the output here.

  • Moderator

    @the-dealman I’m not seeing where its init’ing the network adapter in that screen shot. Will you upload the /var/log/messages file using this process and post it in this thread (I want to see the entire log file):

    1. Insert the usb drive into the target computer.
    2. issue this command from the debug console
      lsblk
    3. I identify the usb flash drive by its size in the list. For the reset of this lets assume it shows up and /dev/sdb
    4. Now let make a directory where we can mount that usb drive.
      mkdir /ext
    5. Lets connect the usb drive to that directory
      mount /dev/sdb1 /ext
    6. That command will mount the first partition on that usb stick to the /ext directory. Issue this command to see the contents of the usb drive
      ls -la /ext
    7. If you see what is expected then copy the log file to the use flash drive directory.
      cp /var/log/messages /ext
    8. When done unmount that usb drive with
      unmount /ext
    9. Now you will be able to remove the usb drive. Don’t remove it before you unmount it and the command completes.

  • @george1421 okay that worked but i didn’t see any error that said “failed to find”

    This section has some network information, does this help?

    2021-02-03_8-29-56.jpg

  • Moderator

    @the-dealman Well I tried to be like them cool linux kids and spit out commands left and right, but it seems I can’t spell worth a hoot.

    Lets try this command with the missing e dmesg | less


  • @george1421
    I followed those instructions but i just see a blank screen with a box that says standard input

  • Moderator

    @the-dealman Yes that is what I needed.

    Intel nic 8086:0d4c first introduced into linux kernel 5.5. So kernel 5.6.18 should work. With that said, there is probably firmware needed.

    I need you to do this process to see what is missing.

    1. Manually register this computer with FOG.
    2. Schedule a capture or deploy task (doesn’t matter) but before you hit the schedule task button enable the debug checkbox. Then schedule the task.
    3. PXE boot the target computer.
    4. After several screens of text where you clear with the enter key you will be dropped to the FOS Linux command prompt.
    5. At the FOS Linux command prompt key in dmsg | less. Search the entire log file. You are looking for “Failed to find file fw…” I need to see that section of the log file. It will list the missing firmware we need to bake into the kernel.

  • @george1421 I tried those kernels and they did not work.

    Is this what you are looking for?

    Capture.PNG

  • Moderator

    @the-dealman Lets start by having you update to the FOS Linux kernel 5.6.18. This is done via the webui -> FOG Configuration -> Kernel update. Install both the x64 and x86 kernels.

    If that doesn’t work then we need to get the hardware ID of that NIC. You can do this via the device manager. I need both the vendor id and device id.

403
Online

8.0k
Users

14.9k
Topics

140.6k
Posts