• Good Afternoon All,

    I am new to FOG and getting it set up and configured in our environment. I have successfully got it all set up and working and have gone to do a PXE boot to capture the first image from a machine. The PXE IPv4 boot starts and it connects to our FOG Server, it get an IP address finds the nbp file (undionly.kpxe) downloads it successfully, then it starts an IPv6 PXE boot for which there isn’t anything and then boots into windows.

    Can someone please provide some guidance on this. My system is as follows:

    Fog 1.5.9 on Ubuntu 20.04
    DHCP on separate windows server configured as this article

    Thanks in advanced

    Frosty

  • Moderator

    @lukekfrost the FOG install doesn’t like it when the ip address of the imaging interface is changed after FOG is installed. There are several locations where the static IP address is recorded. You linked to the wiki page, also this post addresses the same issue as you have today. https://forums.fogproject.org/topic/15112/changed-ip-reinstalling-not-an-option

    My unoffical instructions are to

    1. Update the hidden file /opt/fog/.fogsettings fix the IP address in there.
    2. Update the IP address in /tftpboot/default.ipxe
    3. Update the IP address in the web ui under fog configuration->fog settings->expand all. search for the old IP address and replace it with the new address.
    4. In the fog storage node default, change the IP address in there.
    5. Back in the fog server linux console, rerun the FOG installer to fix the remaining bits.

  • @sebastian-roth Looks like I am getting a little bit further as I had secure boot turned on and that wasn’t allowed as ipxe.efi isn’t signed so was causing issues. I’m nearly there however it’s now when it’s booting into the PXE mode it starts, connects to the fog server however when it trys to connect to the servic/ipxe/boot.php the ipaddress it is using is an old IP address that the server as using when we were testing. I have changed the IP address as detailed in this article but obviously I have missed something somewhere.

    Any ideas where this old address is saved so that I can change that reference as well.


  • @sebastian-roth Thanks very much for your swift reply.

    That would make sense as yes you are correct in that we are using UEFI mode for booting. I have modified the DHCP Server (Windows Server 2019) to add the policy as detailed in the wiki link that you provided. I left the option for 067 set in scope options as well to allow for non-UEFI clients that we have a few legacy systems on our network but I did modify this to add the extra k that I was missing before. The policy seems to be working as it’s now downloading the ipxe.efi successfully however it then doesn’t boot into the ipxe.efi environment it is still booting into windows and displaying the logons screen.

    Hopefully, you can provide some further assistance.

    Kind Regards

  • Senior Developer

    @lukekfrost said in PXE Boot Not Booting:

    it get an IP address finds the nbp file (undionly.kpxe) downloads it successfully,

    NBP file sounds like your machine is set to boot in UEFI mode. You need to use ipxe.efi instead of undionly.kkpxe (for legacy BIOS only) in your DHCP server.

    This wiki article will be useful I suppose: https://wiki.fogproject.org/wiki/index.php?title=BIOS_and_UEFI_Co-Existence

301
Online

8.6k
Users

15.3k
Topics

143.4k
Posts