SOLVED Changed IP, reinstalling not an option


  • I changed the IP. Eventually, I’d like to change the whole subnet, but I wanted to start small. Either way, now my clients can’t successfully pxe boot. I used the updateip.sh, and I changed the IP in the /tftpboot/ipxe.default and hit the /tftpboot with a chmod 777 -R. Here is a picture of my problem. I can’t reinstall, is this mission impossible? pxe_problem.PNG


  • I ended up finding the fix.

    Step 1: Change IP Address, then deactivate and activate the network interface.

    Step 2: Run the UpdateIP.sh within the fog-community-scripts-master.zip found here https://github.com/FOGProject/fog-community-scripts

    Step 3: Rerun the installer.
    If you have NO INTERNET CONNECTION, like myself in this case,
    rerun with the -X option like so,

    ./installfog -X

    I verified it worked with my new subnet and I was able to boot off my Fog Server, register new hosts, as well as capture and deploy an encrypted Linux image.

    This was successfully done on a Rhel 7.9 VM with no internet connection FYI.


  • @george1421 How would I fix that?

  • Senior Developer

    @boriquaboy115 Should be able to fix that without re-install. Go to the directory where you extracted the FOG installer (or cloned it via github). If you don’t have that anymore you can re-download it. Best to use the same version you installed before: https://github.com/FOGProject/fogproject/releases

    Change to root user (e.g. sudo -i or su -) and navigate to the subdirectory utils/FOGiPXE/ within the FOG installer dir. Then run the iPXE buildscript and copy over the new binaries that were generated by the build script:

    ./buildipxe.sh
    cd ../../packages/tftp/
    find -type d -exec mkdir -p /tftpboot/{} \;
    find -type f -exec cp -fv {} /tftpboot/{} \;
    

    See if you clients are able to PXE boot again.

  • Moderator

    @boriquaboy115 The permission denied message is related to the certificates being used. I see you are using https so that means the certificate used to compile ipxe.efi and undionly.kpxe doesn’t match what the apache server is using.

385
Online

8.1k
Users

15.0k
Topics

141.3k
Posts