• Hello.
    I cannot upload the image of the Client PC whose Host is registered in FogServer.
    I was able to register the Host at the first PXE Boot.

    Confirmed registered correctly from the MAC address on FogServer.

    However, when the client PC is restarted, it is displayed that the host is not registered.

    I try to re-register the host, “Already registered” is displayed, an error occurs, and a forced restart is required.

    Client PC does not have a wired LAN port. Therefore, USB-LAN parts are used.

    The USB-LAN component works fine on FogServer.
    Works with standard Linux drivers.

    What should I do now?

    environmen

    • Ubuntu 20.04.1
    • Fog 1.5.9
    • USB-LAN LAZOS L-CD7
  • Senior Developer

    @erasp21 said in Host registration error.:

    How about giving FogServer a little image gift by recognizing only the MAC address that the PC has?

    Not sure what you mean by “image gift” but what you seem to ask is not in the FOG servers hand. Depending on the firmware settings and maybe also drivers (iPXE using different ones than FOS Linux and different to Windows) the MAC address seen by the FOG server is whatever is presented by firmware/settings/driver. Not much we can do about it.


  • @jpolk91 @george1421
    Hello, everybody.

    In the BIOS settings of the PC
    Advanced–MAC address passthrough
    “System address” (default)

    How about giving FogServer a little image gift by recognizing only the MAC address that the PC has?


  • @erasp21 said in Host registration error.:

    @jpolk91 @george1421
    Hello, everybody.
    I have 5 HP 830 G7 kitchens.
    Therefore, please let us know if you would like us to try something.

    My hope is to use the MAC address that Laptop originally has with MAC pass through enabled.


  • @jpolk91 @george1421
    Hello, everybody.
    I have 5 HP 830 G7 kitchens.
    Therefore, please let us know if you would like us to try something.


  • @george1421 sure.

    With MAC pass through disabled FOG registers the MAC of the adapter, so if you use a different adapter for the computer receiving the image it will need to be registered. If you use the same adapter as the computer that uploaded the image it will not.

    However, even if you use the same adapter to deploy as you did to upload it seems MAC pass through needs to be disabled on the receiving machine as well or it will error out before deploying. This could be wrong though, I haven’t thoroughly tested it, just tried it on one machine one time.

    Let me know if you want me to try anything. I should have one or two of these machines for a little while yet.

  • Moderator

    @jpolk91 said in Host registration error.:

    disabling mac passthrough and everything is good

    Just to help me and the OP of the thread. Disabling mac pass through and imaging a second computer. Does FOG see that second computer’s mac address as already registered. Or you have to register the second computer with FOG, which gets a different mac address.

    Since I don’t have HP on my campus we need to fully understand this feature because I’ve seen an uptick in posts regarding this issue.


  • @george1421 it looks like you hit the nail on the head here. I’m having this same issue with a hp 1040 g7. After disabling MAC passthrough in BIOS I was able to capture an image! Deploying is similar, disabling mac passthrough and everything is good!

  • Senior Developer

    @erasp21 said in Host registration error.:

    I feel that the problem is that FogServer reads the USB Type-C NIC MAC Address when trying to register the Host.

    This is something deep down in how firmware (UEFI), NIC adapter and probably the OS driver handle things. It’s not something we can change in FOG. Well there might be special driver options you could set via /proc in FOS but I really doubt you can change that behavior of which MAC is seen.


  • @george1421

    Hello.

    In the BIOS settings of the PC
    Advanced --MAC Address Pass Thruough
    “System Address” (default)
    I feel that the problem is that FogServer reads the USB Type-C NIC MAC Address when trying to register the Host.

    How can I make FogServer read only the MAC Address that my PC has?


  • @george1421

    The default setting was “System Address”.

  • Moderator

    @erasp21 said in Host registration error.:

    There were three options for Host Based MAC Address.

    So what was the default setting for this value?


  • @george1421

    I checked the BIOS notation on the HP 830 G7.

    Advanced --MAC Address Pass Thruough
    The MAC address was written here.

    There were three options for Host Based MAC Address.
    “Disable”
    “System Address”
    “Custom Address”

    The MAC address registered for the first time in FogServer this time recognizes the MAC address of the NIC of USB Type-c, and after being registered as Host in FogServer, the MAC address used for Uploading and Deploying Image is HP 830 G7 Pass. It turned out to be a Thruough MAC address.

    The problem this time is that when registering a new Host in Fog Server, the MAC address of the USB Type-c NIC is registered instead of the MAC address of the MAC Address Pass Thruough that the PC has.

    Is it possible to solve the problem by changing the FogServer settings in order to register the Host Based MAC Address of the PC?

  • Moderator

    @erasp21 As I mentioned in my previous post I don’t use HP so I can’t give you a step by step.

    A quick google-fu search finds this
    “From the BIOS setup, under Main, click System Information. Then click the link at the top, “Show Advanced System Information.” Then scroll all the way down and under the COMMUNICATION header you will see Integrated MAC Address 1.”

    Read the built in mac address from the above link.

    Compare this to the mac address the FOG hardware registration/inventory collects.

    ref: https://h30434.www3.hp.com/t5/Desktops-Archive-Read-Only/MAC-Address/td-p/5719257

    Then in the bios Advanced menu there is a sub menu for MAC Address Pass Through, what are the setting there? What happens if you change the settings from their default values and try to image again?

    ref: http://h10032.www1.hp.com/ctg/Manual/c06691369

    There has to be a reason why iPXE is seeing a different mac address than FOG and Windows.


  • @george1421 said in Host registration error.:

    I’m sorry I can not help with this since we do not use hp on our campus. So I can’t give you step by step instructions.
    I would look through the firmware settings to see if there is any settings that talk about mac pass through.

    Thank you for your answer.

    Please let me know if there is anything I can confirm.

    If you know the procedure, I can cooperate.

  • Moderator

    @erasp21 I’m sorry I can not help with this since we do not use hp on our campus. So I can’t give you step by step instructions.

    I would look through the firmware settings to see if there is any settings that talk about mac pass through.


  • @sebastian-roth
    Sebastian Roth-san
    Thank you for your reply.
    Please wait for a while as we will have the opportunity to touch the verification machine next week.

    Certainly I confirmed the two MAC addresses.

    1. MAC address confirmed by fogserver’s iPXE.
    2. USB-The MAC address that your wired LAN device may have.

    The MAC address confirmed by iPXE of fogserver was manually corrected on the web-UI of fogserver, and the image was uploaded and deployed.

    I’m more interested in this issue and want to know why there are two MAC addresses.


  • @george1421
    I would like to check one firmware of the system to see if there is anything about MAC address passthrough.

    What steps do you need to take?

    I will disclose what I can cooperate with and necessary information.

  • Moderator

    @erasp21 What we are guessing that these 830/840 G7 models are doing something strange. Would you look into the firmware of one of your systems and see if there is something regarding mac address pass through? If so note the setting, then change the setting to see if the network adapter responds normally. The G6 versions of these models act as it should.

    What we are guessing is that the iPXE boot loader uses a lower level driver where it only sees the mac address built into the adapter, where both linux and windows has a higher level driver where it sees the mac pass through address. But without the hardware we can only guess


  • @george1421

    I manually registered the Mac displayed in the iPXE menu, iPXE recognized it as registered.
    And I succeeded in uploading the image.

    Why do iPXE and FOS show different MAC addresses for the same network adapter?

    Also, how can I improve the situation where I have to manually register the MAC address, and can I expect improvements in future updates?

357
Online

8.1k
Users

15.0k
Topics

141.4k
Posts