• Hey

    So i have the most recent version of FOG active on a ubuntu server. FOG is functioning as it should. The Client on the subjugate PC is connected and tasks are running but when the tasks force the reboot to do the task they do not boot to the client but rather just restart the pc and boot windows. What am I missing in my boot settings?

  • Moderator

    @epsilon52 First let me say that I 100% agree with Sebastian, but I also know a secret for the Dells.

    Using the Dell CCTK (Command and configure tool) you can instruct the bios to pxe boot on the next boot up. This is totally outside the scope of FOG and not something that FOG is capable of, but the cctk tool has the ability to update/change bios settings from inside windows. So using that thought one could create a snapin (FOG deployable program) to run the preinstalled cctk command with the proper parameters to pxe boot on the next reboot only then instruct the computer to reboot. You would deploy that task after you have created an imaging task. I have not personally do this on my campus because I have other rules, but it should be totally possible with snapins and the fog client (I don’t use either in my environment).

    As I said before I require the Imaging Tech to sit in front of the computer being imaged so they are 100% certain on what computer they are imaging. Because once in the past with the fully automated process we had an Imaging Tech pick the wrong computer and reimaged (i.e. erased) a VIP’s computer.

  • Senior Developer

    @epsilon52 said in I think i may be just dumb:

    Chainloading wont boot the machine to pxe automatically if a task is qued? im just trying to tie together what your saying and what sebastian is saying

    We’ve never stated this another way. FOG needs PXE to be enabled (by default or some person) to run a scheduled task. Scheduling a task will not make it PXE boot. I have said that before.

    This is different to what you might be used from software like Symantec Ghost where a bootloader will be written to disk that will boot right into the task when it’s scheduled. This is complex and can cause a lot of trouble and FOG does not do it.


  • @george1421 so just so i understand. Even though i schedule a task to be preformed through the fog management to the host with the fog client, a tech still needs to manually be there to pxe boot the machine? Chainloading wont boot the machine to pxe automatically if a task is qued? im just trying to tie together what your saying and what sebastian is saying

  • Moderator

    @epsilon52 said in I think i may be just dumb:

    im not sure this will be a good fix as i belive it is going to boot the ipxe menues every time the computer is started now.

    Ah ok, lets circle back to the title of this thread.

    You can only get into the iPXE menu IF you pxe boot the computer. Without pxe booting it will ALWAYS boot into windows. The computer is doing exactly what you are telling it to do, but alas not what you want it to do.

    FWIW, I have the hard drive set first in the boot order. I require the Imaging Tech to sit in front of the computer to be imaged and use the F12 boot manager to select PXE boot for imaging. You press the F12 key to get the boot manager just after the computer powers up and before it starts loading windows. From the boot manager you can pick network boot under uefi. That way after imaging the computer boots right into windows. The boot order never needs to be touched.


  • @george1421 alright by putting the pxe ipv4and 6 first in the boot order it has booted the ipxe menus and is doing the capture. im not sure this will be a good fix as i belive it is going to boot the ipxe menues every time the computer is started now. i will update after it completes the task to see if the chainloading works.

  • Moderator

    @epsilon52 Its not displaying any error message and in the bios you have the network adapter setup as the first boot item?

    You don’t see an error about NBF or anything like that?

    Is the FOG server on the same subnet as the pxe booting computer? There has to be something missing from your environment. It should boot.


  • @george1421 thats been done but it is still skipping the ipxe screens.

  • Moderator

    @epsilon52 You are sending the wrong boot file then. Please change option 67 to ipxe.efi then it will boot.


  • @george1421 System information says UEFI

  • Moderator

    @epsilon52 So the next question, is the target computer in bios or uefi mode?


  • @george1421 In the current settings that is correct i never see the ipxe menue.

    I see them when I turn all the legacy support stuff and book from the legacy onboard nic but that is the ONLY time.

    For 66 I have "boot Server Host Name: and the fog ip 10.10..
    For 67 I have “Bootfile Name: undionly.kpxe”

  • Moderator

    @epsilon52 said in I think i may be just dumb:

    So when i change the boot order to allow ipv4 and ipv6 pxe boot it boots through them every time never showing me the pxe screen. then eventually getting to the windows

    OK so your computer tries to pxe boots and then fails to pxe boot and windows starts. You NEVER see the FOG iPXE menu? If this is the case, then we can focus on the pxe booting process.

    What specifically do you have configured for dhcp options 66 and 67? These would be values you set in your network’s dhcp server. The pxe booting computer uses the values stored in 66 and 67 to know where the FOG server is and what boot loader to download.


  • @george1421

    So when i change the boot order to allow ipv4 and ipv6 pxe boot it boots through them every time never showing me the pxe screen. then eventually getting to the windows screene where the fog client sees a task and reboots the computer cycleing it through ipv4 and 6 and back to windows.

    When i set the windows boot manager first in the order it just cycles through rebooting windows over and over.

    In both instances i never see the pxe menu unless I turn legacy settings on and boot the legacy onboard nic setting.

  • Moderator

    @epsilon52 Just to be sure we understand what is going on here.

    When you change the pxe boot first in the boot order. The computer pxe boots and do you see the FOG iPXE menu?

    And where its failing is after the iPXE menu times out instead of booting into windows it just reboots?

    -OR-
    Are you never seeing the FOG iPXE menu?
    Do I understand where its failing?


  • @sebastian-roth so if i set a task someone has to physically be at the machine to pxe boot? So right now i have a Capture task set on my test host and the task is going through to the PC causing it to restart. so shouldent the chainload cause it to boot to pxe to do the qued task?

  • Senior Developer

    @epsilon52 said in I think i may be just dumb:

    If I change the boot order it boots PXE every time and wont boot to windows.

    There is what we call the “chainload from disk after PXE boot” that should just boot you Windows if there is no task scheduled for this host in bootup.

  • Senior Developer

    @epsilon52 said in I think i may be just dumb:

    I figured the FOG client would automatically cause it to boot into the PXE on restart.

    No it does not.


  • @sebastian-roth No I do not. The fog client restarts the PC and it boots into windows even though the other options are enabled. I figured the FOG client would automatically cause it to boot into the PXE on restart. If I change the boot order it boots PXE every time and wont boot to windows. I would record it but its litterly just “restarting…Black screen…Dell logo…Dell logo again… windows repeat every 5 min”

  • Senior Developer

    @Epsilon52 Well, do you actually see PXE boot up messages on the screen when it reboots???

    In case you are not sure you might take a video and post a link here.

293
Online

8.3k
Users

15.1k
Topics

142.0k
Posts