• Hello guys im running in to a problem here and im not user what the problem is… i did found some posted but nothing really worked… so im running this as a docker on my unraid server at my office here some info and maybe some can see what i did wrong… thank you ahead of time.
     
    Docker mudislander/fogproject
    fog version 1.5.5 (not sure how to update the docker)
     
    here are the pix of the problem. 
     
    alt text
    https://ibb.co/XVhFdww
    alt text
    https://ibb.co/zNNj0jR


  • @david201 You might be better off getting this out of Docker. Here are steps on how to migrate FOG. If you have the right switches enabled in the hosting OS, you should be able to mount NFS inside of the container. Otherwise, there are other ways to get the images & things out.
    https://wiki.fogproject.org/wiki/index.php?title=Migrate_FOG

  • Moderator

    @david201 I don’t know if we are going to be of much help since the docker setup is not officially supported.

    There is a couple of thing from the screen shots you posted I can speak about.

    1. Don’t worry about the warning message about the microcode needs updating. This is only a warning message and will not impact the function. I can recommend though that you update the FOS Linux kernel to 5.6.18 if you need to use FOG to image 2019 or later hardware. You need this newer kernel to support the newer hardware. If this was a traditional FOG install I would say you do it via the fog web ui in FOG Configuration -> Kernel Update.

    2. From the second picture its saying the target computer can’t connect to the FOG Server over NFS. The target computer connects to the FOG server /images/dev share to upload the target computer’s hard drive. In MS Windows terms it saying it can’t map a drive on /images/dev . This needs to be something that docker is exporting to the world so clients can connect using NFS. I know NFS v3 (what FOG currently uses) is difficult to craft firewall rules for because it uses a lot of random ports for communication.

    I do see that FOG has a page on creating a fog install in a docker container but its quite old.: https://wiki.fogproject.org/wiki/index.php/Install_FOG_in_a_Docker_Container

    I did find someone who had the exact same error message that posted earlier in this year: https://forums.fogproject.org/topic/14742/could-not-mount-images-folder

295
Online

8.1k
Users

15.0k
Topics

141.4k
Posts