• Hello,

    I am trying to image a few systems with as much automation as possible. But, I am running into a few setbacks and am hoping someone here might know of some tricks.

    I am running version 1.5.9 as the master host. This host is mainly only used for capturing images. There will be very little deployments from it. All images are based on Windows XP Pro.

    There will be several locations that will use the FOG storage image for deployments. I want each location to only use the local FOG storage for imaging. I am using the location plugin.

    Everything works great except for the following.

    1. I have Quick Registration set to apply hostname, image, and group. It does all of this, but it will start pulling the image from the master host and not the local storage. Is there a way to force this?

    2. I have a small 1GB ISO for diagnostics in the menu. It works, but it always pulls it from the master host. I have it stored in each replicated storage. Is there a way to tell it to use local storage instead of master?

    3. For above ISO, is there a way to script it, so it pushes to each replication share at creation, rather than manually having to push it? Possibly, have it check the master and if file newer, push out to each?

    4. I have the FOG client installed on each system, but it doesn’t seem to check-in. I am only needing this in order to remotely shutdown or reboot systems. The log file on the client is blank. How can I troubleshoot this?

    Thank you for your time.

    Eddie

  • Senior Developer

    @eseelke Are you still around?

    I just updated the code to add the ${storage-ip} variable. Update to the latest dev-branch to be able to use it.

  • Senior Developer

    @eseelke Are you still keen to discuss all those topics? Please open separate ones.

    I think I have a solution for your question number 2! Waiting for you to open a new topic on this.

  • Senior Developer

    @george1421 This is the last topic I remember the ${storage-ip} iPXE variable has been discussed. Unfortunately there haven’t been a response in a long time and therefore we never added it.

    I am still hoping the OP will open new topics so we don’t miss the different issues.

  • Moderator

    I can’t seem to find it at the moment. One of the developers may have pushed that as a one-off patch that didn’t make it into the official FOG code. The right variable name is storageip. We just need to get that into the iPXE menu.

  • Moderator

    @eseelke said in FOG Automation:

    ${storageip} doesn’t work

    Yes because that came from my rusty memory. I need to find the post, but I’m sure this issue happened before. Let me see what I can find.


  • Thank you @george1421 . Unfortunately though, ${storageip} doesn’t work.

  • Moderator

    @eseelke I have looked into issue 1 in your list and I think I have a path forward with that one.

    For issue 2, I think the developers provided a method in the past to make this work. I think they exported ${storageip} or something like that so it was available in the iPXE menu. With that variable it should point to the storage node not the master server. I still need to dig into that to be sure.


  • @Sebastian-Roth Ok, I will open new topics. Thank you.

    On the FOG client, it did instal and the trat icon showed in the taskbar, so I assumed it was running. But, I just checked in Services, and it will not start. I have .Net 4. installed. I will try 4.5.2 and see what happens.

  • Senior Developer

    @eseelke While I do understand all of those topics are kind of related in your point of view they are actually not and I think it’s way better to open a new topic for each of them. Easier to follow and answer if things aren’t mixed up.

    I’ll quickly answer the questions for now but wait with the details until you opened those different topics. Give them names according to what each of them is really about!

    I have Quick Registration set to apply hostname, image, and group. It does all of this, but it will start pulling the image from the master host and not the local storage. Is there a way to force this?

    How did you make quick registration to apply the group setting to a host? Maybe this customization is preventing the location plugin to work properly. There is no other way to force this other than setting the correct location in the host’s settings.

    I have a small 1GB ISO for diagnostics in the menu. It works, but it always pulls it from the master host. I have it stored in each replicated storage. Is there a way to tell it to use local storage instead of master?

    This has been discussed recently. The FOG menu is mostly pulled from the master node. You need to tell it to load the ISO from storage nodes explicitly.

    For above ISO, is there a way to script it, so it pushes to each replication share at creation, rather than manually having to push it? Possibly, have it check the master and if file newer, push out to each?

    George answered this already.

    I have the FOG client installed on each system, but it doesn’t seem to check-in. I am only needing this in order to remotely shutdown or reboot systems. The log file on the client is blank. How can I troubleshoot this?

    If the fog.log file is empty the fog-client has never ever started on this machine. Windows XP is pretty old. Does it even have .NET Framework 4.5.2 (fog-client used 4.0 up until version 0.11.19 but we switched to 4.5.2 with release 0.12.0). Did the installation succeed? Is the service installed and enabled?

    As mentioned above I ask you to open different topics so we can discuss things in depth separately.

  • Moderator

    @eseelke said in FOG Automation:

    I have Quick Registration set to apply hostname, image, and group. It does all of this, but it will start pulling the image from the master host and not the local storage. Is there a way to force this?

    You are probably going to need to create a custom quick registration script. If you have it auto applying the hostname you have probably already edited the quick registration script. If you were to use the full registration there would be a question about what site the target computer belongs in. The rest of your issue is related to the quick registration not setting this value and defaulting to the master node.

    I have a small 1GB ISO for diagnostics in the menu. It works, but it always pulls it from the master host. I have it stored in each replicated storage. Is there a way to tell it to use local storage instead of master?

    The location plugin will manage this to if the target computer is correctly pointed.

    For above ISO, is there a way to script it, so it pushes to each replication share at creation, rather than manually having to push it? Possibly, have it check the master and if file newer, push out to each?

    Yes there is. I do something similar with the windows driver packs to all of the storage nodes. Simply create a folder in the /images directory then go in and manually create a image definition pointing to that directory you just created. Do this on the master node and mirror an existing image definition and change the appropriate fields for the directory you created. Make sure you mark it enabled and enable replication. That directory will then be picked up by the replication engine and sent to all of the storage nodes in the storage group.

    I have the FOG client installed on each system, but it doesn’t seem to check-in. I am only needing this in order to remotely shutdown or reboot systems. The log file on the client is blank. How can I troubleshoot this?

    When you installed the fog client did you point it to the master fog server? This is a requirement. All of the files will come from the storage nodes, but the clients need to talk to the master fog server to pick up jobs.

350
Online

8.6k
Users

15.3k
Topics

143.5k
Posts