Acer Aspire A515-55 Connection Timed Out

  • Hi all,

    Not sure if this belongs in the FOG Problem or the Hardware Compatibility area so I’ll start here for now. We recently installed FOG for testing on a new batch of Acer Aspire A515-55 laptops we purchased for training. However, we’re not able to get into FOG from the laptops themselves. The initial PXE boot works correctly and gets to the white FOG menu, but any option from there fails on loading the init.xz file due to time out ( It also gives a chain-loading issue, but no specifics.

    The strange part though is that if I enter the ipxe command line, I can ping our FOG server just fine. If I use a VM, or one of our other machines (Mostly HP Probooks and Dell Latitudes tested), the FOG server is working just fine, and we can image/inventory/etc. For testing, we’re just using the ‘compatibility check’ page though.

    FOG server Info:
    • Version: 1.5.9
    • Kernel-Version: 5.6.18 (installed from the FOG Server menu) [Have also tried 4.19.143 and 4.19.123]

    DHCP Info:
    • Server: PFSense
    • Network Booting: Enabled
    • Next Server: {FOG server IP}
    • Default BIOS file Name: snponly.efi
    • UEFI 32bit file name: i386-efi/snponly.efi
    • UEFI 64bit file name: snponly.efi
    • DHCP Option 66: {FOG server IP}
    • DHCP Option 67: snponly.efi

    We’ve tried all the various efi files and only snponly and snp were able to boot for any devices. We have two provisioning VLANs setup, one for BIOS and one for UEFI. Both are working from VM so it seems to not be a network-level issue. Also have tried the various EFI Exit modes, with little to no change on the problem as well. Happy to test/report specific combinations if you have any suggestions.

    Aspire A515-55 info
    • Working inside of windows
    ◦ Driver Version: 10.36.701.2019
    ◦ Hardware ID: PCI\VEN_10EC&DEV_8168&SUBSYS_14291025&REV_15s

    I’m at of a loss at this point, grateful for any insight/assistance

    2020_10_21 10_04 AM Office Lens.jpg

    2020_10_21 10_07 AM Office Lens.jpg

    2020_10_21 10_06 AM Office Lens.jpg

  • Senior Developer

    @dtkeith002 said in Acer Aspire A515-55 Connection Timed Out:

    Does FOG offer the ability to listen on multiple interfaces / ips at the same time? I haven’t dug into the config files to see. If so I can try a direct bridge to the server VM and bypass the network completely.

    Don’t think it’s worth going down that route. Testing on the same switch as the server should be enough to rule out most of the network related stuff.

    From the picture we see that it seems to be able to fully download the kernel (bzImage) file but times out on the initrd (init.xz). I would setup a mirror port on the switch and capture traffic on both ends - client port (using a notebook with Wireshark on the mirror port) and directly on the FOG server (e.g. using tcpdump). Use capture filters to restrict traffic to a particular MAC address (ether host aa:bb:cc:11:22:33). Please upload the PCAPs to a file share and post links here.

    If that doesn’t give us enough insights we might compile debug enabled iPXE binaries to analyze the TCP traffic - though this will a tough job!

    Have you tried using ipxe.efi yet?

  • Moved to a switchport on the same switch as the server and still no luck.

    Does FOG offer the ability to listen on multiple interfaces / ips at the same time? I haven’t dug into the config files to see. If so I can try a direct bridge to the server VM and bypass the network completely.

  • Thanks for breaking it out!

    We’re using MSTP on each port, and our switches don’t support green ethernet. I’ll try and reduce the number of switches between the server and the laptop today as well.

    The realtek.efi file fails on the initial DHCP handshake and doesn’t move past step 1.

    Updated the firmware, but the uefi is pretty barebones even after.

    I’ll update again after I try a more direct link.

  • Moderator

    Ok just for clarity there are 3 parts to pxe booting into FOG Imaging here.

    1. PXE Rom in network adapter
    2. iPXE Boot loader (snponly.efi in your case above). The iPXE boot loader is responsible for the iPXE menu and transferring bzImage and init.xz from the FOG server to the target computer and launching it.
    3. FOS Linux (comprised of bzImage [kernel] and init.xz [virtual hard drive]). You will want to be on 5.6.18 but that doesn’t have an impact to your issue.

    So you booting is failing at stage 2. The download of bzImage or init.xz is typically related to intermittent network issues or network adapter. Some of these realtek nics are finicky about the network port configuration. Check to make sure the network port you have these plugged into is configured to use one of the fast spanning tree protocols and has all of the green ethernet features disabled. There is also a realtek specific boot loader realtek.efi that you can try instead of snponly.efi.

    Also make sure the bios (firmware) is up to date on this computer.