Cannot find disk on system (getHardDisk) - Cannot reimage new hardware

  • Hello,

    I have some demo units that I am evaluating for new staff machines. They are Dell Lattitude 7410 2 in 1 computers. They don’t have a built in NIC, but I did purchase docking stations with them. I am able to change the DHCP Bootfile Name to ipxe.efi and get the machines to PXE to my FOG server. However, when I select “Perform Full Host Registration” it does it’s thing and reports back “Cannot find disk on system (getHardDisk)” then it reboots after 1 minute.

    Some background, I know nothing about Linux and muck my way through this world with suggestions from this forum. I will try and include as much information as I can about what I am running:

    In the GUI, under FOG Version Information it says (DefaultMember FOG Version: (

    When I putty into my FOG server and run “uname --kernel-release --machine” I get “4.4.0-66-generic x86_64”

    I seriously cannot tell you what that means, I believe when I set this up I installed Ubuntu and followed some regiment of commands to update the server during the time of installation.

    I get new machines every 2nd and 3rd year on a rotation, meaning this is a year where I need to imagine new models. I need to get these units out for evaluation as soon as I can but need to make sure they work with FOG as I manage 1400 computers by myself, and yes that means reimaging them every year.

    So please, call me a noob, novice, happy clicker or whatever it takes to get this user some help 🙂

    Attached is the picture of my error message on the Dell Client machine. Error.jpg

  • Senior Developer

    Turns out the DNS server was not ser correctly and the server got it’s IP via DHCP. We got that fixed.

  • Senior Developer

    @michaeloberg Let’s switch to chat -> speech bubble in the top right corner of the forum.

  • @Sebastian-Roth Unknown, I should. I know in the past when I ran updates I had to download updates by typing in:
    sudo apt-get update && apt-get install git

    then something like

    git checkout dev-branch

    and it would download something from

    This is from my notes when I updated the fog server in Feb. 2019. So these may not be entirely accurate but I know that it downloaded something??

    I can also ping from the FOG server. Lost I am 🤢

  • Senior Developer

    @michaeloberg So you don’t have internet access from this server?

  • @Sebastian-Roth I was able to follow along until the line where I type the wget command, it comes back with “failed:Temporary failure in name resolution” Below is everything I had type in Putty:

    root@fog-server:~# cd /var/www/html/fog/service/ipxe
    root@fog-server:/var/www/html/fog/service/ipxe# mkdir backup_kernels
    root@fog-server:/var/www/html/fog/service/ipxe# mv bzImage* backup_kernels
    root@fog-server:/var/www/html/fog/service/ipxe# wget -O bzImage
    –2020-10-13 12:35:45--
    Resolving (… failed: Temporary failure in name resolution.
    wget: unable to resolve host address ‘

  • Senior Developer

    @michaeloberg Give that a try (run as root) :

    cd /var/www/html/fog/service/ipxe
    mkdir backup_kernels
    mv bzImage* backup_kernels
    wget -O bzImage
    wget -O bzImage32
    chown www-data:www-data bzImage*

  • @george1421 I am such a novice at this I don’t know how/where to start. I downloaded the 2 files to my Windows 10 PC, and renamed them (watching the case) to my downloads folder. Then I putty into my FOG server, but am stuck. I am guessing I was supposed to download the files from my FOG server but don’t know how. Simple tasks like that - downloading files, moving, and renaming are difficult because I have no Linux knowledge. In the DOS world I can easily copy, rename, move, create, delete folders but the syntax is different and just a simple, type this “xyz” to download files, then type “abc” to navigate to your Kernel folder, then “qwe” to rename your old files, then whatever else would be helpful. I am sorry as this has to drive you mad working with people like me. I need to learn, I want to, but for lack of better excuses - I don’t have time.



  • Moderator

    @michaeloberg Kernel update. If your fog server doesn’t have direct internet access then you can download the kernels from here:

    Grab these two files

    Rename them to this respectivly.
    Kernel.TomElliott. -> bzImage
    Kernel.TomElliott. ->bzImage32

    Watch your case because it IS important.

    Now move those files to /var/www/html/fog/service/ipxe directory. It probably wouldn’t hurt to rename the existing ones in case you need to go back for some reason.

    The next time you pxe boot the updated kernels will be used.

  • @michaeloberg @george1421 My colleague figured out that we need to disable the MAC address pass through and now it is uploading 🙂 I need to wait for this to finish then pull it down to have a valid test, but things are looking up for imaging at least. Still no progress on the Kernel update, is that needed?

  • @george1421 A bit puzzling this one is. I deleted the Host from FOG, then re-registered it using a different name: ST-3501. Then I created an image upload task for the Host, and rebooted - same thing “Host is not registered!”. So I rebooted and when I hit F12, Choose USB NIC (IPV4), then it states - "Start PXE over IPV4 on MAC: CC-48-3A-A9-6D-16. See attached:

    PXE Boot MAC.jpg

    But when I choose Client System Information from the FOG Boot menu it gives me a different MAC which matches the printed label on the WD19 Dock:
    FOG MAC Addresses.jpg

    When I click on the Host name in the dashboard, the MAC it lists there is the MAC on both screens in the previous Pic.:

    Client Snip 2.JPG

    So I am not sure where that, I will call it “Booting MAC address of " CC-48-3A-A9-6D-16” is coming from and that might just be my problem?

    Also regarding updating the Kernel, I don’t have an option to download anything. I don’t have proxy configured and not sure what to try next.

  • Moderator

    @michaeloberg I guess a couple of things here.

    The host not registered kind of indicates the mac address of the target computer has changed since registration. If you are using a wd19 dock that should have a static mac address assuming you are using the same computer you registered with. (fwiw, the wd15 dock is much more stable than the wd19 dock but I don’t think the wd15 is thunderbolt, only usb-c) My daily driver is a 7400. If you look in the bios (firmware) on the system information page there is a passthrough mac address. This address needs to (should) match the host registration in FOG.

    For the 7400 we needed to go into System Configuration->Thunderbolt Adapter config.
    Enable thunderbolt
    Enable thunderbolt boot support
    enable thunderbolt pre-boot modules
    No security

    To make it pxe boot reliably (and use a wd15 dock or the usb-c to ethernet dell dongle.).

    Kernel update, does your FOG server have internet access? If you access the internet via a proxy server you need to configure that in FOG so it can reach the FOG servers online to read in the kernels. On the screen you shown there should be large buttons under the header to allow you to down. If your fog server can’t reach the internet because of your security policy there is a method to manually download the updated kernel.

  • @george1421 said in Cannot find disk on system (getHardDisk) - Cannot reimage new hardware:

    Also update your fos linux kernels. Be aware this has nothing to do with the FOG Host server but with FOS Linux. Goto FOG Configuration -> Kernel to update FOS Linux kernel.

    Thank you kindly for the information regarding the HDD configuration in the system BIOS. After I changed the RAID setting to AHCI and reloaded Windows I was able to register the host - well sort of 😨

    I stepped through the process of “Perform Full Host Registration and Inventory” and can now find the host in my FOG Dashboard, but when I create a capture task for the image and reboot, F12, select IPV4 PXE, it comes back to the White screen and in RED states : Host is NOT registered! I don’t know if this makes a difference but I am using a Dell Thunderbolt dock with integrated NIC, the computer doesn’t have an RJ45 jack.

    In addition to this, when I go to FOG Configuration-> Kernel Update
    The right windows says “This section allows you to update the Linux kernel which is used to boot the client computers. In FOG, this kernel holds all the drivers for the client computer, so if you are unable to boot a client you may wish to update to a newer kernel which may have more drivers built in. This installation process may take a few minutes, as FOG will attempt to go out to the internet to get the requested Kernel, so if it seems like the process is hanging please be patient.”

    I don’t see an option to update (button or instructions to fire off the process).

    Attached is the screen capture of client screen where it states it is not registered, also a screen capture of the client in FOG, and finally a screen capture of the Kernel Update settings.

    Client Error.jpg

    Client Snip.JPG

    Kernel Snip.JPG

  • Moderator

    In the dell firmware change the disk mode from raid-on to ahci mode then it will find the disk. This is a know linux/dell/intel raid controller issue.

    Also update your fos linux kernels. Be aware this has nothing to do with the FOG Host server but with FOS Linux. Goto FOG Configuration -> Kernel to update FOS Linux kernel.