DHCP option 67



  • Good morning all,
    After several tries, I cannot configure the DHCP so that it points correctly to FOG.
    I put on option 66 the IP address of my server.
    And in 67 I tried several boot files (pxelinux.0 and undionly.kpxe) but unable to start on the server (File not found according to the client machine.)
    I was also able to try with dnsmasq but without success. I have now uninstalled it.
    For info I have the latest version of fog.
    Thank you for your answers.


  • Moderator

    @FOG38640 said in DHCP option 67:

    There is nothing in the kernel version.

    Does your fog have direct internet access or is it via a proxy server? If its via a proxy server you will need to set the proxy server fields in FOG Configuration -> FOG Settings ->Expand All -> Proxy Settings


  • Moderator

    @FOG38640 said in DHCP option 67:

    The address of fog is 192.168.0.168.

    Ok well that would be wrong in the settings. Look under FOG Configuration -> FOG Settings -> Expand all (button)

    Search for 192.168.0.54 this IP address should not be set in any of the configuration settings. If it exists replace it with the FOG server IP. This error is because the ip address check is wrong.



  • There is nothing in the kernel version.

    f75fc1aa-0373-4d6e-a210-708cc2d53d33-image.png



  • The address 192.168.0.54 is the address of the DHCP server (Windows server).
    The address of fog is 192.168.0.168.
    The computer’s network card is an Intel Gigabit.


  • Moderator

    @FOG38640 said in DHCP option 67:

    My kernel is up to date and fog to the latest version 1.5.9

    This does not mean you have the latest kernel. There was a new kernel released right after 1.5.9 was released. The 1.5.9 release used 4.19.143 and the updated kernel is 5.6.18,


  • Moderator

    @FOG38640 This issue isn’t related to pxe booting. This is something in fos linux. I would recommend you update to the latest kernel (fog configuration -> Kernel update).

    Lets confirm a few things too.
    Is your fog server at 192.168.0.54?
    Can you access the fog server at http://192.168.0.54/fog ?
    What network adapter is in this target computer?

    According to the messages this should be working. We have seen some realtek nic behave a bit odd on occasion.



  • My kernel is up to date and fog to the latest version 1.5.9

    What was your message?


  • Moderator

    This post is deleted!


  • 572/5000
    Good morning all,
    I am coming back to you after having been able to test the fog server on real machines. These all have catch spots. I tried with multiple conf files in DCHP option 67 but got an error message.
    Here it is :
    Is there something to do?
    Good morning all,
    I am coming back to you after having been able to test the fog server on real machines. These all have catch spots. I tried with multiple conf files in DCHP option 67 but got an error message.
    For information 192.168.0.54 is a dhcp server (Windows server 2019)
    Here it is :
    65c23ce2-c622-4860-902e-11419191b70c-image.png
    Is there something to do?



  • This post is deleted!

  • Moderator

    @FOG38640 Hyper-V is a bit of a strange bird. If you get to the initalizing devices then you will have no issues with a physical machine. You just need to be mindful of the target arch of the pxe booting computer and send the right boot file. With hyper-v a type 1 (bios) typically use undionly.kpxe, if that is getting stuck then try ipxe.kpxe. For uefi ipxe.efi is the preferred and the alternate is snponly.efi.



  • @Sebastian-Roth and @george1421
    Thank you both very much for your help !! I will have spent a phenomenal time there to resolve the problem.
    I will be testing the FOG server on physical computers next Friday when I move into the company.

    I have so far tested on a hyper-v VM and then yesterday the screen has not changed. I don’t know if this is normal.
    I will keep you up to date with the progress.

    a4962742-65e2-4e18-8e2c-93b7b9c62e8b-image.png

    Thank you 😊


  • Moderator

    @FOG38640 To add on to Sebastian’s post.

    We find sometimes that the FOG Administrator gets instructions to go to the webui to install the database and then forgets to go back to the linux console and press enter to finish the install. The command line installer has 2 parts. They think that when the web ui is up FOG is finished installing, that is wrong.

    Rerun the installer again and pick the same options you did the first time. It will not break your system if you rerun the installer at this point to completion. If the .fogsetting file exists then you are done.


  • Senior Developer

    @FOG38640 You initial FOG install did not run all the way to the end. Please re-run the FOG installer and make sure it’s finishing.



  • I just executed the 2 commands. Here is their result.
    4fd3c094-b77c-4168-8ee1-4c846bb399c9-image.png
    Thank you for your answers.


  • Moderator

    @FOG38640 Will you run this command

    cat /opt/fog/.fogsettings

    All I care about is if it returns data or not. I don’t need to know the data.

    If no data the ls -la /opt/fog we are looking for a file called .fogsettings If that file doesn’t exist then the FOG Installer did not complete correctly.



  • @ george1421 I tried the file “ipxe.efi” and “pelinux.0” but it still does not work.
    @ Sebastian-Roth
    Here is a screenshot of the 2 commands I just performed :
    c7bc5318-474e-4394-bb01-9e829c9f16a5-image.png

    Merci 😊


  • Senior Developer

    @FOG38640 I assume 192.168.0.168 is you static FOG server IP, right?

    As you seem to have tried undionly.kpxe before according to your initial post I am wondering if TFTP is running on your server (netstat -an | grep 67) and if the files do exist (ls -al /tftpboot/). Run both those commands and post output here.


  • Moderator

    @FOG38640 FYI FOG doesn’t use syslinux (pelinux.0) for booting. If you have a bios system it should be undionly.kpxe and for a uefi system its ipxe.efi.


Log in to reply
 

354
Online

7.5k
Users

14.6k
Topics

137.3k
Posts