• I just tried doing an upgrade from 1.5.6 to 1.5.9 and ran into the following. I get the following error on the screen.

     * Checking package: zlib1g....................................OK
    
     * Configuring services
    
     * Setting up fogproject user..................................Skipped
     * Locking fogproject as a system account......................OK
     * Setting up fogproject password..............................Failed!
    
    !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
    !! The installer was not able to run all the way to the end as   !!
    !! something has caused it to fail. The following few lines are  !!
    !! from the error log file which might help us figure out what's !!
    !! wrong. Please add this information when reporting an error.   !!
    !! As well you might want to take a look at the full error log   !!
    !! in /home/omega/fogproject-master/bin/error_logs/fog_error_1.5.9.log !!
    !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
    
    passwd: password unchanged
    Current Kerberos password: Current Kerberos password: passwd: Authentication token manipulation error
    passwd: password unchanged
    Current Kerberos password: Current Kerberos password: passwd: Authentication token manipulation error
    passwd: password unchanged
    

    Here’s what’s in the log file.

    ii  zlib1g:amd64   1:1.2.11.dfsg-0ubuntu2 amd64        compression library - runtime
    Current Kerberos password: Current Kerberos password: passwd: Authentication token manipulation error
    passwd: password unchanged
    Current Kerberos password: Current Kerberos password: passwd: Authentication token manipulation error
    passwd: password unchanged
    Current Kerberos password: Current Kerberos password: passwd: Authentication token manipulation error
    passwd: password unchanged
    Current Kerberos password: Current Kerberos password: passwd: Authentication token manipulation error
    passwd: password unchanged
    Current Kerberos password: Current Kerberos password: passwd: Authentication token manipulation error
    passwd: password unchanged
    Current Kerberos password: Current Kerberos password: passwd: Authentication token manipulation error
    passwd: password unchanged
    Current Kerberos password: Current Kerberos password: passwd: Authentication token manipulation error
    passwd: password unchanged
    Current Kerberos password: Current Kerberos password: passwd: Authentication token manipulation error
    passwd: password unchanged
    Current Kerberos password: Current Kerberos password: passwd: Authentication token manipulation error
    passwd: password unchanged
    Current Kerberos password: Current Kerberos password: passwd: Authentication token manipulation error
    passwd: password unchanged
    

    Any ideas? This is on a test system I cloned from production.

    Thanks


  • @Sebastian-Roth Just upgraded my production machine to 1.5.9 without using the -X option and it worked. I think the difference is on my test system I’ve migrated from a Samba NT4 domain to a Samba Active Directory domain. If you want any extra info on my test system to fix anything with the installer just let me know but I think I’m good to go.

    Thanks

  • Moderator

    @chunter2 said in Upgrade error on Ubuntu 18.04:

    Is it maybe for upgrades from older versions of fog?

    Yes. We used the account fog before. And for more current updates we still wanna make sure the correct password is set.


  • @Sebastian-Roth I did a ‘su fogproject’ and entered the password and it worked so I didn’t bother setting it again. I then ran the setup with the -X and besides the password error again it passed everything else and it seems to be up and running. Any reason why an upgrade is trying to set the password again? Is it maybe for upgrades from older versions of fog?

    Thanks

  • Moderator

    @chunter2 I see, you still have this server running as AD controller and maybe some other things too.

    In this case I would suggest you manually add that user account and run the installer using a parameter to ignore failures and just keep going:

    grep TFTP_FTP_PASSWORD /var/www/html/fog/lib/fog/config.class.php
    ...
    

    Use the password you see to set manually on the console:

    passwd fogproject
    ...
    

    Now re-run the FOG installer including the parameter:

    ./installfog.sh -X
    ...
    

    Hint: Use this parameter with caution, as it might skip other more important steps too. Keep an eye if it says “Failed” at another point as well and let us know.


  • Here’s the output of those commands.

    grep passwd /etc/nsswitch.conf
    passwd:         files winbind compat systemd
    
    grep -e kerberos -e krb /etc/pam.d/*
    /etc/pam.d/common-account:account       required                        pam_krb5.so minimum_uid=1000
    /etc/pam.d/common-auth:auth     [success=3 default=ignore]      pam_krb5.so minimum_uid=1000
    /etc/pam.d/common-auth:auth     [success=1 default=ignore]      pam_winbind.so krb5_auth krb5_ccache_type=FILE cached_login try_first_pass
    /etc/pam.d/common-password:password     [success=3 default=ignore]      pam_krb5.so minimum_uid=1000
    /etc/pam.d/common-session:session       optional                        pam_krb5.so minimum_uid=1000
    /etc/pam.d/common-session-noninteractive:session        optional                        pam_krb5.so minimum_uid=1000
    

    Thanks

  • Moderator

    @chunter2 said in Upgrade error on Ubuntu 18.04:

    Current Kerberos password

    @chunter2 Please run the following commands and post results here:

    grep passwd /etc/nsswitch.conf
    grep -e kerberos -e krb /etc/pam.d/*
    

396
Online

9.0k
Users

15.6k
Topics

145.2k
Posts