OSx won't load after Macbook Pro is imaged. Get 'Cross-out' symbol on boot



  • After battling to get the macbooks to boot to iPXE and capturing the image (OSx 10.10.2), I can’t get any of the Macbooks to actually boot after imaging. After imaging, upon the initial boot, I get the typical loading bar but then it goes to the ‘Circle with line through it’ symbol screen.

    For my core image, I’m using an early-2011 Macbook pro with a 16g sata drive that has OSx 10.10.2 installed. Nothing else.

    I’m imaging TO a mid-2012 Macbook pro with a 500g sata drive.

    I’ve tried using single disk AND all disks images (both non-resizable) which both give the same results. Booting into recovery mode doesn’t show any options for a boot disk when trying to restart.

    Does anyone have any idea what I could be doing wrong? I’m considering a different version of OSx but not sure if that would have any impact. Thanks for any help!


  • Moderator

    @smoooo Unfortunately, Apple is not in the habit of creating open source tools for the community to use, so there’s very little to no options for such things.



  • @smoooo So far my only work around for this is:

    After finishing imaging, booting into a Parted Magic live USB.
    Using the gdisk utility to move the 2nd partition table to the end of the HD.
    Restarting and booting into a OSx installer USB stick.
    And finally using Disk Utility inside the installer program to expand the OS partition to use all of the available free space.

    There HAS to be a better way!!



  • @Sebastian-Roth Ok, so…I’ve discovered what my problem is. Copying the 16g image RAW over to a new laptop results in that same 16g install partition at the beginning of my much larger HD. With Guid, the partition table is written twice on the drive for some reason. So now, at the end of my 16g partition is a backup copy of the partition table. And so far, nothing wants to make moving that to the end of the disk and expanding my 16g install to the full disk capacity an easy task.

    Am I the only one dealing with all this when imaging Macs??


  • Senior Developer

    @smoooo Good to hear! You are more than welcome to share your findings here in the forums.



  • @Sebastian-Roth honestly, I missed that part initially but found it right after my latest post. I actually just successfully got the partition to expand using some combination of gparted and disk utility. Now I’m trying to nail down exactly what made it work so I can streamline the process.

    Do you have any insight on which imaging technique I should use? Is the RAW method still required now that I’ve converted away from Core Storage?

    Thanks for the help and replies Mr Roth!


  • Senior Developer

    @smoooo Did you see the link I posted about converting a core storage setup to a normal one?



  • @Sebastian-Roth Yes. Since 10.10.5 was released in 2017 it appears to use the core storage architecture. Its only using a single drive so Fusion isnt used.

    I’m actually running into an issue resizing the osx partition after the imaging process. Not even gparted seems to be able to make the changes?

    Does anyone else have this setup working and can give me some pointers or have any idea what I could be doing wrong?


  • Senior Developer

    @smoooo I expect you install is based on Apples Core storage - similar to LVM in Linux. See information about this here:



  • Breakthrough!!

    Holy cow!! Ok so creating the image as a dd/Raw image actually works!! The imaged units all boot up into OSx!! For anyone reading this now I’d be more than happy to relay my methodology.

    That said, I still need to figure out the proper way to resize the OS partition from the 16g to the full capacity of the hard drive. Again, any advice is appreciated.


Log in to reply
 

308
Online

7.5k
Users

14.6k
Topics

137.7k
Posts