PXE-E18: Server response timeout


  • Hi, I was working with fog recently and for few days everything worked fine.
    I could capture/deploy images, but today I “finished” work so I thought that I’ll delete all hosts because I don’t need them now… Later when I booted up laptop to PXE I can see this:

    checking media presence…
    media present…
    start PXE over IPv4 on MAC XX:XX:XX:XX:XX:XX
    Station IP adress is 10.0.2.129
    .
    Server IP adress is 10.0.2.15
    NBP filename is ipxe.efi
    NBP filesize is 0 Bytes
    PXE-E18: Server response timeout

    Dell Latitude 5410
    SATA Mode: AHCI
    Secure boot: OFF
    Wake On Lan /w PXE ON

    I have windows 10 with 2 virtual machines.

    1. CentOS /w FOG
      2.Pfsense as a firewall

    I use tplink’s 1Gb/s switch to connect laptops to serv
    As you can see above PFSense works because of DHCP server, “next server”. Devices are in the same local network - I can open webgui of fog/pfsense from windows and from other devices which I connect to the switch.
    I disabled firewall in windows and in CentOS with tutorial from wiki.
    TBH I have no clue what happened - I reinstalled FOG and PFSense and it’s still the same.
    I’ll send tcpdump tommorow when I’ll have acces to machine

  • Senior Developer

    @Pyrol said in PXE-E18: Server response timeout:

    I reinstalled FOG and PFSense and it’s still the same.

    You are using pfSense as DHCP server. Please share the settings you have in there (picture) as well as the information requested by George.

  • Moderator

    @Pyrol said in PXE-E18: Server response timeout:

    10.0.2.15

    Is that the IP address of your fog server?

    Can you confirm by running this command on your fog server ip a s

    Also run these commands on your FOG server

    sudo systemctl status firewalld
    ls -la /tftpboot

357
Online

8.1k
Users

15.0k
Topics

141.4k
Posts