Need Help with Capture and Hard Drive Issue

  • Hello this is my first post because I am at completely out of my depth and this is driving me crazy. We have a computer running as a FOG server running Ubuntu. As far as I know the FOG server is running fine, but it is running version 1.5.7 and the kernel is 4.19.48. I know that the FOG server is out of date, but I don’t know if that is causing the issue or if it something I am doing. So the issue is that I have these Nexlink computers. They are old and not many left and the image that we have for them is over a year old now. I would like to update the image on the FOG server for them. I have free time and tired of wasting a bunch of time when I have to image one and apply a ton of Windows Updates. So I have 3 times now fully updated a NexLink computer and done a capture.
    The steps I take to fully update the computer are:

    • Fully update Windows 10
    • Fully update Smart Notebook and drivers
    • Update Java
    • Disk cleanup delivery optimization files, Windows Update Cleanup, Windows upgrade log files, recycle bin, and system restore and shadow copies
    • Remove any user profiles
    • Add some specific shortcuts to the desktop: Word, This PC, and VLC player

    For my capture I have the same options as the old image. They are:

    • Operating System Windows 10
    • Image Type Single Disk Resizable
    • Partition Everything
    • Image Enabled Checked
    • Replicate? Checked
    • Compression 6
    • Partclone Gzip

    I schedule the capture and restart the client Nexlink and the capture starts. The captures finishes and the container in the fog server shows that it is taking up this much storage and the date/time captured. The client Nexlink restarts and then it stops telling me to press DEL or F2 to enter BIOS and I can no longer use the machine with that hard drive plugged in. I can’t even access the BIOS by pressing DEL or F2. I can’t access the BIOS again, unless I replace the hard drive with a different one. This has happened to 4 different hard drives.

    Lastly, here is what is driving me nuts. After the third try, I swapped out for another hard drive that had an older image on it. I did nothing to it and did the same steps to capture it. It captured just fine and I could still boot up the client Nexlink hard drive after the capture.

    So its got to be what I am doing that is causing this, but what? Also are these hard drives completely unusable now?

    Please help
    Thank you

  • Senior Developer

    @bluedude Thanks for the update. Unfortunately I have not a clue what could have been wrong with those disk that kept your machine form even booting up. No idea really. Looks pretty alright in the pictures.

  • @Sebastian-Roth Hello, sorry it took so long, but I finally got my hands on a USB/SATA adapter. I was able to use disk management to have a look at the drives.

    This is what I got as soon as I launched disk management.

    I changed it to make it online, and then it changed to this.
    573ec209-2ab1-4fd7-8120-167830064404-image.png ![0_1602863834432_0837ce1f-6c3f-4f9a-94ac-3a045b88567f-image.png](Uploading 0%)
    Image Continued

    The good news is that out of the 5 drives, I was able to use diskpart command via the command line and clean 4 of the hard drives. Once I cleaned those 4 hard drives, I was able to reconnect them and access the BIOS and get to FOG to deploy an image. I think I will just toss the 5th hard drive. Its pretty old and it is only a 80GB drive. Not sure if these photos will give you any information as to why this happened or what I did to cause this.

  • @Sebastian-Roth Figures I would screw up something this bad. I don’t have time today to try that. I do have a Lenovo desktop, in the building somewhere. Once I find it, I’ll try connecting it to that and see if it is able to boot.

    I tried to hot swap in a bad image hard drive. I thought it read you could do that with SATA connections. I kept good drive connected initially, and booted into Windows 10. Once I was in, I reconnected the bad image drive and opened disk management. Unfortunately, it would only recognize the hard drive with the good image. It did not recognize the bad image hard drive. I do not have a USB/SATA adapter,. My buddy may have one. I am going to ask him if he does, if I could borrow it. Although, its going to be a few days before I can do any of this.

  • Senior Developer

    @bluedude said in Need Help with Capture and Hard Drive Issue:

    So I am not sure what you are saying in that first paragraph. Are you saying I shouldn’t capture with resizable because FOG can’t resize it anyway? What should then I set the Image Type too then?

    More or less this is what I am saying. The resizable image type won’t help you to make this image fit onto a smaller size disk because the third and fourth are special partitions and seen as fixed by FOG. If you want to keep that partition layout you can just use the non-resizable image type and save you some time as it doesn’t even try to resize then.

    So it seems like those disks in the current state can’t be used in your machines anymore. From my experience this is a very rare situation and I can’t remember we had this being reported before.

    Do you have a different type of PC/notebook that you could connect the disk to? Do you have a USB/SATA adapter that you can use to connect the disk after the machine booted up so we can take a look at it?

  • @Sebastian-Roth I scheduled the debug and plugged in one of the four hard drives with the bad image. PXE is enabled and first priority to boot and this is all it is doing.

    F2 or DEL does nothing and will not let me continue any further.

  • @Sebastian-Roth So I am not sure what you are saying in that first paragraph. Are you saying I shouldn’t capture with resizable because FOG can’t resize it anyway? What should then I set the Image Type too then?

    Also, I stated that the pics yesterday is from a working image. Yesterday, I over wrote the bad image in FOG with this good capture. Although, the bad image is still on these 4 nonfunctioning hard drives. Whenever I have one of these four hard drives plugged in, even with a another good hard drive with a good image and with PXE enabled with PXE set to boot first, the machine is unable to do anything.

    I will try and schedule a debug, but I doubt it is going to work. I will let you know if it does.

  • Senior Developer

    @bluedude We see that the partition number two (sda2) was shrunk downto one quarter of the size it normally has but because of the recovery partitions (type=27 is a “hidden” NTFS partition) this image won’t fit onto a smaller size disk anyway. Those partitions three and four are blocking an efficient resize and FOG won’t move the start sector of those because it would break the recovery.

    On the other hand I don’t see why a disk could be in an unusable state because of this. The minimum partition table looks just fine and I can’t see (yet?) why a PC wouldn’t even let you access the BIOS settings anymore.

    Does the PC boot to PXE? Would you be able to schedule a debug capture task as I said before? We need to get a picture of what’s on that disk. The other ways you could try is to install the disk to a compete different model PC if you have one or download some kind of Linux live boot ISO (Ubuntu Live, SystemRescueCD, …). Whichever you are able to boot up, please open some kind of terminal/console and run sfdisk -l /dev/sda

  • Senior Developer

    @bluedude Well there goes whatever idea I may have had.

    Sorry, it was a thought and didn’t pan out. I tried.

  • @Tom-Elliott
    Hello Tom-Elliott,

    I was able to get access to one of the user accounts. Here is the info you requested.
    ls -l /var/www
    ls -l /var/www/html

  • @Sebastian-Roth
    So I was able to figure out the password to one of the user accounts on Ubuntu. I was also able to get XRDP installed and working. I was able to finally get the information you asked for. Although the bad image that I had, I copied over with a capture that is working. I don’t know if this is going to help anymore, but here is the info you requested.

  • @Tom-Elliott
    Hello, I haven’t used Ubuntu since college so I don’t remember it that well. Plus I am not the one in front of it at the the site its at. When we tried to install xrdp using the command sudo apt install xrdp it asked for a password. I don’t know the password and neither does the new network specialist. We don’t login to the account, the account is always just active.

    For the BIOS, it shows on the splash screen to enter press F2 or DEL, which I do. Although it refuses to do anything with the hard drive still plugged in that I either deployed that bad image too, or when I try to capture from. The splash screen just sits there. Last night I deployed that new capture and the machine finished and restarted. It sat there the entire night at the splash screen, until I came in this morning and removed the hard drive. As soon as I did, boom I could press F2 and access the BIOS.

    As for the FOG version, I don’t have access right now, but here is what the web server shows.

  • Senior Developer

    What do you mean by “sudo” password?

    When you do: sudo -i or sudo su - on the command line, the password it’s expecting is the exact same password as the one you used to sign into the machine in the first place.

    Of course, this means the user you’re signing in with needs “sudo” privileges. If you don’t know the account that has sudo, then you might be in a bind. That will take a little more advanced knowledge than I could give over a single post on the forums.

    In regards to accessing your BIOS, you should be able to access this with or without a hard-drive, period.

    BIOS, whether old or new style (BIOS vs UEFI/EFI) is before Network boot, or anything. There’s going to be some sequence to get into the bios. This could be any key from:

    If I don’t know what key to press, I will keep pressing them all immediately after I press the system’s power button.

    The HDD’s are very unlikely to be in an “unusable” state. The partition tables maybe all wiped out for some reason.

    I’ve heard of similar issue for FOG versions back in the day, like the 1.3.5 RC series. What version of FOG are you guys running? I know you said 1.5.7, but this seems very sketchy to me. Sometimes, we’ve seen, where you install a version, and you technically have 2 versions installed. If you can logon to the machine what’s the output of:
    ls -l /var/www
    ls -l /var/www/html

    Keeping in line with @Sebastian-Roth I really think the partition table is jacked up which is partly what’s causing the issue I think.

  • Hello Sebastian Roth,

    Thank you for trying to help but I have hit a wall. This FOG server is not at my site and I am not able to get to the physical server. I tried to have someone else install xrdp so I could remote in but we need the password for sudo and none of us know what it is. I contacted the previous network specialist and he does not remember what it is. I fell like Hal from Malcom in the Middle. I found this video and it seems pretty straight forward, but I have to clear it with my boss before we do it.

    As for making the image resizable, we do have hard drives that vary in capacity from 80GB to 2TB. I assume that is why he choose resizable.

    I didn’t know you could schedule a debug task. Although I doubt it will matter because the very first hard drive I captured, I set the BIOS CSM to on and all devices to legacy BIOS. Then I made the network card the first priority and after the capture it could never get past the BIOS splash screen unless I unplugged the hard drive and swapped it out.

    Since I’ve run into so many access problems, I think I will just close this issue for the time being. I think its something I am doing. I am going to redeploy an old image, just do windows updates, and then just capture it and see what happens.

    Thank you for trying to help.

  • Senior Developer

    @bluedude said in Need Help with Capture and Hard Drive Issue:

    Also are these hard drives completely unusable now?

    I wouldn’t think so and actually really hope they are. I can’t see how FOG would be able to destroy a disk in a single capture.

    Let’s start to look at the pieces to see what’s going on. Please take a look at the files you have on your FOG server in /images/NAME_OF_THE_IMAGE/.... There should be a few smaller size text files named p1.partitions, d1.minimum.partitions and d1.fixed_size_partitions. Post the contents of these text files here in the forums.

    Image Type Single Disk Resizable

    Do you really need a resizable image type? Do you want to deploy this image to different size disks?

    I can’t even access the BIOS by pressing DEL or F2. I can’t access the BIOS again, unless I replace the hard drive with a different one. This has happened to 4 different hard drives.

    At some point we shall try to take a look at those disks to see what’s going on. What happens if you put one of those back into a PC, schedule a debug task for this machine, PXE boot into the task and run sfdisk -l /dev/sda on the console?