Storage Node Disk not showing



  • Re: Storage node Disk Usage not showing full disk
    Hello guys
    I have a similar problem:
    I have an FOG server installed as Master Node + 4 Storage Nodes
    The problem is that one of the Storage Nodes does not display my capacity correctly and what space is free / occupied
    FOG Master Node is version 1.5.9
    And Storage Nodes are varied between 1.5.9 and 1.5.8
    I also checked the box to show the Graph … and still nothing …
    I want to specify that I tested a PC from that location of the Storage node and I also have a small problem there … I attach images ( p.s. firewall is down from tat location where the Storage Node is instaled)
    37ea0a8b-a857-4d89-87c4-433a2c2eb903-image.png
    b0685171-298c-42a6-aaa4-1f3111d48124-image.png
    9826c011-6fea-427e-882f-6e6d4c634018-image.png
    ![0_1601459932755_ca1707e5-d484-46fa-9570-f657a3c43665-image.png](Uploading 100%)


  • Senior Developer

    @AlexPDX When I looked at this on the smartphone earlier today it did not load the second picture and so I misunderstood the issue. The master nodes sends a HTTP request (URL http://x.x.x.x/fog/status/freespace.php?path=/images) to the storage node to get that information. The storage node checks if the given path exists, is readable and a directory. If not it returns no values.

    So your link /images -> /home/fogproject/images is causing the issue. Linking can be somewhat hideous and I would never advice anyone to link to the images directory just to mask that it was setup the wrong way in the first place.

    I suggest you move all the content from /home/ to a temporary location, re-mount that partition (/dev/mapper/centos-home) into /images and move all the stuff you had in /home/fogproject/imagesover to the new/images` (residing on the extra partition.


  • Senior Developer

    @AlexPDX When I looked at this on the smartphone earlier today it did not load the second picture and so I misunderstood the issue. The master nodes sends a HTTP request (URL http://x.x.x.x/fog/status/freespace.php?path=/images) to the storage node to get that information. The storage node checks if the given path exists, is readable and a directory. If not it returns no values.

    So your link /images -> /home/fogproject/images is causing the issue. Linking can be somewhat hideous and I would never advice anyone to link to the images directory just to mask that it was setup the wrong way in the first place.

    I suggest you move all the content from /home/ to a temporary location, re-mount that partition (/dev/mapper/centos-home) into /images and move all the stuff you had in /home/fogproject/imagesover to the new/images` (residing on the extra partition.



  • Please explain at least how the information from Storage Node reaches Master Storage? There is a “push” from Storage Node to Master Storage, or a “pull” made my Storage Master to Node Storage ?



  • In the output we see that most space is being used by /home. Probably someone made a mistake when setting up the partitions in the initial Linux install.

    I don’t understand what this has to do … even if the storage space installation is wrong … it had to report something, BTW the space in / home I think is big enough, I understand it would have been a problem if it was smaller.
    The images folder is a soft link to / home / fogproject / images
    “who” handles this reporting of space from Storage Node to Master Node?


  • Senior Developer

    @AlexPDX In the output we see that most space is being used by /home. Probably someone made a mistake when setting up the partitions in the initial Linux install.



  • @Sebastian-Roth
    CentOS Linux release 7.5.1804 (Core)
    This screenshot is from the Storage Node that dose not report corectly

    5fe34e4e-48d4-4f27-b185-0f31c22f2a74-image.png


  • Senior Developer

    @AlexPDX said in Storage Node Disk not showing:

    The problem is that one of the Storage Nodes does not display my capacity correctly and what space is free / occupied

    Please run df -h on each node and post all the results here.

    For the second issue I may ask you to open another forum topic to not mix up things.



  • This post is deleted!

Log in to reply
 

366
Online

7.5k
Users

14.6k
Topics

137.3k
Posts