FOG Kernel update: "Preparing to move to tftp server"


  • Hi.
    I’ve a problem with pxe boot not finding an interface. I read that this can be caused by kernel (bzImage/32 version 4.19.145 from september).
    I wanted to update like people say on the enternet by going into ‘fog configuration’ and in ‘kernel update’ tab install kernel 5.8.18 64 but
    it says:

    download succeded
    Download Complete! Preparing to move to tftp server.

    I waited about 30min and nothing happend, also I tried manual update with script:
    https://wiki.fogproject.org/wiki/index.php?title=Kernel_Update1

    I have Win10 and 2 v-boxes
    1.PfSense with DHCP server, pointing pxe on second machine (FOG)
    2. CentOS with fog.

    On my laptop I can see FOG window to register device etc.

    Do you have any suggestions?
    Thank you for help

  • Moderator

    @Pyrol said in FOG Kernel update: "Preparing to move to tftp server":

    and the final step was to go into WebGui>fog settings>tftp server
    and here changed bzImage to bzImage.64 the same with bzImage32

    I would back up to this step. Replace the existing bzImage with the .64 bit one keeping it bzImage and the 32 bit image should be named bzImage32 (watch your case because it is important). Leave everything else FOG defaults. It will save you headaches in the future. Then pxe boot the client once you are on 5.6.18 it will see the network adapter.

    Then we can look back to why the update process is not working as it should. What version of FOG are you running?


  • @george1421
    I made it!

    So to sum up:
    I was unable to update kernel trough WebGui.
    I found subject where was a link to all kernels:

    https://forums.fogproject.org/topic/8439/kernel-download-missing-from-kernel-update-page/2

    https://fogproject.org/kernels/

    Then I downloaded newest version of kernel 64 an 32bit
    Kernel.TomElliott.5.6.18.32
    Kernel.TomElliott.5.6.18.64

    Next I renamed it to BzImage.64/32
    then placed it into “var/www/html/fog/service/ipxe”,
    and the final step was to go into WebGui>fog settings>tftp server
    and here changed bzImage to bzImage.64 the same with bzImage32

    I couldn’t find manual kernel update and it’s so easy (I only found on wiki script which downladed newest version of 4th kernel version).
    So there is my favor to you - if you could make some instructions for FAQ. It would be very helpful

    Thanks for help, especially for “/var/www/html/fog/service/ipxe” ;).

  • Moderator

    @Pyrol Its not clear why the webui update processes is failing. But in the case of your hardware you DO need the 5.6.18 kernel to see the network adapter. Since its a Dell don’t forget to set the disk mode to AHCI mode and not use RAID-ON. The system will function just fine in AHCI mode with no performance loss.


  • I tested it with old tp-link router, so I think it’s dumb 😉
    As you can see below, selinux is set premissive.
    Also what about permissions - set all to rwx or only specyfied files? (it’s only for my purposes.)VirtualBox_centos-fog_23_09_2020_15_31_57[1].png

    It’s DELL LATITUDE 5410 - I read the subject below (about the same device but I think that problem is different)

    So that happens when I make 5410 pxe boot
    IMG_20200923_154106.jpg

  • Senior Developer

    @Pyrol You also might want to share the PC/notebook type and model you have that has issues with getting an IP. Sometimes it’s model specific and updating the kernel to 5.6.18 might help. But it could also be related to spanning tree not setup correctly. To find out if this is the case you connect a really dumb (old) network switch between your PC/notebook and the other network switch and try PXE booting into a task again. Does it get an IP this time?

  • Moderator

    @Pyrol said in FOG Kernel update: "Preparing to move to tftp server":

    I’ve a problem with pxe boot not finding an interface.

    Well this issue may show up in two different places. If you get to the FOG iPXE menu then you are on the right track by upgrading the FOS Linux kernel to 5.6.18 or later.

    On point of your issue, if the FOG server doesn’t have create permissions on the fog web site (/var/www/html/fog) this issue might appear. Please do the following on the FOG server and post the results.

    cd /var/www/html/fog/service/ipxe
    ls -la
    

    Lets see what permissions are set on those files.

    Also did you set selinux to permissive? What is the results of this command?

    getenforce
    

291
Online

7.6k
Users

14.7k
Topics

138.3k
Posts