FOG Server image changed http port



  • I have running FOG server in a Docker container and changed the port from 80 to 5080 with docker.

    I get a virtual machine Boot from network but it hangs here:
    535cb894-0eb8-4eb0-803e-144cb6bd4414-image.png
    I Think its becouse the changed Port? as far as i see that he tries to go to http:ip/fog…boot.php
    but it must be http:ip:5080/fog…boot.php

    Or is the problem at another place? im new to this topic



  • i could register a machine and trying to make the image. no i get an mounting error for /bin/fog.upload but thats another topic 😄 try to find out what this problem is

    Thanks for your help 🙂


  • Moderator

    @wuast94 said in FOG Server image changed http port:

    ok i changed the WEB HOST and added the port

    This iPXE menu looks good. I just gave it a quick once over and didn’t find a problem with it.


  • Moderator

    @wuast94 said in FOG Server image changed http port:

    Is this file changed often?

    This file is changed each time you run the fog installer script. It is never changed unless you run the installer script so it should be good for now.



  • OK i changed the default.ipxe and now it boots.

    Is this file changed often?



  • changing the ipxe files is a bigger problem. its inside the docker container so it gets overwritten on update or rebuild. when this are files that never get updates it shouldn be a problem … but when this files get updates it isnt a good idea to change them manually, nether in docker or in a vm



  • ok i changed the WEB HOST and added the port.
    When i call the http in my browser i see all the http calls and there is all the right port so this looks fine to me

    #!ipxe
    set fog-ip 192.168.178.26:5080
    set fog-webroot fog
    set boot-url http://${fog-ip}/${fog-webroot}
    cpuid --ext 29 && set arch x86_64 || set arch i386
    goto get_console
    :console_set
    colour --rgb 0x00567a 1 ||
    colour --rgb 0x00567a 2 ||
    colour --rgb 0x00567a 4 ||
    cpair --foreground 7 --background 2 2 ||
    goto MENU
    :alt_console
    cpair --background 0 1 ||
    cpair --background 1 2 ||
    goto MENU
    :get_console
    console --picture http://192.168.178.26:5080/fog/service/ipxe/bg.png --left 100 --right 80 && goto console_set || goto alt_console
    :MENU
    menu
    colour --rgb 0xff0000 0 ||
    cpair --foreground 1 1 ||
    cpair --foreground 0 3 ||
    cpair --foreground 4 4 ||
    item --gap Host is NOT registered!
    item --gap -- -------------------------------------
    item fog.local Boot from hard disk
    item fog.memtest Run Memtest86+
    item fog.reginput Perform Full Host Registration and Inventory
    item fog.reg Quick Registration and Inventory
    item fog.deployimage Deploy Image
    item fog.multijoin Join Multicast Session
    item fog.sysinfo Client System Information (Compatibility)
    choose --default fog.local --timeout 3000 target && goto ${target}
    :fog.local
    sanboot --no-describe --drive 0x80 || goto MENU
    :fog.memtest
    kernel memdisk initrd=memtest.bin iso raw
    initrd memtest.bin
    boot || goto MENU
    :fog.reginput
    kernel bzImage32 loglevel=4 initrd=init_32.xz root=/dev/ram0 rw ramdisk_size=127000 web=http://192.168.178.26:5080/fog/ consoleblank=0 rootfstype=ext4 storage=192.168.178.26:/images/ storageip=192.168.178.26 loglevel=4 mode=manreg
    imgfetch init_32.xz
    boot || goto MENU
    :fog.reg
    kernel bzImage32 loglevel=4 initrd=init_32.xz root=/dev/ram0 rw ramdisk_size=127000 web=http://192.168.178.26:5080/fog/ consoleblank=0 rootfstype=ext4 storage=192.168.178.26:/images/ storageip=192.168.178.26 loglevel=4 mode=autoreg
    imgfetch init_32.xz
    boot || goto MENU
    :fog.deployimage
    login
    params
    param mac0 ${net0/mac}
    param arch ${arch}
    param username ${username}
    param password ${password}
    param qihost 1
    isset ${net1/mac} && param mac1 ${net1/mac} || goto bootme
    isset ${net2/mac} && param mac2 ${net2/mac} || goto bootme
    param sysuuid ${uuid}
    :fog.multijoin
    login
    params
    param mac0 ${net0/mac}
    param arch ${arch}
    param username ${username}
    param password ${password}
    param sessionJoin 1
    isset ${net1/mac} && param mac1 ${net1/mac} || goto bootme
    isset ${net2/mac} && param mac2 ${net2/mac} || goto bootme
    param sysuuid ${uuid}
    :fog.sysinfo
    kernel bzImage32 loglevel=4 initrd=init_32.xz root=/dev/ram0 rw ramdisk_size=127000 web=http://192.168.178.26:5080/fog/ consoleblank=0 rootfstype=ext4 storage=192.168.178.26:/images/ storageip=192.168.178.26 loglevel=4 mode=sysinfo
    imgfetch init_32.xz
    boot || goto MENU
    :bootme
    chain -ar http://192.168.178.26:5080/fog/service/ipxe/boot.php##params ||
    goto MENU
    autoboot
    

    but it still hangs on the same place 😕 and i dont the the port in my vm trying to boot the pxe


  • Moderator

    Ok looking at the Web UI for fog in the fog settings there may be two fields we can focus on .

    Web Host and Web Root

    I would first change the web host by appending :5080 onto the end of the IP address of the fog server. Then attempt to image. If something breaks during imaging like ftp trying to connect with the 5080 on the end then remove that from the web host field and change Web Root to :5080/fog/ and see where that gets you. You will still need to fix the default.ipxe file to put everything together.

    One last bit of debugging is you can look at the text behind the fog iPXE menu by calling that url directly with a web browser. http://<fog_server_ip>:5080:/fog/service/ipxe/boot.php?mac=00:00:00:00:00:00

    Make sure all of the calls in there to http:// also have the port number.


  • Moderator

    Well you can fix the pxe boot but the port 5080 is going to be a problem throughout. To fix your immediate issue you will need to edit the /tftpboot/default.ipxe file. Its just a simple text file so you can fix the call there.

    But you will have problems throughout.

    Look in the fog settings->fog configuration->expand all and see if there are any settings that use the IP address where you can tag :5080 on the end. Make sure they are only http calls.

    Let me look at my fog server to see what needs to be changed.


Log in to reply
 

357
Online

7.4k
Users

14.5k
Topics

136.6k
Posts