SOLVED cannot find disk on system (getHardDisk)


  • Hello,
    i’m using FOG 1.5.8

    Kernel:
    bzImage Version: 4.19.101
    bzImage32 Version: 4.19.101

    On a DELL Precision 3541 with windows 10 already installed.

    If i try different task (inventory, deploy, capture) i’ve got this error message:

    cannot find disk on system (getHardDisk)
    

    Here is information from the bios:

    SATA operation: RAID ON
    M.2 PCIe SSD-0 : 512 GB BTHP938501NK512C
    

    After a debug task, the lsblk command return nothing

    Does someone could help me to solve this problem ?
    Thank you

  • Moderator

    In uefi mode set the disk mode to ahci (or something just less than Raid ON). There is a known conflict between the linux kernel and the intel raid adapter in uefi mode. You can either leave the computer in this mode or change it after imaging and before the first boot of the target system OS.

  • Moderator

    @dejv said in cannot find disk on system (getHardDisk):

    we still need to change to ahci?

    Yes this is an Intel and Linux kernel developer issue. There is no resolution at this time.


  • was there a fix for this issue or we still need to change to ahci?


  • Thanks for your help!!
    it works !!

  • Moderator

    In uefi mode set the disk mode to ahci (or something just less than Raid ON). There is a known conflict between the linux kernel and the intel raid adapter in uefi mode. You can either leave the computer in this mode or change it after imaging and before the first boot of the target system OS.

322
Online

9.6k
Users

16.0k
Topics

148.0k
Posts