Cant boot on PXE



  • Hi guys,
    I start a fresh install of Fog on a ubuntu server 18.04.
    The server works. I can manage him, create image on him.
    But when i want to boot a computer on PXE for quick host registration or capture an image, the computer (a Lenovo thinkbook 15Ill) nothing hapen.
    At the left of the computer screen it’s write :
    "Start PXE over IPV4.
    Station IP address is -computer ip-
    Server ip address is -server address ip-
    NBP filename is undionly.kpxe
    NBP filesize is 99002 Bytes
    Downloading NBP file …

    NBP file downloaded successfully."

    And its all. The computer start windows normally after that and i can’t access to the Fog menu for quick registration.

    Can i have some help please ?
    I can’t find a solution for this problem.

    Thanls for your answer.
    PS : Sorry for my english it’s not my first language.
    Bye.


  • Moderator

    @T-thorel Ok you passed the dhcp issue and pxe boot issue. Now the issue is with the iPXE program that creates the FOG iPXE menu.

    Typically when we see this error it is because your building network switch is using Spanning Tree protocol but not one of the fast spanning tree protocols. A test for this can be to find a dumb/cheap/unmanaged switch and place it between the pxe booting computer and then building network switch. If the computer pxe boots correctly into the FOG iPXE menu then you will need to get with your networking/infrastructure group and have them enable one of the fast spanning tree protocols like portfast, RSTP, MSTP, fastSTP, or what ever your switch manufacturer calls it. This setting will need to be enabled on every user facing port where you need to pxe boot.

    The issue is that FOG boots too fast. It will give up trying before spanning tree starts forwarding data on the network interface (~27 seconds after the link light is turned on).



  • @george1421 Thanks a lot for your answer.
    Yes of course i m using my own DHCP server but that’s my mate who had put the settings into it.
    So i dont know where looking for these.
    But i find it i change the settings as you tell.
    Now i got a new error message : “IPXE initialising devices …ok”

    but hen it come to “Configuring (net0 -adressemac- …
    DHCP failed”

    But the dhcp server works because he said to the computer what server is needed for the PXE server.
    An idea ?


  • Moderator

    @T-thorel OK I think we are missing some basics here.

    When the target computer pxe boots it asks the dhcp server about the boot server ip and what boot file to use. If you did not set these at one time someone configured your dhcp server dhcp option 66 {next-server} and dhcp options 67 {boot-file} with the settings to boot from the fog server. I assume you are using your own dhcp server and not one built into the fog server.

    So you need to go to your dhcp server and change dhcp option 67 to ipxe.efi

    If your dhcp server is a windows 2012 or later or a linux dhcp server there are settings you can make to allow the dhcp server to dynamically switch between bios and uefi pxe booting computers. With static settings you can only boot one type of computers (bios or uefi) because they each take their own bootloader.

    For bios its undionly.kpxe and for uefi is ipxe.efi.



  • Hi @george1421

    I’m not sure to what i need to do.
    The PXE file in case is on the server DHCP ?
    I need to replace it by a file but where i can find it ?
    Tnaks for your help.


  • Moderator

    @T-thorel said in Cant boot on PXE:

    NBP filename is undionly.kpxe

    That is your problem. NBP (network boot file) refers to a UEFI system (its called something else for bios based computers). In this case you need to send ipxe.efi to the target computer.


Log in to reply
 

403
Online

7.4k
Users

14.5k
Topics

136.6k
Posts